public
Last active — forked from woodie/README.rdoc

  • Download Gist
README.rdoc
RDoc

Rails 3.0.pre on App Engine

You can Rails 3 on App Engine, but it won't be especially useful until bundler 10. You should try these instead:

Install the Development Environment

The gems for the development environment include a pre-release appengine-tools gem that provides a pre-release version of jruby-rack.

sudo gem install google-appengine

Install Rails 3.0.pre with required patches

Create a folder for your app

mkdir rails_app; cd rails_app

Download and run the setup script

curl -O http://appengine-jruby.googlecode.com/hg/demos/rails/rails_appengine.rb
ruby rails2_appengine.rb

Working with Your Rails App

Start development server

dev_appserver.rb .

Publish to production

appcfg.rb update .

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.