Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
ryan@desktop:~/workspace/citysdk$ node -v
v9.5.0
ryan@desktop:~/workspace/citysdk$ gulp -v
[17:52:03] CLI version 3.9.1
[17:52:03] Local version 3.9.1
ryan@desktop:~/workspace/citysdk$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
ryan@desktop:~/workspace/citysdk$ gulp
[17:42:44] Using gulpfile ~/workspace/citysdk/gulpfile.js
[17:42:44] Starting 'clean'...
[17:42:44] Finished 'clean' after 8.82 ms
[17:42:44] Starting 'compile:CitySdk'...
[17:42:44] Starting 'compile:CitySdkGeoRequest'...
[17:42:44] Starting 'compile:CitySdkTigerwebRequest'...
[17:42:44] Starting 'compile:CitySdkRequestValidator'...
[17:42:44] Starting 'compile:CitySdkRequestUtils'...
[17:42:44] Starting 'compile:CitySdkSummaryRequest'...
[17:42:44] Starting 'copy:resources'...
[17:42:44] Starting 'build:services'...
resolve failed: { Error: Cannot find module 'babel-runtime'
at Function.Module._resolveFilename (module.js:555:15)
at Function.requireRelative.resolve (/home/ryan/workspace/citysdk/node_modules/require-relative/index.js:30:17)
at resolve (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:25:26)
at findAndRemove (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:67:11)
at /home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:111:13
at Array.map (<anonymous>:null:null)
at loadPreset (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:103:29)
at module.exports (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/index.js:97:19)
at Object.<anonymous> (/home/ryan/workspace/citysdk/node_modules/babel-preset-es2015-rollup/index.js:3:18)
at Module._compile (module.js:660:30)
at Object.Module._extensions..js (module.js:671:10)
at Module.load (module.js:573:32)
at tryModuleLoad (module.js:513:12)
at Function.Module._load (module.js:505:3)
at Module.require (module.js:604:17)
at require (internal/module.js:11:18)
at /home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:296:17
at Array.map (<anonymous>:null:null)
at OptionManager.resolvePresets (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:275:20)
at OptionManager.mergePresets (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:264:10)
at OptionManager.mergeOptions (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:249:14)
at OptionManager.init (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:368:12)
at File.initOptions (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/index.js:212:65)
at new File (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/index.js:135:24)
at Pipeline.transform (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/pipeline.js:46:16)
at preflightCheck (/home/ryan/workspace/citysdk/node_modules/rollup-plugin-babel/dist/rollup-plugin-babel.cjs.js:44:25)
at transform$1 (/home/ryan/workspace/citysdk/node_modules/rollup-plugin-babel/dist/rollup-plugin-babel.cjs.js:117:18)
at /home/ryan/workspace/citysdk/node_modules/rollup/dist/rollup.js:7426:28
at tryCatch (/home/ryan/workspace/citysdk/node_modules/rollup/dist/rollup.js:395:12)
at invokeCallback (/home/ryan/workspace/citysdk/node_modules/rollup/dist/rollup.js:407:13)
at publish (/home/ryan/workspace/citysdk/node_modules/rollup/dist/rollup.js:378:7)
at flush (/home/ryan/workspace/citysdk/node_modules/rollup/dist/rollup.js:120:5)
at process._tickCallback (internal/process/next_tick.js:150:11)
at Function.Module.runMain (module.js:703:11)
at startup (bootstrap_node.js:190:16)
at bootstrap_node.js:662:3
code: 'MODULE_NOT_FOUND' } babel-runtime
resolve failed: { Error: Cannot find module '@types'
at Function.Module._resolveFilename (module.js:555:15)
at Function.requireRelative.resolve (/home/ryan/workspace/citysdk/node_modules/require-relative/index.js:30:17)
at resolve (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:25:26)
at findAndRemove (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:67:11)
at /home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:111:13
at Array.map (<anonymous>)
at loadPreset (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/lib/serialize.js:103:29)
at module.exports (/home/ryan/workspace/citysdk/node_modules/modify-babel-preset/index.js:97:19)
at Object.<anonymous> (/home/ryan/workspace/citysdk/node_modules/babel-preset-es2015-rollup/index.js:3:18)
at Module._compile (module.js:660:30)
at Object.Module._extensions..js (module.js:671:10)
at Module.load (module.js:573:32)
at tryModuleLoad (module.js:513:12)
at Function.Module._load (module.js:505:3)
at Module.require (module.js:604:17)
at require (internal/module.js:11:18)
at /home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:296:17
at Array.map (<anonymous>)
at OptionManager.resolvePresets (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:275:20)
at OptionManager.mergePresets (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:264:10)
at OptionManager.mergeOptions (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:249:14)
at OptionManager.init (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/options/option-manager.js:368:12)
at File.initOptions (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/index.js:212:65)
at new File (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/file/index.js:135:24)
at Pipeline.transform (/home/ryan/workspace/citysdk/node_modules/babel-core/lib/transformation/pipeline.js:46:16)
at preflightCheck (/home/ryan/workspace/citysdk/node_modules/rollup-plugin-babel/dist/rollup-plugin-babel.cjs.js:44:25)
at transform$1 (/home/ryan/workspace/citysdk/node_modules/rollup-plugin-babel/dist/rollup-plugin-babel.cjs.js:117:18)
at /home/ryan/workspace/citysdk/node_modules/rollup/src/utils/transform.js:18:28
at tryCatch (/home/ryan/workspace/citysdk/node_modules/rollup/node_modules/es6-promise/lib/es6-promise/-internal.js:187:12)
at invokeCallback (/home/ryan/workspace/citysdk/node_modules/rollup/node_modules/es6-promise/lib/es6-promise/-internal.js:199:13)
at publish (/home/ryan/workspace/citysdk/node_modules/rollup/node_modules/es6-promise/lib/es6-promise/-internal.js:170:7)
at flush (/home/ryan/workspace/citysdk/node_modules/rollup/node_modules/es6-promise/lib/es6-promise/asap.js:87:5)
at process._tickCallback (internal/process/next_tick.js:150:11)
at Function.Module.runMain (module.js:703:11)
at startup (bootstrap_node.js:190:16)
at bootstrap_node.js:662:3 code: 'MODULE_NOT_FOUND' } @types
Treating 'promise' as external dependency
Treating 'promise' as external dependency
Treating 'promise' as external dependency
Treating 'promise' as external dependency
Treating 'promise' as external dependency
Treating 'promise' as external dependency
Treating 'terraformer' as external dependency
Treating 'terraformer-arcgis-parser' as external dependency
Treating 'jquery' as external dependency
Treating 'terraformer' as external dependency
Treating 'terraformer' as external dependency
Treating 'terraformer' as external dependency
Treating 'terraformer-arcgis-parser' as external dependency
Treating 'terraformer-arcgis-parser' as external dependency
Treating 'terraformer-arcgis-parser' as external dependency
Treating 'terraformer' as external dependency
Treating 'terraformer-arcgis-parser' as external dependency
Treating 'jquery' as external dependency
Treating 'jquery' as external dependency
Treating 'terraformer' as external dependency
Treating 'terraformer-arcgis-parser' as external dependency
Treating 'jquery' as external dependency
Treating 'jquery' as external dependency
Treating 'jquery' as external dependency
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment