Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Postman install Ubuntu 18.04
#!/bin/bash
# Get postman app
wget https://dl.pstmn.io/download/latest/linux64 -O postman.tar.gz
sudo tar -xzf postman.tar.gz -C /opt
sudo ln -s /opt/Postman/Postman /usr/bin/postman
#Create a Desktop Entry
cat > ~/.local/share/applications/postman.desktop <<EOL
[Desktop Entry]
Encoding=UTF-8
Name=Postman
Exec=postman
Icon=/opt/Postman/app/resources/app/assets/icon.png
Terminal=false
Type=Application
Categories=Development;
EOL
@shakegioh
Copy link

shakegioh commented Jun 23, 2018

Thanks.

NOTE: do not execute this as root user, because it fails at creating desktop entry.

Instead run
sudo ./postman_install.sh

Loading

@iamnnort
Copy link

iamnnort commented Jul 14, 2018

Thanks!

Loading

@sebastianfrey
Copy link

sebastianfrey commented Aug 1, 2018

On my machine, only the following command did work:

sudo bash postman_install.sh

Loading

@AyzekUorren
Copy link

AyzekUorren commented Aug 16, 2018

sebastianfrey, Thanks it work for me.

Loading

@CancerToul
Copy link

CancerToul commented Aug 17, 2018

it doesn't work for me.
i have error:
vm@vm  /home  postman
ORM initialization successful
App events bus { name: 'booted', namespace: 'shared' }
App events bus { data:
{ adapterMethodName: 'find',
cause:
{ adapterMethodName: 'find',
modelIdentity: 'workspacesession',
name: 'AdapterError',
raw: [Object] },
isOperational: true,
modelIdentity: 'workspacesession',
raw:
{ _e: {},
_stack: 'OpenFailedError: UpgradeError Dexie specification of currently installed DB version is missing\n at Transaction.create (file:///opt/Postman/app/resources/app/js/vendor-shared.js:122645:31)\n at tempTransaction (file:///opt/Postman/app/resources/app/js/vendor-shared.js:121601:23)\n at Table.getTransaction (file:///opt/Postman/app/resources/app/js/vendor-shared.js:122097:17)\n at Table.getIDBObjectStore (file:///opt/Postman/app/resources/app/js/vendor-shared.js:122106:25)\n at Collection._read (file:///opt/Postman/app/resources/app/js/vendor-shared.js:123244:31)\n at Collection.each (file:///opt/Postman/app/resources/app/js/vendor-shared.js:123275:29)\n at Object.find (file:///opt/Postman/app/resources/app/js/vendor-shared.js:184466:10)\n at _getPopulatedRecords (file:///opt/Postman/app/resources/app/js/vendor-shared.js:111297:21)\n at helpFind (file:///opt/Postman/app/resources/app/js/vendor-shared.js:111734:6)\n at _afterPotentiallyRunningBeforeLC (file:///opt/Postman/app/resources/app/js/vendor-shared.js:178346:9)\n at maybeRunBeforeLC (file:///opt/Postman/app/resources/app/js/vendor-shared.js:178320:16)\n at Deferred..extend._WLModel [as _handleExec] (file:///opt/Postman/app/resources/app/js/vendor-shared.js:178322:9)\n at Deferred.exec (file:///opt/Postman/app/resources/app/js/vendor-shared.js:149703:10)\n at promisified (file:///opt/Postman/app/resources/app/js/vendor-shared.js:154507:16)\n at Deferred.toPromise (file:///opt/Postman/app/resources/app/js/vendor-shared.js:149989:19)\n at Deferred.then (file:///opt/Postman/app/resources/app/js/vendor-shared.js:149848:22)',
inner: [Object],
message: 'UpgradeError Dexie specification of currently installed DB version is missing',
name: 'OpenFailedError' } },
name: 'booted',
namespace: 'requester' }

Loading

@harryi3t
Copy link

harryi3t commented Sep 12, 2018

@posemon Can you update your gist to

  1. Use some other directory than /opt/, since we have seen people having permission issues in this location. Because there is no write permission, auto-updates does not work when installed in this directory. Here's the link to the issue that people are facing because of this postmanlabs/postman-app-support#5039
  2. Include the information that Postman now supports auto-updates, and people should be using that instead of manually updating the app

More details:
The problem with using the command sudo tar -xzf postman.tar.gz -C /opt is that it does not remove the old files, just put the new files over the old. Doing this might make the Postman end up in an inconsistent state leading issues which are very difficult to debug and fix

Here's a link to a similar popular gist file, which has been updated accordingly https://gist.github.com/aviskase/e642248c35e400b56e2489430952369f

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment