Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
testing result
hayden@t470s:~$ sudo apt-mark unhold ebtables
[sudo] password for hayden:
Canceled hold on ebtables.
hayden@t470s:~$ sudo nano /etc/apt/sources.list
hayden@t470s:~$ cat /etc/apt/sources.list
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu/ bionic-proposed main restricted
# deb-src http://archive.ubuntu.com/ubuntu/ bionic main restricted
## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://archive.ubuntu.com/ubuntu/ bionic-updates main restricted
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://archive.ubuntu.com/ubuntu/ bionic universe
deb http://archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://archive.ubuntu.com/ubuntu/ bionic-updates universe
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ bionic-updates multiverse
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner
deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security main restricted
deb http://security.ubuntu.com/ubuntu/ bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security universe
deb http://security.ubuntu.com/ubuntu/ bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security multiverse
hayden@t470s:~$ sudo nano /etc/apt/preferences.d/proposed-updates
hayden@t470s:~$ cat /etc/apt/preferences.d/proposed-updates
Package: *
Pin: release a=bionic-proposed
Pin-Priority: 400
hayden@t470s:~$ sudo apt-get upgrade -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
ebtables
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst ebtables [2.0.10.4-3.5ubuntu2] (2.0.10.4-3.5ubuntu2.18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf ebtables (2.0.10.4-3.5ubuntu2.18.04.1 Ubuntu:18.04/bionic-updates [amd64])
hayden@t470s:~$ sudo apt -t bionic-proposed install ebtables
Reading package lists... Done
E: The value 'bionic-proposed' is invalid for APT::Default-Release as such a release is not available in the sources
hayden@t470s:~$ sudo apt update
Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-proposed InRelease [242 kB]
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
ebtables
1 upgraded, 0 newly installed, 0 to remove and 21 not upgraded.
Need to get 79.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 ebtables amd64 2.0.10.4-3.5ubuntu2.18.04.1 [79.9 kB]
Fetched 79.9 kB in 1s (128 kB/s)
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb ...
invoke-rc.d: could not determine current runlevel
* Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: old ebtables package pre-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
invoke-rc.d: could not determine current runlevel
* Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: error processing archive /var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb (--unpack):
new ebtables package pre-removal script subprocess returned error exit status 1
dmesg: read kernel buffer failed: Function not implemented
update-rc.d: warning: start and stop actions are no longer sup
ported; falling back to defaults
invoke-rc.d: could not determine current runlevel
Errors were encountered while processing:
/var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
hayden@t470s:~$ sudo apt-get upgrade -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
apt apt-utils ebtables libapt-inst2.0 libapt-pkg5.0 libnss-systemd libpam-systemd libpython3-stdlib libsystemd0
libudev1 networkd-dispatcher python3 python3-minimal systemd systemd-sysv udev unattended-upgrades
update-notifier-common
18 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 6958 kB/7038 kB of archives.
After this operation, 14.3 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libudev1 amd64 237-3ubuntu10.1 [53.5 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 udev amd64 237-3ubuntu10.1 [1100 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libnss-systemd amd64 237-3ubuntu10.1 [105 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libpam-systemd amd64 237-3ubuntu10.1 [108 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 systemd amd64 237-3ubuntu10.1 [2893 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libsystemd0 amd64 237-3ubuntu10.1 [204 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 systemd-sysv amd64 237-3ubuntu10.1 [11.4 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libapt-pkg5.0 amd64 1.6.2 [801 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libapt-inst2.0 amd64 1.6.2 [55.5 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 apt amd64 1.6.2 [1166 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 apt-utils amd64 1.6.2 [208 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 python3-minimal amd64 3.6.5-3ubuntu1 [23.7 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 python3 amd64 3.6.5-3ubuntu1 [10.2 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libpython3-stdlib amd64 3.6.5-3ubuntu1 [7204 B]
Get:15 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 update-notifier-common all 3.192.1.1 [161 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 networkd-dispatcher all 1.7-0ubuntu3.2 [12.8 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 unattended-upgrades all 1.1ubuntu1.18.04.1 [39.0 kB]
Fetched 6958 kB in 14s (504 kB/s)
Preconfiguring packages ...
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../libudev1_237-3ubuntu10.1_amd64.deb ...
Unpacking libudev1:amd64 (237-3ubuntu10.1) over (237-3ubuntu10) ...
Setting up libudev1:amd64 (237-3ubuntu10.1) ...
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../udev_237-3ubuntu10.1_amd64.deb ...
Unpacking udev (237-3ubuntu10.1) over (237-3ubuntu10) ...
Preparing to unpack .../libnss-systemd_237-3ubuntu10.1_amd64.deb ...
Unpacking libnss-systemd:amd64 (237-3ubuntu10.1) over (237-3ubuntu10) ...
Preparing to unpack .../libpam-systemd_237-3ubuntu10.1_amd64.deb ...
Unpacking libpam-systemd:amd64 (237-3ubuntu10.1) over (237-3ubuntu10) ...
Preparing to unpack .../systemd_237-3ubuntu10.1_amd64.deb ...
Unpacking systemd (237-3ubuntu10.1) over (237-3ubuntu10) ...
Preparing to unpack .../libsystemd0_237-3ubuntu10.1_amd64.deb ...
Unpacking libsystemd0:amd64 (237-3ubuntu10.1) over (237-3ubuntu10) ...
Setting up libsystemd0:amd64 (237-3ubuntu10.1) ...
Setting up systemd (237-3ubuntu10.1) ...
Initializing machine ID from random generator.
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../systemd-sysv_237-3ubuntu10.1_amd64.deb ...
Unpacking systemd-sysv (237-3ubuntu10.1) over (237-3ubuntu10) ...
Preparing to unpack .../libapt-pkg5.0_1.6.2_amd64.deb ...
Unpacking libapt-pkg5.0:amd64 (1.6.2) over (1.6.1) ...
Setting up libapt-pkg5.0:amd64 (1.6.2) ...
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../libapt-inst2.0_1.6.2_amd64.deb ...
Unpacking libapt-inst2.0:amd64 (1.6.2) over (1.6.1) ...
Preparing to unpack .../archives/apt_1.6.2_amd64.deb ...
Unpacking apt (1.6.2) over (1.6.1) ...
Setting up apt (1.6.2) ...
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../apt-utils_1.6.2_amd64.deb ...
Unpacking apt-utils (1.6.2) over (1.6.1) ...
Preparing to unpack .../python3-minimal_3.6.5-3ubuntu1_amd64.deb ...
Unpacking python3-minimal (3.6.5-3ubuntu1) over (3.6.5-3) ...
Setting up python3-minimal (3.6.5-3ubuntu1) ...
(Reading database ... 28475 files and directories currently installed.)
Preparing to unpack .../0-python3_3.6.5-3ubuntu1_amd64.deb ...
running python pre-rtupdate hooks for python3.6...
Unpacking python3 (3.6.5-3ubuntu1) over (3.6.5-3) ...
Preparing to unpack .../1-libpython3-stdlib_3.6.5-3ubuntu1_amd64.deb ...
Unpacking libpython3-stdlib:amd64 (3.6.5-3ubuntu1) over (3.6.5-3) ...
Preparing to unpack .../2-update-notifier-common_3.192.1.1_all.deb ...
Unpacking update-notifier-common (3.192.1.1) over (3.192.1) ...
Preparing to unpack .../3-networkd-dispatcher_1.7-0ubuntu3.2_all.deb ...
Unpacking networkd-dispatcher (1.7-0ubuntu3.2) over (1.7-0ubuntu3) ...
Preparing to unpack .../4-ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb ...
invoke-rc.d: could not determine current runlevel
* Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: old ebtables package pre-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
invoke-rc.d: could not determine current runlevel
* Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: error processing archive /tmp/apt-dpkg-install-iKmQqw/4-ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb (--unpack):
new ebtables package pre-removal script subprocess returned error exit status 1
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
Preparing to unpack .../5-unattended-upgrades_1.1ubuntu1.18.04.1_all.deb ...
Unpacking unattended-upgrades (1.1ubuntu1.18.04.1) over (1.1ubuntu1) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.