Skip to content

Embed URL

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
telemachus ~ ❯❯ gem uninstall minitest wirble
You have requested to uninstall the gem:
minitest-2.3.1
minitest-2.3.1 depends on [minitest (>= 2.3.0)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn] Y
Successfully uninstalled minitest-2.3.1
ERROR: While executing gem ... (Gem::InstallError)
cannot uninstall, check `gem list -d wirble`
telemachus ~ ❯❯ gem uninstall irb_rocket wirble
Successfully uninstalled irb_rocket-0.2.0
ERROR: While executing gem ... (Gem::InstallError)
cannot uninstall, check `gem list -d wirble`
@mattdipasquale

I get this error too for gem -v 1.8.5

@telemachus
Owner

@mattdipasquale I spoke with drbrain about this. The problem for me was related to where the different gems were installed. You can manually handle it with gem uninstall -i /path/to/gem/hard/to/remove , but he also proposed adding gem uninstall -f gem which would handle it no matter what. See here for a bit more: rubygems/rubygems#136

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.