Skip to content

Instantly share code, notes, and snippets.

@thesamesam
Last active Jun 21, 2021
Embed
What would you like to do?
Portage failure with world upgrade for libxcrypt migration
$ emerge -pv1 '>=virtual/libcrypt-2' --autounmask=n --usepkg=n
python-exec: Invalid impl in /etc/python-exec/python-exec.conf: python3.7

 * IMPORTANT: config file '/etc/portage/savedconfig/sys-apps/busybox-1.32.1' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] sys-libs/glibc-2.33-r1:2.2::gentoo [2.33:2.2::gentoo] USE="multiarch ssp (static-libs) (-audit) -caps (-cet) -compile-locales -crypt* -custom-cflags -doc -gd -headers-only (-multilib) -multilib-bootstrap -nscd -profile (-selinux) (-static-pie) -suid -systemtap -test (-vanilla)" 0 KiB
[ebuild  N    ~] sys-libs/libxcrypt-4.4.20:0/1::gentoo  USE="compat static-libs system (-split-usr) -test" 0 KiB
[ebuild  r  U #] virtual/libcrypt-2:0/2::gentoo [1-r1:0/1::gentoo] USE="static-libs (-abi_riscv_lp64%) (-abi_riscv_lp64d%)" 0 KiB
[ebuild  rR    ] sys-libs/pam-1.5.1::gentoo  USE="berkdb filecaps (split-usr) (-audit) -debug -nis (-selinux)" 0 KiB
[ebuild  rR    ] sys-apps/busybox-1.32.1-r1::gentoo  USE="ipv6 static -debug -livecd -make-symlinks -math -mdev -pam -savedconfig (-selinux) -sep-usr -syslog -systemd" 0 KiB
[ebuild  rR    ] sys-apps/util-linux-2.36.2::gentoo  USE="cramfs logger ncurses nls pam readline (split-usr) suid (unicode) (-audit) -build -caps -cryptsetup -fdformat -hardlink -kill -magic% -python (-selinux) -slang -static-libs -su -systemd -test -tty-helpers -udev" PYTHON_TARGETS="python3_8 python3_9 (-python3_7%)" 0 KiB
[ebuild  rR    ] sys-apps/shadow-4.8.1-r3::gentoo  USE="acl nls pam (split-usr) su xattr (-audit) -bcrypt -cracklib (-selinux) -skey" 0 KiB
[ebuild  rR    ] dev-lang/python-3.9.5_p2:3.9::gentoo  USE="gdbm hardened ipv6 ncurses readline sqlite ssl xml -bluetooth -build -examples -test -tk -verify-sig -wininst" 0 KiB
[ebuild  rR    ] dev-lang/python-3.8.10_p2:3.8::gentoo  USE="gdbm hardened ipv6 ncurses readline sqlite ssl xml -bluetooth -build -examples -test -tk -verify-sig -wininst" 0 KiB
[ebuild  r  U  ] net-misc/openssh-8.6_p1-r2::gentoo [8.6_p1-r1::gentoo] USE="pam pie scp ssl -X -X509 (-audit) -bindist (-debug) -hpn -kerberos -ldns -libedit -livecd -sctp (-security-key) (-selinux) -static -test -xmss" 0 KiB
[ebuild  rR    ] dev-lang/perl-5.32.1:0/5.32::gentoo  USE="berkdb gdbm -debug -doc -ithreads -minimal" 0 KiB

Total: 11 packages (3 upgrades, 1 new, 7 reinstalls), Size of downloads: 0 KiB

The following packages are causing rebuilds:

  (virtual/libcrypt-2:0/2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (sys-apps/shadow-4.8.1-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-lang/perl-5.32.1:0/5.32::gentoo, ebuild scheduled for merge)
    (sys-apps/util-linux-2.36.2:0/0::gentoo, ebuild scheduled for merge)
    (dev-lang/python-3.8.10_p2:3.8/3.8::gentoo, ebuild scheduled for merge)
    (dev-lang/python-3.9.5_p2:3.9/3.9::gentoo, ebuild scheduled for merge)
    (sys-libs/pam-1.5.1:0/0::gentoo, ebuild scheduled for merge)
    (sys-apps/busybox-1.32.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (net-misc/openssh-8.6_p1-r2:0/0::gentoo, ebuild scheduled for merge)
$ emerge -a -uvDU @world --autounmask=n
python-exec: Invalid impl in /etc/python-exec/python-exec.conf: python3.7

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following binary packages have been ignored due to non matching USE:

    =sys-apps/util-linux-2.36.2 udev
    =sys-devel/gdb-10.1 python_single_target_python3_8 -python_single_target_python3_9
    =dev-lang/perl-5.32.1 ithreads
    =sys-libs/zlib-1.2.11-r4 minizip static-libs
    =sys-libs/zlib-1.2.11-r4 minizip
    =sys-libs/zlib-1.2.11-r4 static-libs
    =dev-libs/openssl-1.1.1k static-libs
    =app-crypt/gnupg-2.2.27 usb
    =net-libs/gnutls-3.7.1 pkcs11
    =sys-apps/dbus-1.12.20-r1 X user-session
    =sys-auth/polkit-0.118 gtk
    =x11-libs/gtk+-3.24.29 -X wayland
    =media-libs/harfbuzz-2.8.1 icu
    =x11-libs/cairo-1.16.0-r4 opengl
    =media-libs/freetype-2.10.4 X
    =media-libs/libpng-1.6.37-r2 apng
    =app-arch/zstd-1.4.9 static-libs
    =sys-libs/glibc-2.33-r1 crypt

NOTE: The --binpkg-respect-use=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-respect-use=y will silence this warning.

!!! The following binary packages have been ignored due to changed dependencies:

     dev-python/urllib3-1.26.4::gentoo
     sys-devel/llvm-10.0.1::gentoo
     sys-apps/portage-3.0.18::gentoo
     sys-apps/portage-3.0.18::gentoo
     dev-python/snakeoil-0.9.6::gentoo

NOTE: The --binpkg-changed-deps=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-changed-deps=y will silence this warning.

emerge: there are no ebuilds built with USE flags to satisfy "sys-libs/glibc[crypt(+),static-libs(+)?]".
!!! One of the following packages is required to complete your request:
- sys-libs/glibc-2.33-r1::gentoo (Change USE: +crypt)
(dependency required by "virtual/libcrypt-1-r1::gentoo" [installed])
(dependency required by "sys-apps/busybox-1.32.1-r1::gentoo" [installed])
(dependency required by "@system" [set])
(dependency required by "@world" [argument])
$ emerge -a -uvDU @world
python-exec: Invalid impl in /etc/python-exec/python-exec.conf: python3.7

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] sys-libs/glibc-2.33-r1:2.2::gentoo [2.33:2.2::gentoo] USE="crypt multiarch ssp (static-libs) (-audit) -caps (-cet) -compile-locales -custom-cflags -doc -gd -headers-only (-multilib) -multilib-bootstrap -nscd -profile (-selinux) (-static-pie) -suid -systemtap -test (-vanilla)" 0 KiB
[ebuild     U  ] sys-devel/llvm-common-12.0.0::gentoo [11.1.0::gentoo] 0 KiB
[ebuild     U  ] net-libs/nghttp2-1.41.0-r2:0/1.14::gentoo [1.41.0:0/1.14::gentoo] USE="threads -cxx -debug -hpack-tools -jemalloc -static-libs -test -utils -xml (-libressl%)" 0 KiB
[ebuild     U  ] net-libs/libtirpc-1.3.2:0/3::gentoo [1.3.1:0/3::gentoo] USE="ipv6 (split-usr) -kerberos -static-libs" 0 KiB
[binary     U ~] app-misc/pax-utils-1.3.2-1::gentoo [1.3.1::gentoo] USE="seccomp -caps -debug -python" PYTHON_SINGLE_TARGET="python3_9 -python3_8" 0 KiB
[ebuild     U  ] sys-apps/sandbox-2.24::gentoo [2.23::gentoo] 0 KiB
[binary     U ~] sys-devel/gcc-11.1.0-r1-1:11::gentoo [11.1.0:11::gentoo] USE="(cxx) fortran hardened nls nptl openmp pch (pie) sanitize ssp (-ada) -custom-cflags -d -debug -doc (-fixed-point) -go -graphite -jit (-libssp) -lto (-multilib) -objc -objc++ -objc-gc -pgo -systemtap -test -valgrind -vanilla -vtv -zstd" 0 KiB
[ebuild     U  ] dev-util/source-highlight-3.1.9-r1::gentoo [3.1.9::gentoo] USE="-doc -static-libs" 0 KiB
[binary     U  ] dev-python/pygments-2.9.0-5::gentoo [2.8.1::gentoo] USE="-doc -test" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) (-python3_10) (-python3_7%)" 0 KiB
[ebuild     U  ] sys-kernel/installkernel-gentoo-3::gentoo [2::gentoo] 0 KiB
[ebuild     U  ] dev-python/markupsafe-2.0.1::gentoo [1.1.1-r1::gentoo] USE="-test" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) (-python3_10) (-python3_7%)" 0 KiB
[ebuild     U  ] dev-python/click-8.0.1::gentoo [7.1.2-r1::gentoo] USE="-doc -examples -test" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) (-python3_10) (-python3_7%)" 0 KiB
[binary     U  ] dev-python/six-1.16.0-4::gentoo [1.15.0-r1::gentoo] USE="-doc -test" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) (-python3_10) (-python3_7%)" 0 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.12-r3:2::gentoo [2.9.12-r2:2::gentoo] USE="ipv6 python readline -debug -examples -icu -lzma -static-libs -test -verify-sig" PYTHON_TARGETS="python3_8 python3_9" 0 KiB
[ebuild     U  ] net-misc/curl-7.77.0-r1::gentoo [7.77.0::gentoo] USE="ftp http2 imap ipv6 openssl pop3 progress-meter smtp ssl tftp -adns -alt-svc -brotli -gnutls -gopher -hsts -idn -kerberos -ldap -mbedtls -metalink (-nghttp3) -nss (-quiche) -rtmp -samba -ssh -sslv3 -static-libs -telnet -test -threads (-winssl) -zstd" CURL_SSL="openssl -gnutls -mbedtls -nss (-winssl)" 0 KiB
[ebuild     U  ] net-misc/openssh-8.6_p1-r2::gentoo [8.6_p1-r1::gentoo] USE="pam pie scp ssl -X -X509 (-audit) -bindist (-debug) -hpn -kerberos -ldns -libedit -livecd -sctp (-security-key) (-selinux) -static -test -xmss" 0 KiB
[ebuild     U  ] dev-libs/elfutils-0.184::gentoo [0.183::gentoo] USE="bzip2 nls utils -lzma -static-libs -test (-threads) -valgrind -zstd" 0 KiB
[ebuild     U  ] dev-libs/libgpg-error-1.42::gentoo [1.41::gentoo] USE="nls -common-lisp -static-libs" 0 KiB
[binary     U ~] sys-devel/gcc-10.3.0-r1-1:10::gentoo [10.3.0:10::gentoo] USE="(cxx) fortran hardened nls nptl openmp pch (pie) sanitize ssp (-ada) -d -debug -doc (-fixed-point) -go -graphite -jit (-libssp) -lto (-multilib) -objc -objc++ -objc-gc -pgo -systemtap -test -vanilla -vtv -zstd" 0 KiB
[ebuild     U  ] dev-libs/libassuan-2.5.5::gentoo [2.5.4::gentoo] 0 KiB
[ebuild     U  ] dev-libs/libksba-1.5.1::gentoo [1.5.0::gentoo] USE="-static-libs" 0 KiB
[ebuild  NS    ] sys-devel/llvm-12.0.0:12::gentoo [11.1.0:11::gentoo] USE="libffi ncurses -debug -doc -exegesis -gold -libedit -test -xar -xml -z3" LLVM_TARGETS="(ARM) BPF -AArch64 -AMDGPU -ARC -AVR (-CSKY) -Hexagon -Lanai -MSP430 -Mips -NVPTX -PowerPC -RISCV -Sparc -SystemZ -VE -WebAssembly -X86 -XCore" 0 KiB
[ebuild   R    ] sys-devel/gdb-10.1::gentoo  USE="nls python server source-highlight (-cet) -lzma -multitarget -test -vanilla -xml -xxhash" PYTHON_SINGLE_TARGET="python3_9* (-python3_10) -python3_8* (-python3_7%)" 0 KiB
[ebuild     U  ] sys-apps/pkgcore-0.12.1-r1::gentoo [0.11.6-r1::gentoo] USE="-test" PYTHON_TARGETS="python3_8 python3_9 (-python3_10)" 0 KiB
[ebuild     U  ] dev-util/pkgcheck-0.10.1::gentoo [0.9.7-r2::gentoo] USE="-test" PYTHON_TARGETS="python3_8 python3_9 (-python3_10)" 0 KiB
[ebuild     U  ] dev-libs/glib-2.68.2-r1:2::gentoo [2.68.2:2::gentoo] USE="dbus elf mime xattr -debug -fam -gtk-doc (-selinux) -static-libs (-sysprof) -systemtap -test -utils" 0 KiB
[ebuild     U  ] x11-libs/pango-1.48.5-r1::gentoo [1.48.5::gentoo] USE="introspection -X -gtk-doc (-sysprof) -test" 0 KiB
[ebuild     U  ] app-crypt/gpgme-1.15.1:1/11::gentoo [1.14.0:1/11::gentoo] USE="cxx -common-lisp -python -qt5 -static-libs" PYTHON_TARGETS="python3_8 python3_9" 0 KiB

Total: 28 packages (26 upgrades, 1 in new slot, 1 reinstall, 5 binaries), Size of downloads: 0 KiB

!!! The following binary packages have been ignored due to non matching USE:

    =sys-apps/util-linux-2.36.2 udev
    =sys-devel/gdb-10.1 python_single_target_python3_8 -python_single_target_python3_9
    =dev-lang/perl-5.32.1 ithreads
    =sys-libs/zlib-1.2.11-r4 minizip static-libs
    =sys-libs/zlib-1.2.11-r4 minizip
    =sys-libs/zlib-1.2.11-r4 static-libs
    =dev-libs/openssl-1.1.1k static-libs
    =app-crypt/gnupg-2.2.27 usb
    =net-libs/gnutls-3.7.1 pkcs11
    =sys-apps/dbus-1.12.20-r1 X user-session
    =sys-auth/polkit-0.118 gtk
    =x11-libs/gtk+-3.24.29 -X wayland
    =media-libs/harfbuzz-2.8.1 icu
    =x11-libs/cairo-1.16.0-r4 opengl
    =media-libs/freetype-2.10.4 X
    =media-libs/libpng-1.6.37-r2 apng
    =app-arch/zstd-1.4.9 static-libs
    =sys-libs/glibc-2.33-r1 crypt
    =app-editors/vim-8.2.0814-r100 -ipv6 python_single_target_python3_8 -python_single_target_python3_9

NOTE: The --binpkg-respect-use=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-respect-use=y will silence this warning.

!!! The following binary packages have been ignored due to changed dependencies:

     dev-python/urllib3-1.26.4::gentoo
     sys-devel/llvm-10.0.1::gentoo
     sys-apps/portage-3.0.18::gentoo
     sys-apps/portage-3.0.18::gentoo
     dev-python/snakeoil-0.9.6::gentoo

NOTE: The --binpkg-changed-deps=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-changed-deps=y will silence this warning.

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by virtual/libcrypt-1-r1::gentoo
# required by net-misc/openssh-8.6_p1-r2::gentoo[-static]
# required by virtual/ssh-0::gentoo[-minimal]
# required by @system
# required by @world (argument)
>=sys-libs/glibc-2.33-r1 crypt
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment