Instantly share code, notes, and snippets.

Embed
What would you like to do?
RPM Packages available in AWS Lambda
## This is a list of RPM packages available on AWS Lambda, Node.js 6.10 runtime, 05 November 2017
## See https://github.com/claudiajs/lambda-vm-info for how this list was generated and to get an updated version
Installed Packages
ImageMagick.x86_64 6.7.8.9-15.21.amzn1 @amzn-main
alsa-lib.x86_64 1.0.22-3.9.amzn1 @amzn-main
audit-libs.x86_64 2.6.5-3.28.amzn1 @ami
avahi-libs.x86_64 0.6.25-12.17.amzn1 @amzn-main
basesystem.noarch 10.0-4.9.amzn1 @ami
bash.x86_64 4.2.46-28.37.amzn1 @amzn-updates
binutils.x86_64 2.23.52.0.1-55.65.amzn1 @ami
bzip2.x86_64 1.0.6-8.12.amzn1 @ami
bzip2-libs.x86_64 1.0.6-8.12.amzn1 @ami
ca-certificates.noarch 2015.2.6-65.0.1.16.amzn1 @amzn-main
cairo.x86_64 1.12.14-6.8.amzn1 @amzn-main
chkconfig.x86_64 1.3.49.3-2.14.amzn1 @ami
compat-gmp4.x86_64 4.3.2-1.14.amzn1 @amzn-main
copy-jdk-configs.noarch 1.2-1.2.amzn1 @amzn-main
coreutils.x86_64 8.22-15.52.amzn1 @ami
cpio.x86_64 2.10-12.12.amzn1 @ami
cracklib.x86_64 2.8.16-4.14.amzn1 @amzn-main
cracklib-dicts.x86_64 2.8.16-4.14.amzn1 @amzn-main
cups-libs.x86_64 1:1.4.2-67.21.amzn1 @amzn-main
curl.x86_64 7.51.0-9.75.amzn1 @amzn-updates
cyrus-sasl-lib.x86_64 2.1.23-13.16.amzn1 @ami
dash.x86_64 0.5.5.1-4.5.amzn1 @amzn-main
db4.x86_64 4.7.25-18.11.amzn1 @ami
db4-utils.x86_64 4.7.25-18.11.amzn1 @ami
dbus-libs.x86_64 1:1.6.12-14.28.amzn1 @amzn-main
dejavu-fonts-common.noarch 2.33-6.6.amzn1 @amzn-main
dejavu-sans-fonts.noarch 2.33-6.6.amzn1 @amzn-main
dejavu-serif-fonts.noarch 2.33-6.6.amzn1 @amzn-main
diffutils.x86_64 3.3-4.15.amzn1 @ami
dracut.noarch 004-409.31.amzn1 @amzn-main
elfutils.x86_64 0.163-3.18.amzn1 @ami
elfutils-libelf.x86_64 0.163-3.18.amzn1 @ami
elfutils-libs.x86_64 0.163-3.18.amzn1 @ami
epel-release.noarch 6-8.9.amzn1 @amzn-main
ethtool.x86_64 2:3.15-2.27.amzn1 @amzn-main
expat.x86_64 2.1.0-10.21.amzn1 @ami
file.x86_64 5.22-4.31.amzn1 @ami
file-libs.x86_64 5.22-4.31.amzn1 @ami
filesystem.x86_64 2.4.30-3.8.amzn1 @ami
findutils.x86_64 1:4.4.2-6.9.amzn1 @ami
fontconfig.x86_64 2.8.0-5.8.amzn1 @amzn-main
fontpackages-filesystem.noarch 1.41-1.1.2.amzn1 @amzn-main
freetype.x86_64 2.3.11-15.14.amzn1 @amzn-main
gawk.x86_64 3.1.7-10.10.amzn1 @ami
gdb.x86_64 7.6.1-64.33.amzn1 @ami
gdbm.x86_64 1.8.0-36.6.amzn1 @ami
ghostscript.x86_64 8.70-23.25.amzn1 @amzn-updates
ghostscript-fonts.noarch 5.50-23.2.7.amzn1 @amzn-main
giflib.x86_64 4.1.6-3.1.6.amzn1 @amzn-main
glib2.x86_64 2.36.3-5.18.amzn1 @ami
glibc.x86_64 2.17-196.172.amzn1 @amzn-updates
glibc-common.x86_64 2.17-196.172.amzn1 @amzn-updates
gmp.x86_64 6.0.0-11.16.amzn1 @ami
gnupg2.x86_64 2.0.28-1.30.amzn1 @ami
gnutls.x86_64 2.12.23-21.18.amzn1 @amzn-updates
gpgme.x86_64 1.4.3-5.15.amzn1 @ami
grep.x86_64 2.20-2.17.amzn1 @ami
groff-base.x86_64 1.22.2-8.11.amzn1 @ami
grubby.x86_64 7.0.15-5.7.amzn1 @amzn-main
gzip.x86_64 1.5-8.18.amzn1 @ami
hwdata.noarch 0.233-14.1.18.amzn1 @amzn-main
info.x86_64 5.1-4.10.amzn1 @ami
initscripts.x86_64 9.03.49-1.35.amzn1 @amzn-main
iproute.x86_64 4.4.0-3.23.amzn1 @amzn-main
iptables.x86_64 1.4.18-1.22.amzn1 @amzn-main
iputils.x86_64 20121221-7.13.amzn1 @amzn-main
jasper-libs.x86_64 1.900.1-21.9.amzn1 @amzn-updates
java-1.7.0-openjdk.x86_64 1:1.7.0.151-2.6.11.0.74.amzn1 @amzn-updates
java-1.8.0-openjdk.x86_64 1:1.8.0.141-1.b16.32.amzn1 @amzn-updates
java-1.8.0-openjdk-headless.x86_64 1:1.8.0.141-1.b16.32.amzn1 @amzn-updates
javapackages-tools.noarch 0.9.1-1.5.amzn1 @amzn-main
jbigkit-libs.x86_64 2.0-11.4.amzn1 @amzn-main
jpackage-utils.noarch 1.7.5-27.17.amzn1 @amzn-main
kbd.x86_64 1.15-11.4.amzn1 @amzn-main
kbd-misc.noarch 1.15-11.4.amzn1 @amzn-main
kernel.x86_64 4.9.43-17.39.amzn1 @amzn-updates
keyutils-libs.x86_64 1.5.8-3.12.amzn1 @ami
kmod.x86_64 14-10.10.amzn1 @amzn-main
kmod-libs.x86_64 14-10.10.amzn1 @amzn-main
krb5-libs.x86_64 1.14.1-27.41.amzn1 @ami
lcms2.x86_64 2.6-2.5.amzn1 @amzn-main
libICE.x86_64 1.0.6-1.4.amzn1 @amzn-main
libSM.x86_64 1.2.1-2.6.amzn1 @amzn-main
libX11.x86_64 1.6.0-2.2.12.amzn1 @amzn-main
libX11-common.x86_64 1.6.0-2.2.12.amzn1 @amzn-main
libXau.x86_64 1.0.6-4.9.amzn1 @amzn-main
libXcomposite.x86_64 0.4.3-4.6.amzn1 @amzn-main
libXdamage.x86_64 1.1.3-4.7.amzn1 @amzn-main
libXext.x86_64 1.3.2-2.1.10.amzn1 @amzn-main
libXfixes.x86_64 5.0.1-2.1.8.amzn1 @amzn-main
libXfont.x86_64 1.4.5-5.12.amzn1 @amzn-main
libXi.x86_64 1.7.2-2.2.9.amzn1 @amzn-main
libXrender.x86_64 0.9.8-2.1.9.amzn1 @amzn-main
libXt.x86_64 1.1.4-6.1.9.amzn1 @amzn-main
libXtst.x86_64 1.2.2-2.1.9.amzn1 @amzn-main
libXxf86vm.x86_64 1.1.3-2.1.9.amzn1 @amzn-main
libacl.x86_64 2.2.49-6.11.amzn1 @ami
libassuan.x86_64 2.0.3-3.3.amzn1 @ami
libattr.x86_64 2.4.46-12.10.amzn1 @ami
libblkid.x86_64 2.23.2-33.28.amzn1 @amzn-updates
libcap.x86_64 2.16-5.5.8.amzn1 @ami
libcap-ng.x86_64 0.7.5-4.15.amzn1 @ami
libcom_err.x86_64 1.42.12-4.40.amzn1 @ami
libcurl.x86_64 7.51.0-9.75.amzn1 @amzn-updates
libdrm.x86_64 2.4.52-4.12.amzn1 @amzn-main
libffi.x86_64 3.0.13-16.5.amzn1 @ami
libfontenc.x86_64 1.0.5-2.6.amzn1 @amzn-main
libgcc48.x86_64 4.8.3-9.111.amzn1 @ami
libgcrypt.x86_64 1.5.3-12.19.amzn1 @ami
libgomp.x86_64 4.8.3-9.111.amzn1 @amzn-main
libgpg-error.x86_64 1.11-1.12.amzn1 @ami
libicu.x86_64 50.1.2-11.12.amzn1 @ami
libidn.x86_64 1.18-2.8.amzn1 @amzn-main
libidn2.x86_64 0.16-1.2.amzn1 @ami
libjpeg-turbo.x86_64 1.2.90-5.14.amzn1 @amzn-main
libmount.x86_64 2.23.2-33.28.amzn1 @amzn-updates
libnih.x86_64 1.0.1-7.8.amzn1 @amzn-main
libpciaccess.x86_64 0.13.1-4.1.11.amzn1 @amzn-main
libpng.x86_64 2:1.2.49-2.14.amzn1 @amzn-main
libpsl.x86_64 0.6.2-1.2.amzn1 @ami
libpwquality.x86_64 1.2.3-4.8.amzn1 @amzn-main
libselinux.x86_64 2.1.10-3.22.amzn1 @ami
libsepol.x86_64 2.1.7-3.12.amzn1 @ami
libssh2.x86_64 1.4.2-2.13.amzn1 @ami
libstdc++48.x86_64 4.8.3-9.111.amzn1 @ami
libtasn1.x86_64 2.3-6.6.amzn1 @amzn-main
libtiff.x86_64 4.0.3-27.29.amzn1 @amzn-main
libtool-ltdl.x86_64 2.4.2-20.4.8.3.31.amzn1 @amzn-main
libudev.x86_64 173-4.13.amzn1 @amzn-main
libunistring.x86_64 0.9.3-6.1.amzn1 @ami
libuser.x86_64 0.60-7.23.amzn1 @amzn-main
libutempter.x86_64 1.1.5-4.1.6.amzn1 @amzn-main
libuuid.x86_64 2.23.2-33.28.amzn1 @amzn-updates
libuv.x86_64 1:0.10.34-1.el6 @epel
libverto.x86_64 0.2.5-4.9.amzn1 @ami
libwmf-lite.x86_64 0.2.8.4-41.11.amzn1 @amzn-main
libxcb.x86_64 1.11-2.21.amzn1 @amzn-main
libxml2.x86_64 2.9.1-6.3.49.amzn1 @ami
libxslt.x86_64 1.1.28-5.12.amzn1 @amzn-main
lksctp-tools.x86_64 1.0.10-7.7.amzn1 @amzn-main
lua.x86_64 5.1.4-4.1.9.amzn1 @ami
make.x86_64 1:3.82-21.10.amzn1 @ami
mesa-dri-drivers.x86_64 10.1.2-2.35.amzn1 @amzn-main
mesa-dri-filesystem.x86_64 10.1.2-2.35.amzn1 @amzn-main
mesa-dri1-drivers.x86_64 7.11-8.7.amzn1 @amzn-main
mesa-libGL.x86_64 10.1.2-2.35.amzn1 @amzn-main
mingetty.x86_64 1.08-5.9.amzn1 @amzn-main
ncurses.x86_64 5.7-4.20090207.14.amzn1 @ami
ncurses-base.x86_64 5.7-4.20090207.14.amzn1 @ami
ncurses-libs.x86_64 5.7-4.20090207.14.amzn1 @ami
net-tools.x86_64 1.60-110.10.amzn1 @amzn-main
nodejs.x86_64 0.10.48-3.el6 @epel
nspr.x86_64 4.13.1-1.0.39.amzn1 @amzn-updates
nss.x86_64 3.28.4-1.2.79.amzn1 @amzn-updates
nss-softokn.x86_64 3.16.2.3-14.4.39.amzn1 @ami
nss-softokn-freebl.x86_64 3.16.2.3-14.4.39.amzn1 @ami
nss-sysinit.x86_64 3.28.4-1.2.79.amzn1 @amzn-updates
nss-tools.x86_64 3.28.4-1.2.79.amzn1 @amzn-updates
nss-util.x86_64 3.28.4-1.0.52.amzn1 @amzn-updates
openldap.x86_64 2.4.40-12.30.amzn1 @ami
openssl.x86_64 1:1.0.1k-15.99.amzn1 @ami
p11-kit.x86_64 0.18.5-2.3.amzn1 @amzn-main
p11-kit-trust.x86_64 0.18.5-2.3.amzn1 @amzn-main
pam.x86_64 1.1.8-12.33.amzn1 @amzn-main
patch.x86_64 2.7.1-8.9.amzn1 @ami
pcre.x86_64 8.21-7.7.amzn1 @ami
perl.x86_64 4:5.16.3-286.38.amzn1 @ami
perl-Carp.noarch 1.26-244.5.amzn1 @ami
perl-Encode.x86_64 2.51-7.5.amzn1 @ami
perl-Exporter.noarch 5.68-3.5.amzn1 @ami
perl-File-Path.noarch 2.09-2.5.amzn1 @ami
perl-File-Temp.noarch 0.23.01-3.5.amzn1 @ami
perl-Filter.x86_64 1.49-3.5.amzn1 @ami
perl-Getopt-Long.noarch 2.40-2.5.amzn1 @ami
perl-HTTP-Tiny.noarch 0.033-3.6.amzn1 @ami
perl-PathTools.x86_64 3.40-5.5.amzn1 @ami
perl-Pod-Escapes.noarch 1:1.04-286.38.amzn1 @ami
perl-Pod-Perldoc.noarch 3.20-4.7.amzn1 @ami
perl-Pod-Simple.noarch 1:3.28-4.6.amzn1 @ami
perl-Pod-Usage.noarch 1.63-3.5.amzn1 @ami
perl-Scalar-List-Utils.x86_64 1.27-248.5.amzn1 @ami
perl-Socket.x86_64 2.010-3.5.amzn1 @ami
perl-Storable.x86_64 2.45-3.5.amzn1 @ami
perl-Text-ParseWords.noarch 3.29-4.5.amzn1 @ami
perl-Thread-Queue.noarch 3.02-2.5.amzn1 @ami
perl-Time-HiRes.x86_64 4:1.9725-272.5.amzn1 @ami
perl-Time-Local.noarch 1.2300-2.5.amzn1 @ami
perl-constant.noarch 1.27-2.5.amzn1 @ami
perl-libs.x86_64 4:5.16.3-286.38.amzn1 @ami
perl-macros.x86_64 4:5.16.3-286.38.amzn1 @ami
perl-parent.noarch 1:0.225-244.5.amzn1 @ami
perl-podlators.noarch 2.5.1-3.8.amzn1 @ami
perl-threads.x86_64 1.87-4.5.amzn1 @ami
perl-threads-shared.x86_64 1.43-6.5.amzn1 @ami
pinentry.x86_64 0.7.6-6.11.amzn1 @ami
pixman.x86_64 0.32.4-4.11.amzn1 @amzn-main
pkgconfig.x86_64 1:0.27.1-2.7.amzn1 @ami
popt.x86_64 1.13-7.7.amzn1 @ami
procps.x86_64 3.2.8-30.14.amzn1 @amzn-main
psmisc.x86_64 22.20-8.12.amzn1 @amzn-main
pth.x86_64 2.0.7-9.3.7.amzn1 @ami
python27.x86_64 2.7.12-2.120.amzn1 @ami
python27-iniparse.noarch 0.3.1-2.1.9.amzn1 @ami
python27-libs.x86_64 2.7.12-2.120.amzn1 @ami
python27-pycurl.x86_64 7.19.0-17.12.amzn1 @ami
python27-pygpgme.x86_64 0.3-9.12.amzn1 @ami
python27-pyliblzma.x86_64 0.5.3-11.6.amzn1 @ami
python27-pyxattr.x86_64 0.5.0-1.6.amzn1 @ami
python27-urlgrabber.noarch 3.10-8.16.amzn1 @ami
python34.x86_64 3.4.3-1.33.amzn1 @ami
python34-libs.x86_64 3.4.3-1.33.amzn1 @ami
readline.x86_64 6.2-9.14.amzn1 @ami
rpm.x86_64 4.11.3-21.75.amzn1 @ami
rpm-build.x86_64 4.11.3-21.75.amzn1 @ami
rpm-build-libs.x86_64 4.11.3-21.75.amzn1 @ami
rpm-libs.x86_64 4.11.3-21.75.amzn1 @ami
rpm-python27.x86_64 4.11.3-21.75.amzn1 @ami
sed.x86_64 4.2.1-10.10.amzn1 @ami
setup.noarch 2.8.14-20.12.amzn1 @ami
shadow-utils.x86_64 2:4.1.4.2-13.10.amzn1 @ami
shared-mime-info.x86_64 1.1-9.8.amzn1 @ami
sqlite.x86_64 3.7.17-6.13.amzn1 @ami
sysctl-defaults.noarch 1.0-1.1.amzn1 @ami
system-release.noarch 2017.03-0.1 @amzn-updates
sysvinit.x86_64 2.87-6.dsf.15.amzn1 @amzn-main
tar.x86_64 2:1.26-31.22.amzn1 @ami
ttmkfdir.x86_64 3.0.9-32.1.5.amzn1 @amzn-main
tzdata.noarch 2017b-1.69.amzn1 @ami
tzdata-java.noarch 2017b-1.69.amzn1 @amzn-main
udev.x86_64 173-4.13.amzn1 @amzn-main
unzip.x86_64 6.0-4.10.amzn1 @ami
upstart.x86_64 0.6.5-13.3.13.amzn1 @amzn-main
urw-fonts.noarch 2.4-10.7.amzn1 @amzn-main
util-linux.x86_64 2.23.2-33.28.amzn1 @amzn-updates
which.x86_64 2.19-6.10.amzn1 @amzn-main
xorg-x11-font-utils.x86_64 1:7.2-11.5.amzn1 @amzn-main
xorg-x11-fonts-Type1.noarch 7.2-9.1.5.amzn1 @amzn-main
xz.x86_64 5.1.2-12alpha.12.amzn1 @ami
xz-libs.x86_64 5.1.2-12alpha.12.amzn1 @ami
yum.noarch 3.4.3-150.70.amzn1 @amzn-updates
yum-metadata-parser.x86_64 1.1.4-10.20.amzn1 @ami
yum-plugin-priorities.noarch 1.1.31-40.29.amzn1 @ami
zlib.x86_64 1.2.8-7.18.amzn1 @ami
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment