Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Installing love-release
#!/bin/bash
# Installing love-release may be cumbersome, this should help
# This works for love-release version 2.0.9-1
set -e
sudo apt-get update
# These should already be installed, but who knows
sudo apt-get install -y git make
# love-release depends on libzip and luarocks needs lua
sudo apt-get install -y libzip-dev lua5.1 lua5.1-dev
wget http://luarocks.github.io/luarocks/releases/luarocks-3.0.4.tar.gz
tar xf luarocks-3.0.4.tar.gz
cd luarocks-3.0.4
./configure
make
sudo make install
sudo luarocks --tree=system install love-release 2.0.9-1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.