Skip to content

Instantly share code, notes, and snippets.

Avatar

Janitha Ranawansa JanithaR

View GitHub Profile
View gist:12e90e829ddd4acd289f674031823dc0
If you ever come across such a similar error or your xcode complains the project cannot be read because it can't parse it...
xcodebuild[25580:465966] Error Domain=NSCocoaErrorDomain Code=3840 "Unexpected character / at line 1" UserInfo={NSDebugDescription=Unexpected character / at line 1, kCFPropertyListOldStyleParsingError=Error Domain=NSCocoaErrorDomain Code=3840 "Missing ';' on line 1095" UserInfo={NSDebugDescription=Missing ';' on line 1095}}
Do, actually check the line in your project.pbxproj. Mine was...
HEADER_SEARCH_PATHS = "$(inherited)""$(SRCROOT)/../node_modules/react-native-i18n/ios";
and I corrected it to...
HEADER_SEARCH_PATHS = (
"$(inherited)",
View 2018-03-13T06_16_07_416Z-debug
This file has been truncated, but you can view the full file.
20010 verbose unbuild rmStuff in /Users/janithar/Desktop/Repos/mobile_react_native/ProfessionalApp/node_modules/uglify-es/node_modules
20011 info lifecycle commander@2.13.0~postuninstall: commander@2.13.0
20012 silly unbuild ua-parser-js@0.7.14
20013 info lifecycle ua-parser-js@0.7.14~preuninstall: ua-parser-js@0.7.14
20014 info lifecycle ua-parser-js@0.7.14~uninstall: ua-parser-js@0.7.14
20015 verbose unbuild rmStuff ua-parser-js@0.7.14 from /Users/janithar/Desktop/Repos/mobile_react_native/ProfessionalApp/node_modules
20016 info lifecycle ua-parser-js@0.7.14~postuninstall: ua-parser-js@0.7.14
20017 silly unbuild command-line-args@4.0.7
20018 info lifecycle command-line-args@4.0.7~preuninstall: command-line-args@4.0.7
View gist:2abf5b43c46afd7c960015e3691edfc1
{
"Message": "An error has occurred.",
"ExceptionMessage": "Expression expected",
"ExceptionType": "System.Linq.Dynamic.ParseException",
"StackTrace": " at System.Linq.Dynamic.ExpressionParser.ParsePrimaryStart() in C:\\Program Files (x86)\\Jenkins\\workspace\\Facilit.WebAPI\\Facilit.BLL\\Filtering\\Dynamic.cs:line 1109\r\n at System.Linq.Dynamic.ExpressionParser.ParsePrimary() in C:\\Program Files (x86)\\Jenkins\\workspace\\Facilit.WebAPI\\Facilit.BLL\\Filtering\\Dynamic.cs:line 1067\r\n at System.Linq.Dynamic.ExpressionParser.ParseUnary() in C:\\Program Files (x86)\\Jenkins\\workspace\\Facilit.WebAPI\\Facilit.BLL\\Filtering\\Dynamic.cs:line 1062\r\n at System.Linq.Dynamic.ExpressionParser.ParseMultiplicative() in C:\\Program Files (x86)\\Jenkins\\workspace\\Facilit.WebAPI\\Facilit.BLL\\Filtering\\Dynamic.cs:line 1007\r\n at System.Linq.Dynamic.ExpressionParser.ParseAdditive() in C:\\Program Files (x86)\\Jenkins\\workspace\\Facilit.WebAPI\\Facilit.BLL\\Filtering\\Dynamic.cs:line 975\r\n at Sy
View gist:c5c7b3be1ce6b26ca3e66feb7937c94c
> 10:59:26 AM: Executing task 'androidDependencies'...
>
> WARNING: The option 'android.enableAapt2' is deprecated and should not be used anymore.
> Use 'android.enableAapt2=true' to remove this warning.
> It will be removed at the end of 2018..
> Reading env from: .env
> WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
> It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
> WARNING: The option 'android.enableAapt2' is deprecated and should not be used anymore.
> Use 'android.enableAapt2=true' to remove this warning.
View gist:7ef9c4582d9d68967c856cac925c70bd
#!/usr/bin/env bash -e
DIR=$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )
source "$DIR/helper.sh"
open -a "React Native Debugger"
print_green_text 'Which simulator do you want to open?'
device=''