Skip to content

Instantly share code, notes, and snippets.

@AdamIsrael AdamIsrael/log.txt
Created Nov 21, 2018

Embed
What would you like to do?
OSM R5 Install backtrace
multipass@big-bowerbird:~$ wget https://osm-download.etsi.org/ftp/osm-5.0-five/install_osm.sh
--2018-11-21 14:51:57-- https://osm-download.etsi.org/ftp/osm-5.0-five/install_osm.sh
Resolving osm-download.etsi.org (osm-download.etsi.org)... 195.238.226.47
Connecting to osm-download.etsi.org (osm-download.etsi.org)|195.238.226.47|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 858 [text/x-sh]
Saving to: ‘install_osm.sh’
install_osm.sh 100%[===================================================================================================================================================================>] 858 --.-KB/s in 0s
2018-11-21 14:51:58 (21.7 MB/s) - ‘install_osm.sh’ saved [858/858]
multipass@big-bowerbird:~$ chmod +x install_osm.sh
multipass@big-bowerbird:~$ ./install_osm.sh
OK
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:5 https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease [11.3 kB]
Get:6 https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing/devops amd64 Packages [488 B]
Fetched 11.8 kB in 1s (11.9 kB/s)
Reading package lists... Done
W: Conflicting distribution: https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease (expected testing but got )
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:5 https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease
Reading package lists... Done
W: Conflicting distribution: https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease (expected testing but got )
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:5 https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease
Reading package lists...
W: Conflicting distribution: https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease (expected testing but got )
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
grub-pc-bin
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
osm-devops
0 upgraded, 1 newly installed, 0 to remove and 53 not upgraded.
Need to get 173 kB of archives.
After this operation, 2386 kB of additional disk space will be used.
Get:1 https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing/devops amd64 osm-devops all 4.0.1.post153-1 [173 kB]
Fetched 173 kB in 1s (174 kB/s)
Selecting previously unselected package osm-devops.
(Reading database ... 59999 files and directories currently installed.)
Preparing to unpack .../osm-devops_4.0.1.post153-1_all.deb ...
Unpacking osm-devops (4.0.1.post153-1) ...
Setting up osm-devops (4.0.1.post153-1) ...
Checking required packages: git jq wget curl tar
One or several required packages are not installed. Updating apt cache requires root privileges.
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:5 https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease
Reading package lists... Done [63/157]
W: Conflicting distribution: https://osm-download.etsi.org/repository/osm/debian/ReleaseFIVE-daily testing InRelease (expected testing but got )
Installing git jq wget curl tar requires root privileges.
Reading package lists... Done
Building dependency tree
Reading state information... Done
tar is already the newest version (1.29b-2).
curl is already the newest version (7.58.0-2ubuntu3.5).
git is already the newest version (1:2.17.1-1ubuntu0.3).
wget is already the newest version (1.19.4-1ubuntu2.1).
The following package was automatically installed and is no longer required:
grub-pc-bin
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
libjq1 libonig4
The following NEW packages will be installed:
jq libjq1 libonig4
0 upgraded, 3 newly installed, 0 to remove and 53 not upgraded.
Need to get 276 kB of archives.
After this operation, 930 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libonig4 amd64 6.7.0-1 [119 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libjq1 amd64 1.5+dfsg-2 [111 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/universe amd64 jq amd64 1.5+dfsg-2 [45.6 kB]
Fetched 276 kB in 1s (336 kB/s)
Selecting previously unselected package libonig4:amd64.
(Reading database ... 60560 files and directories currently installed.)
Preparing to unpack .../libonig4_6.7.0-1_amd64.deb ...
Unpacking libonig4:amd64 (6.7.0-1) ...
Selecting previously unselected package libjq1:amd64.
Preparing to unpack .../libjq1_1.5+dfsg-2_amd64.deb ...
Unpacking libjq1:amd64 (1.5+dfsg-2) ...
Selecting previously unselected package jq.
Preparing to unpack .../jq_1.5+dfsg-2_amd64.deb ...
Unpacking jq (1.5+dfsg-2) ...
Setting up libonig4:amd64 (6.7.0-1) ...
Setting up libjq1:amd64 (1.5+dfsg-2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up jq (1.5+dfsg-2) ...
## Wed Nov 21 14:52:24 EST 2018 source: logging sourced
## Wed Nov 21 14:52:24 EST 2018 source: config sourced
## Wed Nov 21 14:52:24 EST 2018 source: container sourced
## Wed Nov 21 14:52:24 EST 2018 source: git_functions sourced
The installation will configure LXD, install juju, install docker CE and init a docker swarm, as pre-requirements. Do you want to proceed (Y/n)? y
Installing lightweight build of OSM
Checking required packages: lxd snapd
Installing juju
2018-11-21T19:54:29Z INFO Waiting for restart...
juju 2.4.6 from 'canonical' installed
Warning: Stopping lxd.service, but it can still be activated by:
lxd.socket
Finished installation of juju
Since Juju 2 is being run for the first time, downloading latest cloud information.
Fetching latest public cloud list...
Since Juju 2 is being run for the first time, downloading latest cloud information.
Fetching latest public cloud list...
Updated your list of public clouds with 18 cloud regions added; 1 cloud attribute changed as well as 5 cloud regions deleted:
added cloud region:
- aws-china/cn-northwest-1
- azure/francecentral
- cloudsigma/dub
- cloudsigma/fra
- cloudsigma/mel
- cloudsigma/mnl
- cloudsigma/per
- cloudsigma/ruh
- cloudsigma/waw
- google/asia-east2
- google/europe-north1
- google/europe-west4
- google/northamerica-northeast1
- google/us-west2
- oracle/eu-frankfurt-1
- oracle/uk-london-1
- oracle/us-ashburn-1
- oracle/us-phoenix-1
changed cloud attribute:
- oracle
deleted cloud region:
- oracle/em2
- oracle/em3
- oracle/us2
- oracle/us6
- oracle/uscom-central-1
ERROR No controllers registered.
Please either create a new controller using "juju bootstrap" or connect to
another controller that you have been given access to using "juju register".
### Wed Nov 21 14:55:06 EST 2018 juju_createcontroller: FATAL error: Juju installation failed
BACKTRACE:
### FATAL /usr/share/osm-devops/jenkins/common/logging 39
### juju_createcontroller /usr/share/osm-devops/installers/full_install_osm.sh 639
### install_lightweight /usr/share/osm-devops/installers/full_install_osm.sh 989
### main /usr/share/osm-devops/installers/full_install_osm.sh 1329
-------
multipass@big-bowerbird:~$ Updated your list of public clouds with 18 cloud regions added; 1 cloud attribute changed as well as 5 cloud regions deleted:
added cloud region:
- aws-china/cn-northwest-1
- azure/francecentral
- cloudsigma/dub
- cloudsigma/fra
- cloudsigma/mel
- cloudsigma/mnl
- cloudsigma/per
- cloudsigma/ruh
- cloudsigma/waw
- google/asia-east2
- google/europe-north1
- google/europe-west4
- google/northamerica-northeast1
- google/us-west2
- oracle/eu-frankfurt-1
- oracle/uk-london-1
- oracle/us-ashburn-1
- oracle/us-phoenix-1
changed cloud attribute:
- oracle
deleted cloud region:
- oracle/em2
- oracle/em3
- oracle/us2
- oracle/us6
- oracle/uscom-central-1
ERROR controller osm not found
multipass@big-bowerbird:~$
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.