Skip to content

Instantly share code, notes, and snippets.

Alex Mayfield AlexMax

Block or report user

Report or block AlexMax

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
@AlexMax
AlexMax / retroarch.md
Last active Sep 6, 2019
Setting up RetroArch on a Raspberry Pi
View retroarch.md

Setting up RetroArch on a Raspberry Pi

I just put the finishing touches on my Raspberry Pi 3 emulation machine running RetroArch. I was not a huge fan of RetroPie due to the reliance on Emulation Station - more moving parts meant that there were more things that could potentially break. I just wanted something that would run raw RetroArch, no frills.

This tutorial is mostly recreated from memory and was most recently tested with a Raspberry Pi 3 running Raspbian Stretch and RetroArch 1.7.7. If there is a mistake or a broken link, PLEASE message me and I will fix it.

Step 1: Install Raspbian

I used Raspbian Stretch Lite from this page. Write the image to your SD card using something like Win32 Disk Imager, or if you're using OSX/Linux follow a tutorial on how to write the image using dd.

View brew doctor
Please note that these warnings are just used to help the Homebrew maintainers
with debugging if you file an issue. If everything you use Homebrew for is
working fine: please don't worry and just ignore them. Thanks!
Warning: Some installed formula are missing dependencies.
You should `brew install` the missing dependencies:
brew install php56
Run `brew missing` for more details.
View brew --config
HOMEBREW_VERSION: 0.9.5
ORIGIN: https://github.com/mxcl/homebrew.git
HEAD: ecfe86d417503667320091372b6d271802f55131
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: dual-core 64-bit penryn
OS X: 10.6.8-i386
Xcode: 3.2.6
GCC-4.0: build 5494
GCC-4.2: build 5666
@AlexMax
AlexMax / 04.make
Last active Dec 27, 2015
subversion17 failed to build on 10.6
View 04.make
/bin/sh /private/tmp/subversion17-Rqr8/subversion-1.7.13/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.2 -I/usr/local/opt/sqlite/include -I/usr/local/opt/readline/include -I/usr/local/opt/neon/include -F/usr/local/Frameworks -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -Os -w -pipe -march=core2 -msse4.1 -mmacosx-version-min=10.6 -Werror=implicit-function-declaration -DNDEBUG -I./subversion/include -I./subversion -I/usr/include/apr-1 -I/usr/local/Cellar/httpd/2.2.25/include/apache2 -I/usr/local/Cellar/neon/0.30.0/include/neon -I/usr/local/Cellar/subversion17/1.7.13/libexec/serf/include/serf-1 -I/usr/local/opt/sqlite/include -I/usr/include -o subversion/libsvn_delta/cancel.lo -c subversion/libsvn_delta/cancel.c
/bin/sh /private/tmp/subversion17-Rqr8/subversion-1.7.13/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.2 -I/usr/local/opt/sqlite/include -I/usr/local/opt/readline/include -I/usr/local/opt/neon/include -F/usr/local/Frameworks -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -Os -w -pipe -ma
View HOMEBREW_MAKE_JOBS=1 VERBOSE=1 brew install php54 --with-pgsql > out.txt 2>&1
This file has been truncated, but you can view the full file.
==> Downloading http://www.php.net/get/php-5.4.15.tar.bz2/from/this/mirror
Already downloaded: /Users/alex/Library/Caches/Homebrew/php54-5.4.15
tar xf /Users/alex/Library/Caches/Homebrew/php54-5.4.15
Warning: Backing up all known pear.conf and .pearrc files
Warning: If you have a pre-existing pear install outside
of homebrew-php, or you are using a non-standard
pear.conf location, installation may fail.
View HOMEBREW_MAKE_JOBS=1 VERBOSE=1 brew install gdk-pixbuf
==> Downloading http://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/2.26/gdk-pixbuf-2.26.5.tar.xz
Already downloaded: /Users/alex/Library/Caches/Homebrew/gdk-pixbuf-2.26.5.tar.xz
xz -dc "/Users/alex/Library/Caches/Homebrew/gdk-pixbuf-2.26.5.tar.xz" | /usr/bin/tar xf -
==> ./configure --disable-dependency-tracking --disable-maintainer-mode --enable-debug=no --prefix=/usr/local/Cellar/gdk-pixbuf/2.26.5 --enable-introspection=no --disable-Bsymbolic --without-gdiplus
./configure --disable-dependency-tracking --disable-maintainer-mode --enable-debug=no --prefix=/usr/local/Cellar/gdk-pixbuf/2.26.5 --enable-introspection=no --disable-Bsymbolic --without-gdiplus
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
@AlexMax
AlexMax / gist:5100238
Last active Dec 14, 2015
gmp failed to build on 10.6
View gist:5100238
## The output from HOMEBREW_MAKE_JOBS=1 VERBOSE=1 brew install foo
:~ alex% HOMEBREW_MAKE_JOBS=1 VERBOSE=1 brew upgrade gmp
==> Upgrading gmp
rm /usr/local/include/gmpxx.h
rm /usr/local/include/gmp.h
rm /usr/local/lib/libgmpxx.dylib
rm /usr/local/lib/libgmpxx.a
rm /usr/local/lib/libgmpxx.4.dylib
rm /usr/local/lib/libgmp.dylib
You can’t perform that action at this time.