Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
1 - Symfony : Introduction à Symfony 4
1 - Quelle est la société qui développe Symfony ?
SensioLabs
2 - Cite les autres produits développés par cette société ?
- Blackfire.IO
- Composer
- Twig
- Doctrine
les autres produits développés sont:
- Blackfire.IO
- Twig
3 - Parmi ces outils, lesquels sont des frameworks
- Symfony
- Wordpress
- Laravel
- Joomla!
les frameworks parmis ses outils sont:
- Symfony
- Laravel
4 - Symfony 4 embarque la librairie Twig
- Vrai
- Faux
la réponse est :
- Vrai
5 - Flexbox est le nouveau système de gestion des dépendances dans Symfony 4.
- Vrai
- Faux
la réponse est :
- Faux
6 - Pour créer un projet Symfony 4, tu dois utiliser la commande :
- composer create-project <skeleton-de-ton-choix> <project-name>
- symfony new <project-name> <version>
on utilise la commande:
- composer create-project <skeleton-de-ton-choix> <project-name>
7 - MVC est un type d'architecture propre à Symfony
- Vrai
- Faux
la réponse est :
- Faux
8 - Le V de MVC signifie Vue (View), pourquoi ?
- Parce que Symfony utilise Vue.js
- Parce que c'est la partie visible de l'application
la réponse est :
- Parce que c'est la partie visible de l'application
9 - Les actions des contrôleurs doivent se terminer par Action
- Vrai
- Faux
la réponse est:
- Faux mais je demande une explication pour moi la question n'est pas clair.
10 - La version minimum de PHP pour utiliser Symfony 4 est la
- 5.6
- 7.0
- 7.1
- Il n'y a aucune contrainte.
la version minimum est:
- 7.1
Critéres de validation
• Toutes les réponses se trouvent dans les documentations fournies, tu devrais réussir facilement à valider la quête. Dans tous les cas, une correction commune avec ton formateur sera réalisée.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.