Skip to content

Instantly share code, notes, and snippets.

@FragsterAt FragsterAt/test.bsl
Last active Oct 22, 2018

Embed
What would you like to do?
Абыр = "Абырвалг";
Итераций = 1000000;
ИФ = ПолучитьИмяВременногоФайла();
Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
ЗТ = Новый ЗаписьТекста(ИФ);
Для Сч = 1 по Итераций Цикл
ЗТ.Записать(Абыр);
ЗТ.Записать(Абыр);
ЗТ.Записать(Абыр);
ЗТ.Записать(Абыр);
ЗТ.ЗаписатьСтроку(Абыр);
КонецЦикла;
ЗТ.Закрыть();
Сообщить("Записать + ЗаписатьСтроку: "+ (ТекущаяУниверсальнаяДатаВМиллисекундах() - Начало));
УдалитьФайлы(ИФ);
ИФ = ПолучитьИмяВременногоФайла();
Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
ЗТ = Новый ЗаписьТекста(ИФ);
Для Сч = 1 по Итераций Цикл
Массив = Новый Массив;
Массив.Добавить(Абыр);
Массив.Добавить(Абыр);
Массив.Добавить(Абыр);
Массив.Добавить(Абыр);
Массив.Добавить(Абыр);
ЗТ.ЗаписатьСтроку(СтрСоединить(Массив, ""));
КонецЦикла;
ЗТ.Закрыть();
Сообщить("СтрСоединить + ЗаписатьСтроку: "+ (ТекущаяУниверсальнаяДатаВМиллисекундах() - Начало));
УдалитьФайлы(ИФ);
ИФ = ПолучитьИмяВременногоФайла();
Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
ЗТ = Новый ЗаписьТекста(ИФ);
Для Сч = 1 по Итераций Цикл
Стр = Абыр + Абыр+ Абыр + Абыр + Абыр;
ЗТ.ЗаписатьСтроку(Стр);
КонецЦикла;
ЗТ.Закрыть();
Сообщить("ЗаписатьСтроку: "+ (ТекущаяУниверсальнаяДатаВМиллисекундах() - Начало));
УдалитьФайлы(ИФ);
ИФ = ПолучитьИмяВременногоФайла();
Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
ЗТ = Новый ЗаписьТекста(ИФ);
Для Сч = 1 по Итераций Цикл
ЗТ.ЗаписатьСтроку(Абыр + Абыр+ Абыр + Абыр + Абыр);
КонецЦикла;
ЗТ.Закрыть();
Сообщить("ЗаписатьСтроку (Инлайн): "+ (ТекущаяУниверсальнаяДатаВМиллисекундах() - Начало));
УдалитьФайлы(ИФ);
Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
ИФ = ПолучитьИмяВременногоФайла();
ЗХ = Новый ЗаписьXML;
ЗХ.УстановитьСтроку();
Для Сч = 1 по Итераций Цикл
ЗХ.ЗаписатьБезОбработки(Абыр);
ЗХ.ЗаписатьБезОбработки(Абыр);
ЗХ.ЗаписатьБезОбработки(Абыр);
ЗХ.ЗаписатьБезОбработки(Абыр);
ЗХ.ЗаписатьБезОбработки(Абыр);
ЗХ.ЗаписатьБезОбработки(Символы.ПС);
КонецЦикла;
ЗТ = Новый ЗаписьТекста(ИФ);
ЗТ.Записать(Зх.Закрыть());
ЗТ.Закрыть();
Сообщить("ЗаписатьXML: "+ (ТекущаяУниверсальнаяДатаВМиллисекундах() - Начало));
УдалитьФайлы(ИФ);
ИФ = ПолучитьИмяВременногоФайла();
Начало = ТекущаяУниверсальнаяДатаВМиллисекундах();
ЗХ = Новый ЗаписьXML;
ЗХ.УстановитьСтроку();
Для Сч = 1 по Итераций Цикл
ЗХ.ЗаписатьБезОбработки(Абыр + Абыр+ Абыр + Абыр + Абыр + Символы.ПС);
КонецЦикла;
ЗТ = Новый ЗаписьТекста(ИФ);
ЗТ.Записать(Зх.Закрыть());
ЗТ.Закрыть();
Сообщить("ЗаписатьXML (Инлайн): "+ (ТекущаяУниверсальнаяДатаВМиллисекундах() - Начало));
УдалитьФайлы(ИФ);
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.