Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
These are the steps to install qgis, postgres. CANNOT INSTALL postgis
#adding the repo for qgis
sudo add-apt-repository "deb http://qgis.org/ubuntugis trusty main"
sudo add-apt-repository "deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main"
#installing qgis
sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass
#output
The following extra packages will be installed:
cpp-4.8 fonts-lyx gcc-4.8 gcc-4.8-base gdal-bin grass-core javascript-common
libaacs0 libarmadillo4 libarpack2 libasan0 libatomic1 libavcodec54
libavdevice53 libavformat54 libavutil52 libblas3 libbluray1
libboost-serialization1.54.0 libboost-thread1.54.0 libcgal10 libcoin80
libcrypto++9 libdap11 libdapclient3 libdc1394-22 libdrm-amdgpu1 libdrm-dev
libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libepsilon1 libfaad2
libfcgi0ldbl libfftw3-double3 libfreexl1 libgcc-4.8-dev libgdal20
libgeos-3.5.0 libgeos-c1v5 libgeotiff2 libgfortran3 libgif4 libgl1-mesa-dev
libglade2-0 libglu1-mesa-dev libgomp1 libgraphicsmagick3 libgsl0ldbl libgsm1
libhdf4-0-alt libhdf5-7 libiso9660-8 libitm1 libjs-jquery libjs-leaflet
libkml0 liblapack3 liblas-c3 liblas3 liblwgeom-2.2-5 liblwgeom-dev libmad0
libmng2 libmodplug1 libmp3lame0 libmpcdec6 libmysqlclient18 libnetcdfc7
libodbc1 libogdi3.2 libopenjp2-7 libopenjpeg2 libopenscenegraph100v5
libopenthreads20 libopus0 libpostproc52 libpq5 libproj0
libpthread-stubs0-dev libqca2 libqca2-plugin-ossl libqgis-analysis2.18.0
libqgis-app2.18.0 libqgis-core2.18.0 libqgis-customwidgets libqgis-gui2.18.0
libqgis-networkanalysis2.18.0 libqgis-server2.18.0 libqgisgrass7-2.18.0
libqgispython2.18.0 libqhull6 libqjson0 libqscintilla2-11
libqscintilla2-l10n libqt4-dev libqt4-dev-bin libqt4-opengl-dev
libqt4-qt3support libqtwebkit-dev libquadmath0 libqwt5-qt4
libschroedinger-1.0-0 libsfcgal1 libspatialindex3 libspatialite5 libstdc++6
libswscale2 libtsan0 liburiparser1 libva1 libvcdinfo0 libwxbase2.8-0
libwxgtk2.8-0 libx11-dev libx11-doc libx11-xcb-dev libx264-142 libxau-dev
libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev
libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev libxcb-sync-dev
libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev libxerces-c3.1
libxext-dev libxfixes-dev libxine2 libxine2-bin libxine2-doc libxine2-ffmpeg
libxine2-misc-plugins libxine2-plugins libxshmfence-dev libxvidcore4
libxxf86vm-dev libyaml-0-2 mesa-common-dev mysql-common odbcinst
odbcinst1debian2 proj-bin proj-data python-dateutil python-egenix-mxdatetime
python-egenix-mxtools python-gdal python-glade2 python-jinja2
python-markupsafe python-matplotlib python-matplotlib-data python-numpy
python-psycopg2 python-pygments python-pyparsing python-pyspatialite
python-qgis-common python-qscintilla2 python-qt4-sql python-shapely
python-support python-tk python-tz python-yaml qgis-common
qgis-plugin-grass-common qgis-provider-grass qgis-providers
qgis-providers-common qt4-designer qt4-linguist-tools qt4-qmake
x11proto-core-dev x11proto-damage-dev x11proto-dri2-dev x11proto-fixes-dev
x11proto-gl-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev
x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
Suggested packages:
gcc-4.8-locales gcc-4.8-multilib gcc-4.8-doc libgcc1-dbg libgomp1-dbg
libitm1-dbg libatomic1-dbg libasan0-dbg libtsan0-dbg libquadmath0-dbg
grass-doc grass-gui grass-dev e00compr avce00 gnuplot gpsbabel gpstrans
netpbm python-rpy2 apache2 lighttpd httpd libbluray-bdj libopenal0a
libsimage-dev libfftw3-bin libfftw3-dev geotiff-bin libgeotiff-epsg
graphicsmagick-dbg gsl-ref-psdoc gsl-doc-pdf gsl-doc-info gsl-ref-html
libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 libmyodbc odbc-postgresql
tdsodbc unixodbc-bin ogdi-bin opus-tools libqca2-plugin-cyrus-sasl
libqca2-plugin-gnupg firebird-dev libmysqlclient-dev libpq-dev
libsqlite0-dev libsqlite3-dev qt4-dev-tools qt4-doc unixodbc-dev libxcb-doc
libxext-doc gxine xine-ui python-egenix-mxdatetime-dbg
python-egenix-mxdatetime-doc python-egenix-mxtools-dbg
python-egenix-mxtools-doc python-gtk2-doc python-jinja2-doc dvipng inkscape
ipython python-configobj python-excelerator python-matplotlib-doc
python-nose python-scipy python-tornado python-traits python-wxgtk2.8
texlive-extra-utils texlive-latex-extra ttf-staypuft gfortran python-dev
python-numpy-dbg python-numpy-doc python-psycopg2-doc ttf-bitstream-vera tix
python-tk-dbg
The following NEW packages will be installed:
fonts-lyx gdal-bin grass-core javascript-common libaacs0 libarmadillo4
libarpack2 libavcodec54 libavdevice53 libavformat54 libavutil52 libblas3
libbluray1 libboost-serialization1.54.0 libboost-thread1.54.0 libcgal10
libcoin80 libcrypto++9 libdap11 libdapclient3 libdc1394-22 libdrm-dev
libepsilon1 libfaad2 libfcgi0ldbl libfftw3-double3 libfreexl1 libgdal20
libgeos-3.5.0 libgeos-c1v5 libgeotiff2 libgfortran3 libgif4 libgl1-mesa-dev
libglade2-0 libglu1-mesa-dev libgraphicsmagick3 libgsl0ldbl libgsm1
libhdf4-0-alt libhdf5-7 libiso9660-8 libjs-jquery libjs-leaflet libkml0
liblapack3 liblas-c3 liblas3 liblwgeom-2.2-5 liblwgeom-dev libmad0 libmng2
libmodplug1 libmp3lame0 libmpcdec6 libmysqlclient18 libnetcdfc7 libodbc1
libogdi3.2 libopenjp2-7 libopenjpeg2 libopenscenegraph100v5 libopenthreads20
libopus0 libpostproc52 libpq5 libproj0 libpthread-stubs0-dev libqca2
libqca2-plugin-ossl libqgis-analysis2.18.0 libqgis-app2.18.0
libqgis-core2.18.0 libqgis-customwidgets libqgis-gui2.18.0
libqgis-networkanalysis2.18.0 libqgis-server2.18.0 libqgisgrass7-2.18.0
libqgispython2.18.0 libqhull6 libqjson0 libqscintilla2-11
libqscintilla2-l10n libqt4-dev libqt4-dev-bin libqt4-opengl-dev
libqt4-qt3support libqtwebkit-dev libqwt5-qt4 libschroedinger-1.0-0
libsfcgal1 libspatialindex3 libspatialite5 libswscale2 liburiparser1 libva1
libvcdinfo0 libwxbase2.8-0 libwxgtk2.8-0 libx11-dev libx11-doc
libx11-xcb-dev libx264-142 libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev
libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev
libxcb-shape0-dev libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev
libxdamage-dev libxdmcp-dev libxerces-c3.1 libxext-dev libxfixes-dev
libxine2 libxine2-bin libxine2-doc libxine2-ffmpeg libxine2-misc-plugins
libxine2-plugins libxshmfence-dev libxvidcore4 libxxf86vm-dev libyaml-0-2
mesa-common-dev mysql-common odbcinst odbcinst1debian2 proj-bin proj-data
python-dateutil python-egenix-mxdatetime python-egenix-mxtools python-gdal
python-glade2 python-jinja2 python-markupsafe python-matplotlib
python-matplotlib-data python-numpy python-psycopg2 python-pygments
python-pyparsing python-pyspatialite python-qgis python-qgis-common
python-qscintilla2 python-qt4-sql python-shapely python-support python-tk
python-tz python-yaml qgis qgis-common qgis-plugin-grass
qgis-plugin-grass-common qgis-provider-grass qgis-providers
qgis-providers-common qt4-designer qt4-linguist-tools qt4-qmake
x11proto-core-dev x11proto-damage-dev x11proto-dri2-dev x11proto-fixes-dev
x11proto-gl-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev
x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
The following packages will be upgraded:
cpp-4.8 gcc-4.8 gcc-4.8-base libasan0 libatomic1 libdrm-amdgpu1
libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libgcc-4.8-dev libgomp1
libitm1 libquadmath0 libstdc++6 libtsan0
16 upgraded, 179 newly installed, 0 to remove and 206 not upgraded.
Need to get 129 MB/141 MB of archives.
After this operation, 499 MB of additional disk space will be used.
###installing postgresql####
#adding the repo to the sources.list
sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -cs)-pgdg main" > /etc/apt/sources.list.d/pgdg.list'
#adding the key
sudo apt-get install wget ca-certificates
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
#update and upgrade and installation
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install postgresql-9.6
####output
The following extra packages will be installed:
libpq5 pgdg-keyring postgresql-client-9.6 postgresql-client-common
postgresql-common postgresql-contrib-9.6 sysstat
Suggested packages:
locales-all postgresql-doc-9.6 libdbd-pg-perl isag
The following NEW packages will be installed:
pgdg-keyring postgresql-9.6 postgresql-client-9.6 postgresql-client-common
postgresql-common postgresql-contrib-9.6 sysstat
The following packages will be upgraded:
libpq5
1 upgraded, 7 newly installed, 0 to remove and 206 not upgraded.
Need to get 6.440 kB of archives.
After this operation, 28,3 MB of additional disk space will be used.
###installing postgis
repo used for fetching deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
sudo apt-get update
sudo apt-get install postgis
##output
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
postgis : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
Depends: liblwgeom-2.3-0 (>= 2.0.0) but it is not going to be installed
Recommends: postgresql-9.6-postgis-2.3 but it is not going to be installed
## about
libgdal1h
libgeos-c1
liblwgeom-2.3-0
you can find some information here:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839182
## Trying to install postgis 2.3
sudo apt-get install postgis 2.3
#output
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'python2.3-gammu' for regex '2.3'
Note, selecting 'python2.3-pysqlite1.1' for regex '2.3'
Note, selecting 'libghc-hdbc-prof-2.3.1.2-28675' for regex '2.3'
Note, selecting 'libghc-cpu-prof-0.1.2-3b02d' for regex '2.3'
Note, selecting 'python2.3-pyvtk' for regex '2.3'
Note, selecting 'python2.3-dialog' for regex '2.3'
Note, selecting 'python2.3-xmpp' for regex '2.3'
Note, selecting 'libghc-pandoc-types-prof-1.12.3-12449' for regex '2.3'
Note, selecting 'libghc-unordered-containers-prof-0.2.3.0-9584b' for regex '2.3'
Note, selecting 'postgresql-9.4-postgis-2.3' for regex '2.3'
Note, selecting 'python2.3-adodb' for regex '2.3'
Note, selecting 'libghc-zlib-enum-dev-0.2.3-511ac' for regex '2.3'
Note, selecting 'python2.3-ldap-tls' for regex '2.3'
Note, selecting 'python2.3-opencv' for regex '2.3'
Note, selecting 'libghc-cpu-dev-0.1.2-3b02d' for regex '2.3'
Note, selecting 'python2.3-xlib' for regex '2.3'
Note, selecting 'python2.3-pyode' for regex '2.3'
Note, selecting 'python2.3-pyorbit-omg' for regex '2.3'
Note, selecting 'libghc-edisonapi-prof-1.2.2-22f39' for regex '2.3'
Note, selecting 'libghc-xmlhtml-dev-0.2.3-53dc0' for regex '2.3'
Note, selecting 'python2.3-dhm' for regex '2.3'
Note, selecting 'libghc-hdbc-postgresql-dev-2.3.2.1-90dce' for regex '2.3'
Note, selecting 'python2.3-cherrypy2.1' for regex '2.3'
Note, selecting 'python2.3-pypoker-eval' for regex '2.3'
Note, selecting 'libtaoframework-freetype2.3-cil' for regex '2.3'
Note, selecting 'libghc-ed25519-dev-0.0.2.0-9243f' for regex '2.3'
Note, selecting 'libffms2-3' for regex '2.3'
Note, selecting 'libgraphite2-3' for regex '2.3'
Note, selecting 'python2.3-htmlgen' for regex '2.3'
Note, selecting 'libghc-hdbc-dev-2.3.1.2-28675' for regex '2.3'
Note, selecting 'python2.3-pysqlite2' for regex '2.3'
Note, selecting 'xtables-addons-common-2.3' for regex '2.3'
Note, selecting 'libghc-crypto-numbers-dev-0.2.3-28720' for regex '2.3'
Note, selecting 'python2.3-poker-eval' for regex '2.3'
Note, selecting 'python2.3-apoo' for regex '2.3'
Note, selecting 'libbox2d2.3.0' for regex '2.3'
Note, selecting 'libtime-y2038-perl' for regex '2.3'
Note, selecting 'python2.3-egenix-mxtexttools' for regex '2.3'
Note, selecting 'libslepc2.3.2' for regex '2.3'
Note, selecting 'libghc-ed25519-prof-0.0.2.0-9243f' for regex '2.3'
Note, selecting 'postgresql-9.4-postgis-2.3-scripts' for regex '2.3'
Note, selecting 'libghc-gtksourceview2-prof-0.12.3.1-95f4c' for regex '2.3'
Note, selecting 'python2.3-gadfly' for regex '2.3'
Note, selecting 'python2.3-kjbuckets' for regex '2.3'
Note, selecting 'python2.3-eyed3' for regex '2.3'
Note, selecting 'python2.3-ifeffit' for regex '2.3'
Note, selecting 'python2.3-ldaptor' for regex '2.3'
Note, selecting 'libghc-data-accessor-dev-0.2.2.3-f24d7' for regex '2.3'
Note, selecting 'libghc-yesod-core-dev-1.2.3-7090b' for regex '2.3'
Note, selecting 'python2.3-pyorbit' for regex '2.3'
Note, selecting 'python2.3-apsw' for regex '2.3'
Note, selecting 'postgresql-9.3-postgis-2.3' for regex '2.3'
Note, selecting 'python2.3-xml' for regex '2.3'
Note, selecting 'libzthread-2.3-2' for regex '2.3'
Note, selecting 'libmpdec2.3' for regex '2.3'
Note, selecting 'libglacier2-35' for regex '2.3'
Note, selecting 'libghc-uuid-prof-1.2.3-9a1e0' for regex '2.3'
Note, selecting 'libghc-gtksourceview2-dev-0.12.3.1-95f4c' for regex '2.3'
Note, selecting 'liblasso0-python2.3' for regex '2.3'
Note, selecting 'libghc-webkit-prof-0.12.3-5567f' for regex '2.3'
Note, selecting 'libghc-bmp-prof-1.2.3.4-dce3a' for regex '2.3'
Note, selecting 'ruby-activesupport-2.3' for regex '2.3'
Note, selecting 'python2.3-libuser' for regex '2.3'
Note, selecting 'python2.3-pyepl' for regex '2.3'
Note, selecting 'liblwgeom-2.3-0' for regex '2.3'
Note, selecting 'postgresql-9.6-postgis-2.3' for regex '2.3'
Note, selecting 'python2.3-libhamlib2' for regex '2.3'
Note, selecting 'python2.3-templayer' for regex '2.3'
Note, selecting 'libghc-pipes-safe-dev-2.0.2-335df' for regex '2.3'
Note, selecting 'python2.3-sqlite' for regex '2.3'
Note, selecting 'libghc-data-pprint-dev-0.2.3-2f7a9' for regex '2.3'
Note, selecting 'libghc-sandi-prof-0.2.3-3ddc6' for regex '2.3'
Note, selecting 'unison2.32.52' for regex '2.3'
Note, selecting 'libghc-web-plugins-dev-0.2.3-6730c' for regex '2.3'
Note, selecting 'libghc-http-client-conduit-dev-0.2.0.0-02a37' for regex '2.3'
Note, selecting 'python2.3-pygresql' for regex '2.3'
Note, selecting 'libghc-wai-eventsource-prof-1.3.0.4-cf223' for regex '2.3'
Note, selecting 'liblivetribe-jsr223-java' for regex '2.3'
Note, selecting 'postgresql-9.6-postgis-2.3-scripts' for regex '2.3'
Note, selecting 'libghc-hdbc-postgresql-prof-2.3.2.1-90dce' for regex '2.3'
Note, selecting 'postgresql-9.3-postgis-2.3-scripts' for regex '2.3'
Note, selecting 'libghc-repa-dev-3.2.3.3-1699c' for regex '2.3'
Note, selecting 'python2.3-svn' for regex '2.3'
Note, selecting 'libghc-edisonapi-dev-1.2.2-22f39' for regex '2.3'
Note, selecting 'postgresql-9.2-postgis-2.3' for regex '2.3'
Note, selecting 'python2.3-gpod' for regex '2.3'
Note, selecting 'python2.3-albatross' for regex '2.3'
Note, selecting 'libghc-terminal-progress-bar-dev-0.0.1.3-6e2c3' for regex '2.3'
Note, selecting 'python2.3-pymad' for regex '2.3'
Note, selecting 'python2.3-forgetsql' for regex '2.3'
Note, selecting 'python2.3-tk' for regex '2.3'
Note, selecting 'libapreq2-3' for regex '2.3'
Note, selecting 'python2.3-hamlib3' for regex '2.3'
Note, selecting 'libghc-hdbc-odbc-dev-2.3.1.1-18eb1' for regex '2.3'
Note, selecting 'libicepatch2-35' for regex '2.3'
Note, selecting 'libghc-csv-prof-0.1.2-3d3c6' for regex '2.3'
Note, selecting 'python2.3-twisted-web2' for regex '2.3'
Note, selecting 'python2.3-htmltmpl' for regex '2.3'
Note, selecting 'libghc-agda-dev-2.3.2.2-ffa3d' for regex '2.3'
Note, selecting 'libghc-intervals-dev-0.2.2.1-02536' for regex '2.3'
Note, selecting 'python2.3-egenix-mxstack' for regex '2.3'
Note, selecting 'libghc-yesod-core-prof-1.2.3-7090b' for regex '2.3'
Note, selecting 'libghc-cabal-file-th-prof-0.2.3-28de3' for regex '2.3'
Note, selecting 'python2.3-yappy' for regex '2.3'
Note, selecting 'python2.3-rpm' for regex '2.3'
Note, selecting 'python2.3-rpy' for regex '2.3'
Note, selecting 'python2.3-adns' for regex '2.3'
Note, selecting 'postgresql-9.5-postgis-2.3' for regex '2.3'
Note, selecting 'gir1.2-webkit2-3.0' for regex '2.3'
Note, selecting 'libghc-pipes-safe-prof-2.0.2-335df' for regex '2.3'
Note, selecting 'unison2.32.52-gtk' for regex '2.3'
Note, selecting 'python2.3-rrd' for regex '2.3'
Note, selecting 'libghc-uuid-dev-1.2.3-9a1e0' for regex '2.3'
Note, selecting 'python2.3-pythoncard' for regex '2.3'
Note, selecting 'libghc-csv-dev-0.1.2-3d3c6' for regex '2.3'
Note, selecting 'python2.3-gdbm' for regex '2.3'
Note, selecting 'libghc-colour-dev-2.3.3-8d8d4' for regex '2.3'
Note, selecting 'python2.3-biopython' for regex '2.3'
Note, selecting 'python2.3-slides' for regex '2.3'
Note, selecting 'libghc-http-client-conduit-prof-0.2.0.0-02a37' for regex '2.3'
Note, selecting 'libghc-data-accessor-prof-0.2.2.3-f24d7' for regex '2.3'
Note, selecting 'python2.3-egenix-mxqueue' for regex '2.3'
Note, selecting 'libamd2.3.1' for regex '2.3'
Note, selecting 'python2.3-mysqldb' for regex '2.3'
Note, selecting 'libghc-tagged-dev-0.7-d243d' for regex '2.3'
Note, selecting 'python2.3-gst0.10' for regex '2.3'
Note, selecting 'libsbjson2.3' for regex '2.3'
Note, selecting 'ruby-rails-2.3' for regex '2.3'
Note, selecting 'postgresql-9.5-postgis-2.3-scripts' for regex '2.3'
Note, selecting 'python2.3-quixote' for regex '2.3'
Note, selecting 'libghc-hdbc-sqlite3-dev-2.3.3.0-bb2c3' for regex '2.3'
Note, selecting 'python2.3-fuse' for regex '2.3'
Note, selecting 'libghc-repa-prof-3.2.3.3-1699c' for regex '2.3'
Note, selecting 'libghc-hdbc-odbc-prof-2.3.1.1-18eb1' for regex '2.3'
Note, selecting 'python2.3-egenix-mxtools' for regex '2.3'
Note, selecting 'libminc2-3' for regex '2.3'
Note, selecting 'qtdeclarative5-cordova-2.3-plugin' for regex '2.3'
Note, selecting 'python2.3-omniorb2-omg' for regex '2.3'
Note, selecting 'libghc-crypto-numbers-prof-0.2.3-28720' for regex '2.3'
Note, selecting 'libghc-unordered-containers-dev-0.2.3.0-9584b' for regex '2.3'
Note, selecting 'libghc-hdbc-sqlite3-prof-2.3.3.0-bb2c3' for regex '2.3'
Note, selecting 'libldap-2.3-0' for regex '2.3'
Note, selecting 'python2.3-iplib' for regex '2.3'
Note, selecting 'libghc-zlib-enum-prof-0.2.3-511ac' for regex '2.3'
Note, selecting 'python2.3-biopython-sql' for regex '2.3'
Note, selecting 'libghc-bmp-dev-1.2.3.4-dce3a' for regex '2.3'
Note, selecting 'python2.3-speex' for regex '2.3'
Note, selecting 'ruby-actionpack-2.3' for regex '2.3'
Note, selecting 'libghc-incremental-parser-dev-0.2.3.2-ce2e3' for regex '2.3'
Note, selecting 'libopenr2-3' for regex '2.3'
Note, selecting 'brhl2030lpr' for regex '2.3'
Note, selecting 'python2.3-pyxmpp' for regex '2.3'
Note, selecting 'libghc-tagged-prof-0.7-d243d' for regex '2.3'
Note, selecting 'python2.3-aubio' for regex '2.3'
Note, selecting 'python2.3-pychart' for regex '2.3'
Note, selecting 'libgraphite2-3-dbg' for regex '2.3'
Note, selecting 'libslepc2.3.2-dev' for regex '2.3'
Note, selecting 'python2.3-lasso' for regex '2.3'
Note, selecting 'libghc-wai-eventsource-dev-1.3.0.4-cf223' for regex '2.3'
Note, selecting 'ruby-activerecord-2.3' for regex '2.3'
Note, selecting 'libghc-cabal-file-th-dev-0.2.3-28de3' for regex '2.3'
Note, selecting 'libghc-colour-prof-2.3.3-8d8d4' for regex '2.3'
Note, selecting 'libghc-intervals-prof-0.2.2.1-02536' for regex '2.3'
Note, selecting 'python2.3-jabber' for regex '2.3'
Note, selecting 'libghc-filemanip-prof-0.3.6.2-2739f' for regex '2.3'
Note, selecting 'ruby-actionmailer-2.3' for regex '2.3'
Note, selecting 'python2.3-clearsilver' for regex '2.3'
Note, selecting 'libghc-filemanip-dev-0.3.6.2-2739f' for regex '2.3'
Note, selecting 'python2.3-tau' for regex '2.3'
Note, selecting 'libcamd2.3.1' for regex '2.3'
Note, selecting 'libsasl2-3' for regex '2.3'
Note, selecting 'python2.3-egenix-mxproxy' for regex '2.3'
Note, selecting 'python2.3-soappy' for regex '2.3'
Note, selecting 'libghc-pandoc-types-dev-1.12.3-12449' for regex '2.3'
Note, selecting 'cupswrapperhl2030' for regex '2.3'
Note, selecting 'libghc-webkit-dev-0.12.3-5567f' for regex '2.3'
Note, selecting 'python2.3-epydoc' for regex '2.3'
Note, selecting 'libghc-terminal-progress-bar-prof-0.0.1.3-6e2c3' for regex '2.3'
Note, selecting 'libghc-data-pprint-prof-0.2.3-2f7a9' for regex '2.3'
Note, selecting 'libghc-xmlhtml-prof-0.2.3-53dc0' for regex '2.3'
Note, selecting 'ruby-activeresource-2.3' for regex '2.3'
Note, selecting 'libghc-web-plugins-prof-0.2.3-6730c' for regex '2.3'
Note, selecting 'libbox2d2.3.0-dbg' for regex '2.3'
Note, selecting 'python2.3-xmldiff' for regex '2.3'
Note, selecting 'python2.3-egenix-mxdatetime' for regex '2.3'
Note, selecting 'python2.3-gamin' for regex '2.3'
Note, selecting 'python2.3-gdchart2' for regex '2.3'
Note, selecting 'libghc-incremental-parser-prof-0.2.3.2-ce2e3' for regex '2.3'
Note, selecting 'xfonts-jisx0213' for regex '2.3'
Note, selecting 'python2.3-ldap' for regex '2.3'
Note, selecting 'python2.3-elementtidy' for regex '2.3'
Note, selecting 'libsmokeknewstuff2-3' for regex '2.3'
Note, selecting 'python2.3-zsi' for regex '2.3'
Note, selecting 'postgresql-9.2-postgis-2.3-scripts' for regex '2.3'
Note, selecting 'libghc-sandi-dev-0.2.3-3ddc6' for regex '2.3'
Note, selecting 'python2.3-tcpwrap' for regex '2.3'
Note, selecting 'libghc-unordered-containers-dev' instead of 'libghc-unordered-containers-dev-0.2.3.0-9584b'
Note, selecting 'libghc-unordered-containers-prof' instead of 'libghc-unordered-containers-prof-0.2.3.0-9584b'
Note, selecting 'libghc-agda-dev' instead of 'libghc-agda-dev-2.3.2.2-ffa3d'
Note, selecting 'libghc-tagged-dev' instead of 'libghc-tagged-dev-0.7-d243d'
Note, selecting 'libghc-tagged-prof' instead of 'libghc-tagged-prof-0.7-d243d'
Note, selecting 'libghc-bmp-dev' instead of 'libghc-bmp-dev-1.2.3.4-dce3a'
Note, selecting 'libghc-bmp-prof' instead of 'libghc-bmp-prof-1.2.3.4-dce3a'
Note, selecting 'libghc-cabal-file-th-dev' instead of 'libghc-cabal-file-th-dev-0.2.3-28de3'
Note, selecting 'libghc-cabal-file-th-prof' instead of 'libghc-cabal-file-th-prof-0.2.3-28de3'
Note, selecting 'libghc-colour-dev' instead of 'libghc-colour-dev-2.3.3-8d8d4'
Note, selecting 'libghc-data-accessor-dev' instead of 'libghc-data-accessor-dev-0.2.2.3-f24d7'
Note, selecting 'libghc-colour-prof' instead of 'libghc-colour-prof-2.3.3-8d8d4'
Note, selecting 'libghc-data-accessor-prof' instead of 'libghc-data-accessor-prof-0.2.2.3-f24d7'
Note, selecting 'libghc-pandoc-types-dev' instead of 'libghc-pandoc-types-dev-1.12.3-12449'
Note, selecting 'libghc-pandoc-types-prof' instead of 'libghc-pandoc-types-prof-1.12.3-12449'
Note, selecting 'libghc-cpu-dev' instead of 'libghc-cpu-dev-0.1.2-3b02d'
Note, selecting 'libghc-cpu-prof' instead of 'libghc-cpu-prof-0.1.2-3b02d'
Note, selecting 'libghc-crypto-numbers-dev' instead of 'libghc-crypto-numbers-dev-0.2.3-28720'
Note, selecting 'libghc-crypto-numbers-prof' instead of 'libghc-crypto-numbers-prof-0.2.3-28720'
Note, selecting 'libghc-csv-dev' instead of 'libghc-csv-dev-0.1.2-3d3c6'
Note, selecting 'libghc-csv-prof' instead of 'libghc-csv-prof-0.1.2-3d3c6'
Note, selecting 'libghc-data-pprint-dev' instead of 'libghc-data-pprint-dev-0.2.3-2f7a9'
Note, selecting 'libghc-data-pprint-prof' instead of 'libghc-data-pprint-prof-0.2.3-2f7a9'
Note, selecting 'libghc-intervals-dev' instead of 'libghc-intervals-dev-0.2.2.1-02536'
Note, selecting 'libghc-intervals-prof' instead of 'libghc-intervals-prof-0.2.2.1-02536'
Note, selecting 'libghc-ed25519-dev' instead of 'libghc-ed25519-dev-0.0.2.0-9243f'
Note, selecting 'libghc-ed25519-prof' instead of 'libghc-ed25519-prof-0.0.2.0-9243f'
Note, selecting 'libghc-edison-api-dev' instead of 'libghc-edisonapi-dev-1.2.2-22f39'
Note, selecting 'libghc-edison-api-prof' instead of 'libghc-edisonapi-prof-1.2.2-22f39'
Note, selecting 'libghc-filemanip-dev' instead of 'libghc-filemanip-dev-0.3.6.2-2739f'
Note, selecting 'libghc-filemanip-prof' instead of 'libghc-filemanip-prof-0.3.6.2-2739f'
Note, selecting 'libghc-gtksourceview2-dev' instead of 'libghc-gtksourceview2-dev-0.12.3.1-95f4c'
Note, selecting 'libghc-gtksourceview2-prof' instead of 'libghc-gtksourceview2-prof-0.12.3.1-95f4c'
Note, selecting 'libghc-hdbc-dev' instead of 'libghc-hdbc-dev-2.3.1.2-28675'
Note, selecting 'libghc-hdbc-odbc-dev' instead of 'libghc-hdbc-odbc-dev-2.3.1.1-18eb1'
Note, selecting 'libghc-hdbc-prof' instead of 'libghc-hdbc-prof-2.3.1.2-28675'
Note, selecting 'libghc-hdbc-odbc-prof' instead of 'libghc-hdbc-odbc-prof-2.3.1.1-18eb1'
Note, selecting 'libghc-hdbc-postgresql-dev' instead of 'libghc-hdbc-postgresql-dev-2.3.2.1-90dce'
Note, selecting 'libghc-hdbc-postgresql-prof' instead of 'libghc-hdbc-postgresql-prof-2.3.2.1-90dce'
Note, selecting 'libghc-hdbc-sqlite3-dev' instead of 'libghc-hdbc-sqlite3-dev-2.3.3.0-bb2c3'
Note, selecting 'libghc-hdbc-sqlite3-prof' instead of 'libghc-hdbc-sqlite3-prof-2.3.3.0-bb2c3'
Note, selecting 'libghc-webkit-dev' instead of 'libghc-webkit-dev-0.12.3-5567f'
Note, selecting 'libghc-webkit-prof' instead of 'libghc-webkit-prof-0.12.3-5567f'
Note, selecting 'libghc-xmlhtml-dev' instead of 'libghc-xmlhtml-dev-0.2.3-53dc0'
Note, selecting 'libghc-xmlhtml-prof' instead of 'libghc-xmlhtml-prof-0.2.3-53dc0'
Note, selecting 'libghc-http-client-conduit-dev' instead of 'libghc-http-client-conduit-dev-0.2.0.0-02a37'
Note, selecting 'libghc-http-client-conduit-prof' instead of 'libghc-http-client-conduit-prof-0.2.0.0-02a37'
Note, selecting 'libghc-incremental-parser-dev' instead of 'libghc-incremental-parser-dev-0.2.3.2-ce2e3'
Note, selecting 'libghc-incremental-parser-prof' instead of 'libghc-incremental-parser-prof-0.2.3.2-ce2e3'
Note, selecting 'libghc-pipes-safe-dev' instead of 'libghc-pipes-safe-dev-2.0.2-335df'
Note, selecting 'libghc-pipes-safe-prof' instead of 'libghc-pipes-safe-prof-2.0.2-335df'
Note, selecting 'libghc-repa-dev' instead of 'libghc-repa-dev-3.2.3.3-1699c'
Note, selecting 'libghc-repa-prof' instead of 'libghc-repa-prof-3.2.3.3-1699c'
Note, selecting 'libghc-sandi-dev' instead of 'libghc-sandi-dev-0.2.3-3ddc6'
Note, selecting 'libghc-sandi-prof' instead of 'libghc-sandi-prof-0.2.3-3ddc6'
Note, selecting 'libghc-zlib-enum-dev' instead of 'libghc-zlib-enum-dev-0.2.3-511ac'
Note, selecting 'libghc-zlib-enum-prof' instead of 'libghc-zlib-enum-prof-0.2.3-511ac'
Note, selecting 'libghc-terminal-progress-bar-dev' instead of 'libghc-terminal-progress-bar-dev-0.0.1.3-6e2c3'
Note, selecting 'libghc-terminal-progress-bar-prof' instead of 'libghc-terminal-progress-bar-prof-0.0.1.3-6e2c3'
Note, selecting 'libghc-uuid-dev' instead of 'libghc-uuid-dev-1.2.3-9a1e0'
Note, selecting 'libghc-uuid-prof' instead of 'libghc-uuid-prof-1.2.3-9a1e0'
Note, selecting 'libghc-wai-eventsource-dev' instead of 'libghc-wai-eventsource-dev-1.3.0.4-cf223'
Note, selecting 'libghc-wai-eventsource-prof' instead of 'libghc-wai-eventsource-prof-1.3.0.4-cf223'
Note, selecting 'libghc-web-plugins-dev' instead of 'libghc-web-plugins-dev-0.2.3-6730c'
Note, selecting 'libghc-web-plugins-prof' instead of 'libghc-web-plugins-prof-0.2.3-6730c'
Note, selecting 'libghc-yesod-core-dev' instead of 'libghc-yesod-core-dev-1.2.3-7090b'
Note, selecting 'libghc-yesod-core-prof' instead of 'libghc-yesod-core-prof-1.2.3-7090b'
Note, selecting 'python-dialog' instead of 'python2.3-dialog'
Note, selecting 'python-lasso' instead of 'liblasso0-python2.3'
Note, selecting 'xtables-addons-common' instead of 'xtables-addons-common-2.3'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
liblwgeom-2.3-0 : Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
postgis : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
postgresql-9.2-postgis-2.3 : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
postgresql-9.3-postgis-2.3 : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
postgresql-9.4-postgis-2.3 : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
postgresql-9.5-postgis-2.3 : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
postgresql-9.6-postgis-2.3 : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
#run the command
sudo apt-cache policy postgis 2.3
libghc-hdbc-postgresql-prof-2.3.2.1-90dce:
Installed: (none)
Candidate: (none)
Version table:
postgresql-9.3-postgis-2.3-scripts:
Installed: (none)
Candidate: 2.3.0+dfsg-2.pgdg14.04+1
Version table:
2.3.0+dfsg-2.pgdg14.04+1 0
500 http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages
libghc-repa-dev-3.2.3.3-1699c:
Installed: (none)
Candidate: (none)
Version table:
python2.3-svn:
Installed: (none)
Candidate: (none)
Version table:
libghc-edisonapi-dev-1.2.2-22f39:
Installed: (none)
Candidate: (none)
Version table:
postgresql-9.2-postgis-2.3:
Installed: (none)
Candidate: 2.3.0+dfsg-2.pgdg14.04+1
Version table:
2.3.0+dfsg-2.pgdg14.04+1 0
500 http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages
python2.3-gpod:
Installed: (none)
Candidate: (none)
Version table:
python2.3-albatross:
Installed: (none)
Candidate: (none)
Version table:
libghc-terminal-progress-bar-dev-0.0.1.3-6e2c3:
Installed: (none)
Candidate: (none)
Version table:
python2.3-pymad:
Installed: (none)
Candidate: (none)
Version table:
python2.3-forgetsql:
Installed: (none)
Candidate: (none)
Version table:
python2.3-tk:
Installed: (none)
Candidate: (none)
Version table:
libapreq2-3:
Installed: (none)
Candidate: 2.13-3ubuntu2
Version table:
2.13-3ubuntu2 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
python2.3-hamlib3:
Installed: (none)
Candidate: (none)
Version table:
libghc-hdbc-odbc-dev-2.3.1.1-18eb1:
Installed: (none)
Candidate: (none)
Version table:
libicepatch2-35:
Installed: (none)
Candidate: 3.5.1-5.2
Version table:
3.5.1-5.2 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
libghc-csv-prof-0.1.2-3d3c6:
Installed: (none)
Candidate: (none)
Version table:
python2.3-twisted-web2:
Installed: (none)
Candidate: (none)
Version table:
python2.3-htmltmpl:
Installed: (none)
Candidate: (none)
Version table:
libghc-agda-dev-2.3.2.2-ffa3d:
Installed: (none)
Candidate: (none)
Version table:
libghc-intervals-dev-0.2.2.1-02536:
Installed: (none)
Candidate: (none)
Version table:
python2.3-egenix-mxstack:
Installed: (none)
Candidate: (none)
Version table:
libghc-yesod-core-prof-1.2.3-7090b:
Installed: (none)
Candidate: (none)
Version table:
libghc-cabal-file-th-prof-0.2.3-28de3:
Installed: (none)
Candidate: (none)
Version table:
python2.3-yappy:
Installed: (none)
Candidate: (none)
Version table:
python2.3-rpm:
Installed: (none)
Candidate: (none)
Version table:
python2.3-rpy:
Installed: (none)
Candidate: (none)
Version table:
python2.3-adns:
Installed: (none)
Candidate: (none)
Version table:
postgresql-9.5-postgis-2.3:
Installed: (none)
Candidate: 2.3.0+dfsg-2.pgdg14.04+1
Version table:
2.3.0+dfsg-2.pgdg14.04+1 0
500 http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages
gir1.2-webkit2-3.0:
Installed: (none)
Candidate: 2.4.10-0ubuntu0.14.04.1
Version table:
2.4.10-0ubuntu0.14.04.1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
2.4.0-1ubuntu2 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libghc-pipes-safe-prof-2.0.2-335df:
Installed: (none)
Candidate: (none)
Version table:
unison2.32.52-gtk:
Installed: (none)
Candidate: 2.32.52-7ubuntu1
Version table:
2.32.52-7ubuntu1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
python2.3-rrd:
Installed: (none)
Candidate: (none)
Version table:
libghc-uuid-dev-1.2.3-9a1e0:
Installed: (none)
Candidate: (none)
Version table:
python2.3-pythoncard:
Installed: (none)
Candidate: (none)
Version table:
libghc-csv-dev-0.1.2-3d3c6:
Installed: (none)
Candidate: (none)
Version table:
python2.3-gdbm:
Installed: (none)
Candidate: (none)
Version table:
libghc-colour-dev-2.3.3-8d8d4:
Installed: (none)
Candidate: (none)
Version table:
python2.3-biopython:
Installed: (none)
Candidate: (none)
Version table:
python2.3-slides:
Installed: (none)
Candidate: (none)
Version table:
libghc-http-client-conduit-prof-0.2.0.0-02a37:
Installed: (none)
Candidate: (none)
Version table:
libghc-data-accessor-prof-0.2.2.3-f24d7:
Installed: (none)
Candidate: (none)
Version table:
python2.3-egenix-mxqueue:
Installed: (none)
Candidate: (none)
Version table:
libamd2.3.1:
Installed: (none)
Candidate: 1:4.2.1-3ubuntu1
Version table:
1:4.2.1-3ubuntu1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
python2.3-mysqldb:
Installed: (none)
Candidate: (none)
Version table:
libghc-tagged-dev-0.7-d243d:
Installed: (none)
Candidate: (none)
Version table:
python2.3-gst0.10:
Installed: (none)
Candidate: (none)
Version table:
libsbjson2.3:
Installed: (none)
Candidate: 2.3.2-2build1
Version table:
2.3.2-2build1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
ruby-rails-2.3:
Installed: (none)
Candidate: (none)
Version table:
postgresql-9.5-postgis-2.3-scripts:
Installed: (none)
Candidate: 2.3.0+dfsg-2.pgdg14.04+1
Version table:
2.3.0+dfsg-2.pgdg14.04+1 0
500 http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages
python2.3-quixote:
Installed: (none)
Candidate: (none)
Version table:
libghc-hdbc-sqlite3-dev-2.3.3.0-bb2c3:
Installed: (none)
Candidate: (none)
Version table:
python2.3-fuse:
Installed: (none)
Candidate: (none)
Version table:
libghc-repa-prof-3.2.3.3-1699c:
Installed: (none)
Candidate: (none)
Version table:
libghc-hdbc-odbc-prof-2.3.1.1-18eb1:
Installed: (none)
Candidate: (none)
Version table:
python2.3-egenix-mxtools:
Installed: (none)
Candidate: (none)
Version table:
libminc2-3:
Installed: (none)
Candidate: 2.2.00-3
Version table:
2.2.00-3 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
qtdeclarative5-cordova-2.3-plugin:
Installed: (none)
Candidate: (none)
Version table:
python2.3-omniorb2-omg:
Installed: (none)
Candidate: (none)
Version table:
libghc-crypto-numbers-prof-0.2.3-28720:
Installed: (none)
Candidate: (none)
Version table:
libghc-unordered-containers-dev-0.2.3.0-9584b:
Installed: (none)
Candidate: (none)
Version table:
libghc-hdbc-sqlite3-prof-2.3.3.0-bb2c3:
Installed: (none)
Candidate: (none)
Version table:
libldap-2.3-0:
Installed: (none)
Candidate: (none)
Version table:
python2.3-iplib:
Installed: (none)
Candidate: (none)
Version table:
libghc-zlib-enum-prof-0.2.3-511ac:
Installed: (none)
Candidate: (none)
Version table:
python2.3-biopython-sql:
Installed: (none)
Candidate: (none)
Version table:
libghc-bmp-dev-1.2.3.4-dce3a:
Installed: (none)
Candidate: (none)
Version table:
python2.3-speex:
Installed: (none)
Candidate: (none)
Version table:
ruby-actionpack-2.3:
Installed: (none)
Candidate: (none)
Version table:
libghc-incremental-parser-dev-0.2.3.2-ce2e3:
Installed: (none)
Candidate: (none)
Version table:
libopenr2-3:
Installed: (none)
Candidate: 1.3.3-1
Version table:
1.3.3-1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
brhl2030lpr:
Installed: (none)
Candidate: (none)
Version table:
python2.3-pyxmpp:
Installed: (none)
Candidate: (none)
Version table:
libghc-tagged-prof-0.7-d243d:
Installed: (none)
Candidate: (none)
Version table:
python2.3-aubio:
Installed: (none)
Candidate: (none)
Version table:
python2.3-pychart:
Installed: (none)
Candidate: (none)
Version table:
libgraphite2-3-dbg:
Installed: (none)
Candidate: 1.3.6-1ubuntu0.14.04.1
Version table:
1.3.6-1ubuntu0.14.04.1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
1.2.4-1ubuntu1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libslepc2.3.2-dev:
Installed: (none)
Candidate: (none)
Version table:
python2.3-lasso:
Installed: (none)
Candidate: (none)
Version table:
libghc-wai-eventsource-dev-1.3.0.4-cf223:
Installed: (none)
Candidate: (none)
Version table:
ruby-activerecord-2.3:
Installed: (none)
Candidate: (none)
Version table:
libghc-cabal-file-th-dev-0.2.3-28de3:
Installed: (none)
Candidate: (none)
Version table:
libghc-colour-prof-2.3.3-8d8d4:
Installed: (none)
Candidate: (none)
Version table:
libghc-intervals-prof-0.2.2.1-02536:
Installed: (none)
Candidate: (none)
Version table:
python2.3-jabber:
Installed: (none)
Candidate: (none)
Version table:
libghc-filemanip-prof-0.3.6.2-2739f:
Installed: (none)
Candidate: (none)
Version table:
ruby-actionmailer-2.3:
Installed: (none)
Candidate: (none)
Version table:
python2.3-clearsilver:
Installed: (none)
Candidate: (none)
Version table:
libghc-filemanip-dev-0.3.6.2-2739f:
Installed: (none)
Candidate: (none)
Version table:
python2.3-tau:
Installed: (none)
Candidate: (none)
Version table:
libcamd2.3.1:
Installed: (none)
Candidate: 1:4.2.1-3ubuntu1
Version table:
1:4.2.1-3ubuntu1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libsasl2-3:
Installed: (none)
Candidate: (none)
Version table:
python2.3-egenix-mxproxy:
Installed: (none)
Candidate: (none)
Version table:
python2.3-soappy:
Installed: (none)
Candidate: (none)
Version table:
libghc-pandoc-types-dev-1.12.3-12449:
Installed: (none)
Candidate: (none)
Version table:
cupswrapperhl2030:
Installed: (none)
Candidate: (none)
Version table:
libghc-webkit-dev-0.12.3-5567f:
Installed: (none)
Candidate: (none)
Version table:
python2.3-epydoc:
Installed: (none)
Candidate: (none)
Version table:
libghc-terminal-progress-bar-prof-0.0.1.3-6e2c3:
Installed: (none)
Candidate: (none)
Version table:
libghc-data-pprint-prof-0.2.3-2f7a9:
Installed: (none)
Candidate: (none)
Version table:
libghc-xmlhtml-prof-0.2.3-53dc0:
Installed: (none)
Candidate: (none)
Version table:
ruby-activeresource-2.3:
Installed: (none)
Candidate: (none)
Version table:
libghc-web-plugins-prof-0.2.3-6730c:
Installed: (none)
Candidate: (none)
Version table:
libbox2d2.3.0-dbg:
Installed: (none)
Candidate: 2.3.0+ds-2
Version table:
2.3.0+ds-2 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
python2.3-xmldiff:
Installed: (none)
Candidate: (none)
Version table:
python2.3-egenix-mxdatetime:
Installed: (none)
Candidate: (none)
Version table:
python2.3-gamin:
Installed: (none)
Candidate: (none)
Version table:
python2.3-gdchart2:
Installed: (none)
Candidate: (none)
Version table:
libghc-incremental-parser-prof-0.2.3.2-ce2e3:
Installed: (none)
Candidate: (none)
Version table:
xfonts-jisx0213:
Installed: (none)
Candidate: 0+20040511-4
Version table:
0+20040511-4 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
python2.3-ldap:
Installed: (none)
Candidate: (none)
Version table:
python2.3-elementtidy:
Installed: (none)
Candidate: (none)
Version table:
libsmokeknewstuff2-3:
Installed: (none)
Candidate: 4:4.13.0-0ubuntu1
Version table:
4:4.13.0-0ubuntu1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
python2.3-zsi:
Installed: (none)
Candidate: (none)
Version table:
postgresql-9.2-postgis-2.3-scripts:
Installed: (none)
Candidate: 2.3.0+dfsg-2.pgdg14.04+1
Version table:
2.3.0+dfsg-2.pgdg14.04+1 0
500 http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages
libghc-sandi-dev-0.2.3-3ddc6:
Installed: (none)
Candidate: (none)
Version table:
python2.3-tcpwrap:
Installed: (none)
Candidate: (none)
Version table:
sudo apt-cache policy postgis
postgis:
Installed: (none)
Candidate: 2.3.0+dfsg-2.pgdg14.04+1
Version table:
2.3.0+dfsg-2.pgdg14.04+1 0
500 http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main amd64 Packages
2.2.2+dfsg-2~trusty0 0
500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main amd64 Packages
2.1.2+dfsg-2ubuntu0.1 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
2.1.2+dfsg-2 0
500 http://es.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
apt-cache depends postgis #it shows the dependency of the packages
postgis
Depends: libc6
Depends: libgdal1h
Depends: libgeos-c1
Depends: liblwgeom-2.3-0
Depends: libpq5
Suggests: postgis-gui
Recommends: postgresql-9.6-postgis-2.3
Recommends: postgis-doc
Conflicts: postgis:i386
sudo apt-cache show postgis
Package: postgis
Version: 2.3.0+dfsg-2.pgdg14.04+1
Architecture: amd64
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Installed-Size: 801
Depends: libc6 (>= 2.14), libgdal1h (>= 1.9.0), libgeos-c1 (>= 3.4.2), liblwgeom-2.3-0 (>= 2.0.0), libpq5
Recommends: postgresql-9.6-postgis-2.3, postgis-doc
Suggests: postgis-gui
Homepage: http://postgis.net/
Priority: optional
Section: misc
Filename: pool/main/p/postgis/postgis_2.3.0+dfsg-2.pgdg14.04+1_amd64.deb
Size: 577058
SHA256: 828ce1a01c3b30ff5dce2b192f8defcc0b2a92620ca7de414ba0564a0d0921c4
SHA1: 539b2d1eee694d552b1ddeed0991b26c1a0348d1
MD5sum: b8a2ab7aa5e0012e677a8d564d699ba2
Description-en: Geographic objects support for PostgreSQL
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL".
.
This package contains the PostGIS userland binaries, common files.
Description-md5: 71b1ab6dbb24f361235106dc71acd572
Package: postgis
Priority: optional
Section: misc
Installed-Size: 836
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Architecture: amd64
Version: 2.2.2+dfsg-2~trusty0
Recommends: postgresql-9.3-postgis-2.2, postgis-doc
Suggests: postgis-gui
Depends: libc6 (>= 2.14), libgdal20 (>= 2.0.1), libgeos-c1v5 (>= 3.4.2), liblwgeom-2.2-5 (>= 2.0.0), libpq5
Filename: pool/main/p/postgis/postgis_2.2.2+dfsg-2~trusty0_amd64.deb
Size: 564772
MD5sum: 2cb9adad1f089527930e244cd49b316b
SHA1: 018ac7d98873e414e025d7b0f4d116ac55e6bc1e
SHA256: 53f28bc25fd927c3da4a18d425291090c1d1e971d729705937b1f5086bb3f182
Description-en: Geographic objects support for PostgreSQL
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL".
.
This package contains the PostGIS userland binaries, common files.
Description-md5: 71b1ab6dbb24f361235106dc71acd572
Package: postgis
Priority: optional
Section: universe/misc
Installed-Size: 886
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Architecture: amd64
Version: 2.1.2+dfsg-2ubuntu0.1
Depends: libc6 (>= 2.14), libgdal1h (>= 1.9.0), libgeos-c1 (>= 3.4.2), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.14.0), liblwgeom-2.1.2 (>= 2.0.0), libpq5
Suggests: postgresql-9.3-postgis-2.1, postgis-doc
Filename: pool/universe/p/postgis/postgis_2.1.2+dfsg-2ubuntu0.1_amd64.deb
Size: 156234
MD5sum: 0cb613a28ff7c0cc3534ed38d5e4a5ff
SHA1: bd38017300d570834784c2810704d6d55a72f90c
SHA256: c7d88af4872e96628b18e24ef5966203c7fa809e41f753c1f516f9cbc9c7c68f
Description-en: Geographic objects support for PostgreSQL
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL".
.
This package contains the PostGIS userland binaries, common files.
Description-md5: 71b1ab6dbb24f361235106dc71acd572
Homepage: http://postgis.refractions.net/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Package: postgis
Priority: optional
Section: universe/misc
Installed-Size: 886
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Architecture: amd64
Version: 2.1.2+dfsg-2
Depends: libc6 (>= 2.14), libgdal1h (>= 1.9.0), libgeos-c1 (>= 3.4.2), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.14.0), liblwgeom-2.1.2 (>= 2.0.0), libpq5
Suggests: postgresql-9.3-postgis-2.1, postgis-doc
Filename: pool/universe/p/postgis/postgis_2.1.2+dfsg-2_amd64.deb
Size: 155920
MD5sum: 342facb2749fd943b9bcf81534818394
SHA1: c29dc8328eca8497606ddb63a51e544effe946bc
SHA256: 393e5f7f04c0965b04f1477df741821796379b7fbc903ea52bf12dfb8efd8f1d
Description-en: Geographic objects support for PostgreSQL
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL".
.
This package contains the PostGIS userland binaries, common files.
Description-md5: 71b1ab6dbb24f361235106dc71acd572
Homepage: http://postgis.refractions.net/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.