Skip to content

Instantly share code, notes, and snippets.

@MicahElliott
Created July 4, 2012 18:01
  • Star 18 You must be signed in to star a gist
  • Fork 5 You must be signed in to fork a gist
Star You must be signed in to star a gist
Save MicahElliott/3048622 to your computer and use it in GitHub Desktop.
Configure vim in arch linux for python runtime support

Steps to upgrade vim in arch linux for python runtime support

Python support is needed by vim in order to run things like Conque and Slimv. Arch keeps vim slim by only providing Python support in gvim. But you may prefer vim to gvim, so here's what's needed.

More ABS info.

# Install and run abs (sync)
sudo pacman -S abs
sudo abs
# Prepare a build area
mkdir ~/abs
cd ~/abs
# Make a local copy
cp -r /var/abs/extra/vim .
cd vim
vim PKBGUID
# Change the --disable-python options to "enable"
# Build the package
makepkg
# Wait for a while
# Install your new vim and runtime
sudo pacman -U vim-runtime-7.3.547-1-x86_64.pkg.tar.xz
sudo pacman -U vim-7.3.547-1-x86_64.pkg.tar.xz
# Check it for "+python"
vim --version
@iuuso
Copy link

iuuso commented Aug 20, 2014

Awesome. Thank you for this.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment