Created

Embed URL

HTTPS clone URL

SSH clone URL

You can clone with HTTPS or SSH.

Download Gist

Build log gnuradio using PyBOMBS

View grbuildlog
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123
[pacman@localhost pybombs]$ ./pybombs install gnuradio
[sudo] password for pacman:
Settled on prefix: /home/pacman/target
Initializing environmental variables...
/home/pacman/target/python/:/home/pacman/target/lib/python2.6/site-packages/:/home/pacman/target/lib64/python2.6/site-packages/:/home/pacman/target/lib/python2.6/dist-packages/:/home/pacman/target/lib64/python2.6/dist-packages/:/home/pacman/target/lib/python2.7/site-packages/:/home/pacman/target/lib64/python2.7/site-packages/:/home/pacman/target/lib/python2.7/dist-packages/:/home/pacman/target/lib64/python2.7/dist-packages/:/home/pacman/target/python/:/home/pacman/target/lib/python2.6/site-packages/:/home/pacman/target/lib64/python2.6/site-packages/:/home/pacman/target/lib/python2.6/dist-packages/:/home/pacman/target/lib64/python2.6/dist-packages/:/home/pacman/target/lib/python2.7/site-packages/:/home/pacman/target/lib64/python2.7/site-packages/:/home/pacman/target/lib/python2.7/dist-packages/:/home/pacman/target/lib64/python2.7/dist-packages/
---------- loading recipes -------------------
Loading recipes ...
Loading recipes ... done
---------- loading recipes finished ----------
 
checking for gnuradio
False
/home/pacman/pybombs/mod_pybombs/sysutils.py:588: RuntimeWarning: tempnam is a potential security risk to your program
tmpfile = os.tempnam(d);
TMPFILE = /home/pacman/target/fileEtS5xq
WRITE PERMS OK /home/pacman/target/fileEtS5xq
installing gnuradio
gnuradio dep [['make', 'boost', 'fftw', 'cppunit', 'swig', 'gsl', 'uhd', 'git', 'python', 'cheetah', 'wxpython', 'numpy', 'lxml', 'pygtk', 'pycairo', 'cmake', 'pyqt4', 'pyqwt5', 'gcc', 'ice', 'git', 'cmake']]
make dep [[]]
boost dep [['python', 'libbzip', 'wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of boost-devel (1.54.0) is >= than 1.53
fftw dep [['wget']]
cppunit dep [['wget']]
swig dep [['python', 'wget', 'gcc']]
gsl dep [['wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of gsl-devel (1.15) is >= than 1.13
uhd dep [['make', 'swig', 'python', 'libusb', 'git', 'cmake', 'cheetah', 'boost', 'gsl', 'numpy', 'cppunit', 'fftw', 'git', 'cmake']]
git dep [['wget', 'curl']]
python dep [['wget']]
cheetah dep [['python', 'wget', 'python']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of python-cheetah (2.4.4) is >= than 2.0.0
wxpython dep [['gtk2', 'python', 'swig', 'wget']]
numpy dep [['python', 'swig', 'wget', 'python']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of numpy (1.8.0) is >= than 1.5
lxml dep [['python', 'libxml', 'libxslt', 'setuptools', 'wget', 'python']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of python-lxml (3.3.3) is >= than 2.3.2
pygtk dep [['python', 'swig', 'gtk2', 'pygobject', 'pango', 'cairo', 'wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of pygtk2-devel (2.24.0) is >= than 2.17
pycairo dep [['cairo', 'python', 'wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of pycairo-devel (1.8.10) is >= than 1.8
cmake dep [['wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of cmake (2.8.12) is >= than 2.8.3
pyqt4 dep [['python', 'sip', 'qt4', 'wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of PyQt4-devel (4.10.2) is >= than 4.6.2
pyqwt5 dep [['qwt5', 'pyqt4', 'sip', 'wget']]
PyBombs.sysutils - INFO - have_rpm: Satisfies requirement...installed version of PyQwt-devel (5.2.0) is >= than 5.2
gcc dep [[]]
ice dep [['swig', 'mcpp', 'db48', 'libbzip', 'expat', 'python', 'wget', 'ssl']]
git dep [['wget', 'curl']]
cmake dep [['wget']]
packages to install: ['gnuradio']
install called (gnuradio)
install type priority: ['rpm', 'src']
install rpm called (gnuradio)
no rpm satisfiers available
install src called (gnuradio)
state = fetch
Current step: (gnuradio :: configure)
configure
(' \n CC=gcc CXX=g++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/home/pacman/target -DENABLE_GR_FCD=ON -DENABLE_DOXYGEN=ON -DENABLE_GR_LOG=ON -DENABLE_PERFORMANCE_COUNTERS=ON -DCMAKE_CXX_FLAGS=-fpermissive \n', ' \n CC=$cc CXX=$cxx cmake .. -DCMAKE_BUILD_TYPE=$cmakebuildtype -DCMAKE_INSTALL_PREFIX=$prefix $config_opt\n')
(' \n CC=gcc CXX=g++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/home/pacman/target -DENABLE_GR_FCD=ON -DENABLE_DOXYGEN=ON -DENABLE_GR_LOG=ON -DENABLE_PERFORMANCE_COUNTERS=ON -DCMAKE_CXX_FLAGS=-fpermissive \n', ' \n CC=gcc CXX=g++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/home/pacman/target -DENABLE_GR_FCD=ON -DENABLE_DOXYGEN=ON -DENABLE_GR_LOG=ON -DENABLE_PERFORMANCE_COUNTERS=ON -DCMAKE_CXX_FLAGS=-fpermissive \n')
bash exec (/home/pacman/pybombs/src/gnuradio/build)::
CC=gcc CXX=g++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/home/pacman/target -DENABLE_GR_FCD=ON -DENABLE_DOXYGEN=ON -DENABLE_GR_LOG=ON -DENABLE_PERFORMANCE_COUNTERS=ON -DCMAKE_CXX_FLAGS=-fpermissive
 
-- Extracting version information from git describe...
-- ADDING PERF COUNTERS
-- Minimum SWIG version required is 1.3.31
--
-- The build system will automatically enable all components.
-- Use -DENABLE_DEFAULT=OFF to disable components by default.
--
-- Configuring python-support support...
-- Dependency PYTHONLIBS_FOUND = TRUE
-- Dependency SWIG_FOUND = TRUE
-- Dependency SWIG_VERSION_CHECK = TRUE
-- Enabling python-support support.
-- Override with -DENABLE_PYTHON=ON/OFF
--
-- Configuring testing-support support...
-- Dependency CPPUNIT_FOUND = TRUE
-- Enabling testing-support support.
-- Override with -DENABLE_TESTING=ON/OFF
--
-- Configuring volk support...
-- Enabling volk support.
-- Override with -DENABLE_VOLK=ON/OFF
CMake Warning (dev) at volk/CMakeLists.txt:53 (include):
Syntax Warning in cmake code at
 
/home/pacman/pybombs/src/gnuradio/volk/cmake/GrPython.cmake:202:44
 
Argument not separated from preceding token by whitespace.
This warning is for project developers. Use -Wno-dev to suppress it.
 
CMake Warning (dev) at volk/CMakeLists.txt:53 (include):
Syntax Warning in cmake code at
 
/home/pacman/pybombs/src/gnuradio/volk/cmake/GrPython.cmake:202:92
 
Argument not separated from preceding token by whitespace.
This warning is for project developers. Use -Wno-dev to suppress it.
 
CMake Warning (dev) at volk/CMakeLists.txt:53 (include):
Syntax Warning in cmake code at
 
/home/pacman/pybombs/src/gnuradio/volk/cmake/GrPython.cmake:202:100
 
Argument not separated from preceding token by whitespace.
This warning is for project developers. Use -Wno-dev to suppress it.
 
--
-- Python checking for python >= 2.5
-- Python checking for python >= 2.5 - found
--
-- Python checking for cheetah >= 2.0.0
-- Python checking for cheetah >= 2.0.0 - not found
CMake Error at volk/CMakeLists.txt:62 (message):
Cheetah templates required to build VOLK
 
 
-- Configuring incomplete, errors occurred!
See also "/home/pacman/pybombs/src/gnuradio/build/CMakeFiles/CMakeOutput.log".
ERROR:root:PyBOMBS Configure step failed for package (gnuradio) please see bash output above for a reason (hint: look for the word Error)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.