Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Output which displays hanging before command
-----> Apt app detected
-----> Detected Aptfile or Stack changes, flushing cache
-----> Adding custom repositories
-----> Updating apt caches
Get:1 http://archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
Get:2 http://apt.postgresql.org/pub/repos/apt bionic-pgdg InRelease [46.3 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1,344 kB]
Get:6 http://apt.postgresql.org/pub/repos/apt bionic-pgdg/main amd64 Packages [293 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [11.3 MB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages [836 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [824 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1,351 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [1,128 kB]
Fetched 17.6 MB in 3s (6,601 kB/s)
Reading package lists...
-----> Fetching .debs for thrift-compiler
Reading package lists...
Building dependency tree...
The following NEW packages will be installed:
thrift-compiler
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 923 kB of archives.
After this operation, 2,978 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 thrift-compiler amd64 0.9.1-2.1 [923 kB]
Fetched 923 kB in 1s (1,507 kB/s)
Download complete and in download only mode
-----> Installing thrift-compiler_0.9.1-2.1_amd64.deb
-----> Writing profile script
-----> Rewrite package-config files
-----> CustomSSHKey app detected
-----> Successfully added custom SSH key
-----> Node.js app detected
-----> Creating runtime environment
NPM_CONFIG_LOGLEVEL=error
NODE_ENV=production
NODE_MODULES_CACHE=true
NODE_VERBOSE=false
-----> Installing binaries
engines.node (package.json): 10.x
engines.npm (package.json): unspecified (use default)
engines.yarn (package.json): unspecified (use default)
Resolving node version 10.x...
Downloading and installing node 10.19.0...
Using default npm version: 6.13.4
Resolving yarn version 1.x...
Downloading and installing yarn (1.22.0)...
Installed yarn 1.22.0
-----> Installing dependencies
Installing node modules (yarn.lock)
yarn install v1.22.0
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
$ cd frontend && yarn --pure-lockfile --production=false
yarn install v1.22.0
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
info fsevents@2.1.2: The platform "linux" is incompatible with this module.
info "fsevents@2.1.2" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@1.2.9: The platform "linux" is incompatible with this module.
info "fsevents@1.2.9" is an optional dependency and failed compatibility check. Excluding it from installation.
[4/5] Linking dependencies...
warning " > @angular/http@7.2.16" has incorrect peer dependency "@angular/core@7.2.16".
warning " > @angular/http@7.2.16" has incorrect peer dependency "@angular/platform-browser@7.2.16".
warning " > @ngrx/effects@8.6.0" has incorrect peer dependency "@angular/core@^8.0.0".
warning " > @ngrx/router-store@8.6.0" has incorrect peer dependency "@angular/common@^8.0.0".
warning " > @ngrx/router-store@8.6.0" has incorrect peer dependency "@angular/core@^8.0.0".
warning " > @ngrx/router-store@8.6.0" has incorrect peer dependency "@angular/router@^8.0.0".
warning " > @ngrx/store@8.6.0" has incorrect peer dependency "@angular/core@^8.0.0".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/animations@7.x || 8.x".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/cdk@7.x || 8.x".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/core@7.x || 8.x".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/common@7.x || 8.x".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/forms@7.x || 8.x".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/platform-browser@7.x || 8.x".
warning " > @swimlane/ngx-charts@12.1.0" has incorrect peer dependency "@angular/platform-browser-dynamic@7.x || 8.x".
[5/5] Building fresh packages...
Done in 184.35s.
-----> Build
Detected both "build" and "heroku-postbuild" scripts
Running heroku-postbuild (yarn)
yarn run v1.22.0
$ bin/build_frontend.sh
[1/5] Validating package.json...
[2/5] Resolving packages...
success Already up-to-date.
$ yarn run build:app && yarn run build:compress && yarn run sentry:postbuild
$ ng build --configuration=production && yarn build:index
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.