Skip to content

Instantly share code, notes, and snippets.

Avatar

R. de Wilde RdeWilde

View GitHub Profile
View output
$ flutter pub run ffigen -v fine
[ +122 ms] executing: [/home/robert/snap/flutter/common/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[ +31 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[ ] f25bd9c55c48c139524139b477d04b13e9f36b2c
[ ] executing: [/home/robert/snap/flutter/common/flutter/] git tag --contains HEAD
[ +202 ms] Exit code 0 from: git tag --contains HEAD
[ ] 1.21.0-1.0.pre
1.21.0-5.0.pre
[ +11 ms] executing: [/home/robert/snap/flutter/common/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[ +6 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
View console_output.log
$ gradle build -i > gradlebuild.log
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.intellij.ide.IdeEventQueue to constructor sun.awt.PostEventQueue(java.awt.EventQueue)
WARNING: Please consider reporting this to the maintainers of com.intellij.ide.IdeEventQueue
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
2019-12-10 13:32:56,018 [ 3754] WARN - ConfigurableExtensionPointUtil - ignore deprecated groupId: language for id: preferences.language.Kotlin.scripting
w: visitTypeAliasDescriptor() is ignored for now
w: visitTypeAliasDescriptor() is ignored for now
@RdeWilde
RdeWilde / build.gradle.kts
Created Dec 10, 2019
Export dependency to shared library
View build.gradle.kts
group = "com.mylib"
version = "0.0.1"
plugins {
idea
java
id("kotlin-multiplatform")
}
repositories {
View BigInteger.kt
expect class BigInteger(value: String) : Number, Comparable<BigInteger> {
}
// ...
typealias JvmBigInteger = java.math.BigInteger
actual class BigInteger actual constructor(value: String) : JvmBigInteger(value), Comparable<BigInteger> { // <<< Error below
// ..
View BigInteger.kt
//actual val java.math.BigInteger.NEGATIVE_ZERO : java.math.BigInteger = BigInteger("-1") // Extension property cannot be initialized because it has no backing field
//actual val java.math.BigInteger.NEGATIVE_ZERO : BigInteger = BigInteger("-1")
//actual val java.math.BigInteger.NEGATIVE_ZERO : BigInteger = java.math.BigInteger("-1")
actual typealias BigInteger = java.math.BigInteger
//actual val BigInteger.NEGATIVE_ZERO : java.math.BigInteger = BigInteger("-1") // Extension property cannot be initialized because it has no backing field
//actual val BigInteger.NEGATIVE_ZERO : BigInteger = BigInteger("-1")
//actual val BigInteger.NEGATIVE_ZERO : BigInteger = java.math.BigInteger("-1")
@RdeWilde
RdeWilde / btcpayments.rst
Created Aug 23, 2018 — forked from gavinandresen/btcpayments.rst
Bitcoin Payment Messages
View btcpayments.rst

SEE BIP 70

See https://en.bitcoin.it/wiki/BIP_0070 for the latest version of this document; I'll keep this document so the process of discussion/revision isn't lost.

Bitcoin Payment Messages

This document proposes protocol buffer-based formats for a simple payment protocol between a customer's bitcoin client software and a merchant.

View test.dart
ObservableList<Peer> sub = toObservable(server.peers) as ObservableList<Peer>;
sub.changes.listen((l) {
print('Changes');
});
sub.listChanges.listen((l) {
print('List');
});
server.peers.add(new Peer());
new Timer.periodic(new Duration(seconds: 5), (t) {
View crash
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_1_SWIFTTX found in database
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_2_SWIFTTX_BLOCK_FILTERING found in database
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_3_SWIFTTX_MAX_VALUE found in database
2018-04-02 16:26:22 LoadSporksFromDB : loaded spork SPORK_4_MASTERNODE_PAYMENT_ENFORCEMENT with value 1530000000 : Tue Jun 26 08:00:00 2018
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_5_MASTERNODE_BUDGET_ENFORCEMENT found in database
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_6_MASTERNODE_ENABLE_SUPERBLOCKS found in database
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_7_MASTERNODE_PAY_UPDATED_NODES found in database
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_8_NEW_PROTOCOL_ENFORCEMENT found in database
2018-04-02 16:26:22 LoadSporksFromDB : no previous value for SPORK_9_ZEROCOIN_MAINTENANCE_MODE found in databas
View Install protobuf 3 on Ubuntu
# Make sure you grab the latest version
curl -OL https://github.com/google/protobuf/releases/download/v3.2.0/protoc-3.2.0-linux-x86_64.zip
# Unzip
unzip protoc-3.2.0-linux-x86_64.zip -d protoc3
# Move protoc to /usr/local/bin/
sudo mv protoc3/bin/* /usr/local/bin/
# Move protoc3/include to /usr/local/include/
View gist:82b022ef6543f8ce69d28c5096adfd0d
Verifying my Blockstack ID is secured with the address 1Cx7hvpRhnrnkpDwqXhTKSWffKzfiNv7rF https://explorer.blockstack.org/address/1Cx7hvpRhnrnkpDwqXhTKSWffKzfiNv7rF