Skip to content

Instantly share code, notes, and snippets.

Avatar
💭
I may be slow to respond.

Sohan Tirpude SohanTirpude

💭
I may be slow to respond.
View GitHub Profile
View issue_#1280
$ git clone https://github.com/ChangezKhan/openlibrary.git
Cloning into 'openlibrary'...
remote: Enumerating objects: 1, done.
remote: Counting objects: 100% (1/1), done.
remote: Total 56278 (delta 0), reused 0 (delta 0), pack-reused 56277
Receiving objects: 100% (56278/56278), 44.31 MiB | 142.00 KiB/s, done.
Resolving deltas: 100% (41092/41092), done.
Checking out files: 100% (1907/1907), done.
View gist:e72671db34d5900fef39979f655aec76
$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'ubuntu/xenial64'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'ubuntu/xenial64' is up to date...
==> default: Setting the name of the VM: openlibrary_default_1539285812503_94776
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
View vagrant_up_issue
$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'ubuntu/xenial64' could not be found. Attempting to find and in stall...
default: Box Provider: virtualbox
default: Box Version: >= 0
==> default: Loading metadata for box 'ubuntu/xenial64'
default: URL: https://vagrantcloud.com/ubuntu/xenial64
==> default: Adding box 'ubuntu/xenial64' (v20181005.0.0) for provider: virtualb ox
default: Downloading: https://vagrantcloud.com/ubuntu/boxes/xenial64/version s/20181005.0.0/providers/virtualbox.box
default: Download redirected to host: cloud-images.ubuntu.com
View github_error.log
(pywebpush) kapil@sohan:~/Projects/pywebpush$ bin/pip install -r requirements.txt
Collecting cryptography<1.10,>=1.8.1 (from -r requirements.txt (line 1))
/home/kapil/Projects/pywebpush/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
SNIMissingWarning
/home/kapil/Projects/pywebpush/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer ve
View gist:b186ed3d92b69bfc575257379115ddf3
------------------------------------------------------------
/usr/bin/pip run on Mon Jul 3 23:32:32 2017
Downloading/unpacking pywebpush
Getting page https://pypi.python.org/simple/pywebpush/
URLs to search for versions for pywebpush:
* https://pypi.python.org/simple/pywebpush/
Analyzing links from page https://pypi.python.org/simple/pywebpush/
Found link https://pypi.python.org/packages/1e/aa/51c1a32212d929cd637c2ed020a52ff1979d1bf0e62560f36d3c9103ac51/pywebpush-0.6.1.tar.gz#md5=b395888b4f54f36489acbcc3b2385761 (from https://pypi.python.org/simple/pywebpush/), version: 0.6.1
Found link https://pypi.python.org/packages/23/39/8f5d7f0969f6e7ae391f91fc79c4e3b0c117c4344e40b7de6792a2384d99/pywebpush-1.0.4.tar.gz#md5=86975e4b38d9ece3259eea3eb5275082 (from https://pypi.python.org/simple/pywebpush/), version: 1.0.4
Found link https://pypi.python.org/packages/40/92/6fff79fee5f0535af59fa729ca0f1f014ca26753f03eba20137bf2dc98c9/pywebpush-0.7.0.tar.gz#md5=dc1b114b782c8eaf02f2f1a0643c8bc9 (from https:/