Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Install PHP7 on Raspberry PI or Debian or Ubuntu
#!/bin/bash
wget http://de1.php.net/get/php-7.0.0.tar.bz2/from/this/mirror
tar -xvjf mirror
cd php-7.0.0/
./configure \
--with-readline \
--enable-pcntl \
--with-gettext \
--enable-phpdbg \
--enable-phpdbg-webhelper \
--enable-mbstring \
--enable-zip \
--enable-bcmath \
--enable-ftp \
--enable-exif \
--enable-calendar \
--enable-sockets \
--enable-sysvmsg \
--enable-sysvsem \
--enable-sysvshm \
--enable-wddx \
--with-curl \
--with-mcrypt \
--with-iconv \
--with-pspell \
--with-gd \
--enable-gd-native-ttf \
--enable-gd-jis-conv \
--with-openssl \
--enable-soap \
--with-zlib-dir=/usr \
--with-zlib=/usr \
--with-bz2=/usr
make -j `nproc`
sudo make install
php -v
#!/bin/bash
sudo pear install PHP_Codesniffer
phpcs -i
<?php
phpinfo();
sudo php -S 0.0.0.0:80 phpinfo.php
@HansVanEijsden

This comment has been minimized.

@mycloa

This comment has been minimized.

Copy link

commented Dec 27, 2015

ty

@loi219

This comment has been minimized.

Copy link

commented Jan 14, 2016

I've some problems when I run ./configure and I found this thread: http://stackoverflow.com/questions/30987883/how-do-i-install-php-7-php-next-generation-on-ubuntu

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.