Skip to content

Instantly share code, notes, and snippets.

@aaizemberg

aaizemberg/GeoNode

Last active Dec 23, 2015
Embed
What would you like to do?
instalando un GeoNode 2.x en una maquina virtual con ubuntu 12.04 LTS
http://geonode.org/
google --> "foss4g 2013 geonode"
W7: GeoNode, A complete SDI
http://2013.foss4g.org/conf/programme/workshops/7/
W10: GeoNode Developers Workshop
http://2013.foss4g.org/conf/programme/workshops/6/
demo --> http://beta.dev.geonode.org/
blog --> http://geonode.org/blog/
docs --> http://docs.geonode.org/en/latest/
http://foss4g-na.org/wp-content/uploads/2012/03/state-of-geonode-2012.pdf
Código fuente en GitHub
https://github.com/GeoNode/geonode/
recomiendo participar reportando bugs o mejoras
bugs, issues --> https://github.com/GeoNode/geonode/issues?milestone=4&state=open
o ayudando a traducir
en, es, ... --> https://www.transifex.com/projects/p/geonode/
1.2 (estable, pero es de octubre del 2012)
2.0b61 (sigue en Beta, esta versión tiene 5 dias)
Quick Installation Guide
http://docs.geonode.org/en/dev/intro/install.html
On Ubuntu 12.04 and older:
sudo apt-get install python-software-properties
Release
sudo add-apt-repository ppa:geonode/release
ó
Testing
sudo add-apt-repository ppa:geonode/testing
sudo apt-get update
sudo apt-get install geonode (cofee break o almuerzo)
(opcional)
geonode validate
0 errores found
ifconfig
(mira la IP)
sudo geonode-updateip <IP>
geonode createsuperuser
Desde el navegador
http://<IP>/
listo
---------------------------------------------------------------------------------------------------------------------------
* Restarting web server apache2
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
... waiting .apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
Para solucionar lo del ServerName
http://askubuntu.com/questions/256013/could-not-reliably-determine-the-servers-fully-qualified-domain-name
editamos el apache2.conf
y agregamos
ServerName localhost
sudo service apache2 restart
---------------------------------------------------------------------------------------------------------------------------
Configuring GeoNode for Production
http://docs.geonode.org/en/latest/deploy/production.html
---------------------------------------------------------------------------------------------------------------------------
ariel@geonode:/var/log/postgresql$ sudo su - postgres
postgres@geonode:~$ psql -l
List of databases
Name | Owner | Encoding | Collate | Ctype | Access privileges
-----------+----------+----------+-------------+-------------+-----------------------
geonode | postgres | UTF8 | en_US.UTF8 | en_US.UTF8 |
postgres | postgres | UTF8 | en_US.UTF-8 | en_US.UTF-8 |
template0 | postgres | UTF8 | en_US.UTF-8 | en_US.UTF-8 | =c/postgres +
| | | | | postgres=CTc/postgres
template1 | postgres | UTF8 | en_US.UTF-8 | en_US.UTF-8 | =c/postgres +
| | | | | postgres=CTc/postgres
(4 rows)
postgres@geonode:~$ psql
\c geonodde
\d suelos_tuc
--------------
La imagen raster se recupera mediante esta URL
http://192.168.1.99/geoserver/wms?SERVICE=WMS&LAYERS=geonode%3Arecorte_tucuman_landsat_geocover_wgs84_utm_z20n&FORMAT=image%2Fpng&TRANSPARENT=TRUE&VERSION=1.1.1&REQUEST=GetMap&STYLES=&TILED=true&SRS=EPSG%3A900913&BBOX=-7378070.2323743,-3258344.1535733,-7064984.1645618,-2945258.0857608&WIDTH=256&HEIGHT=256
El geotif es solicitado con un SRS 900913
Revisar si el GeoTiff que esta en este directorio /usr/share/geoserver/data/data/default/ ya esta re-proyectado, o en cada pedido, se esta pasando de UTM20S a 900913, se puede usar el "gdalwarp" http://www.gdal.org/gdalwarp.html para hacer esto. Esteban seguramente va a usar el QGIS porque no le gusta la linea de comando.
los vectores (shapefiles) van al Postgresql
--------------
Enabling DEBUG mode
DEBUG=True
en
/etc/geonode/local_settings.py
sudo service apache2 restart
logs
====
/var/log/geonode/apache.log
/var/log/apache2/error.log
/usr/share/geoserver/data/logs/geoserver.log
/var/log/tomcat7/catalina.out
/var/log/postgresql/postgresql-9.1-main.log
--------------------
En algunas situaciones, cuando se esta haciendo un "preview" de un layer, se esta buscando en localhost y puerto 8080 al geoserver. Me parece que tocaron el codigo fuente, para que funcione con el LiveDVD de OSGeo 7.0 y no estan tomando los datos del /etc/geonode/local_settings.py
la GEOSERVER_BASE_URL no deberia ser esta --> "http://localhost:8080/geoserver/"
--------------------
Mapa temático (sobre el layers de suelos, usando el campo IND_PROD)
ind_prod R,G,B
< 33 229, 245, 224
>=33 y < 66 161, 217, 155
>= 66 49, 163, 84
@vlasvlasvlas

This comment has been minimized.

Copy link

@vlasvlasvlas vlasvlasvlas commented Apr 22, 2015

hola, disculpá! estoy probando tu tutorial, y me con ubuntu 12.04 me tira el siguiente error a la hora de ejecutar el install geonode:


root@ubuntu:/etc/apt# sudo apt-get install geonode
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
geonode : Depende: geoserver-geonode pero no va a instalarse o
geoserver pero no va a instalarse
Depende: python-virtualenv pero no es instalable
Depende: python-pyproj pero no es instalable
Depende: python-shapely pero no es instalable
Depende: gdal-bin pero no es instalable
Depende: libgeos-dev pero no es instalable
Depende: postgresql-9.1-postgis pero no es instalable o
postgresql-8.4-postgis pero no es instalable
Depende: python-gdal pero no es instalable
Depende: libproj-dev pero no es instalable
Depende: python-django-downloadview pero no va a instalarse
Depende: python-django-extensions pero no va a instalarse
Depende: python-django-user-accounts pero no va a instalarse
Depende: python-pycsw pero no va a instalarse
Depende: python-paver pero no va a instalarse
Depende: python-pinax-theme-bootstrap-account pero no va a instalarse
Depende: python-multipartposthandler pero no es instalable
Recomienda: python-gisdata pero no va a instalarse
Recomienda: transifex-client pero no es instalable
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


sabes cual puede ser el problema? gracias!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment