Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Compiling and installing `ffmpeg` with Decklink SDK on Ubuntu 18.04 Server
@stoyanovgeorge

This comment has been minimized.

Copy link

stoyanovgeorge commented Sep 30, 2019

I can confirm that ffmpeg 4.2 has compiled without a hitch with BMD SDK 11.4.

@sandervg

This comment has been minimized.

Copy link

sandervg commented Mar 16, 2020

It is not working with ffmpeg 4.2 and BMD SDK 11.5

@tech-nickel

This comment has been minimized.

Copy link

tech-nickel commented May 5, 2020

It is not working with ffmpeg 4.2 and BMD SDK 11.5

I can confirm, I'm still trying to find a version that compiles.

@stoyanovgeorge

This comment has been minimized.

Copy link

stoyanovgeorge commented May 6, 2020

@tech-nickel @sandervg did you guys manage to compile the BMD SDK 11.5? I think you need to execute sudo ldconfig after the compilation of the BMD SDK 11.5 otherwise ffmpeg won't be able to find the libraries of Blackmagic.

@tech-nickel

This comment has been minimized.

Copy link

tech-nickel commented May 6, 2020

@tech-nickel @sandervg did you guys manage to compile the BMD SDK 11.5? I think you need to execute sudo ldconfig after the compilation of the BMD SDK 11.5 otherwise ffmpeg won't be able to find the libraries of Blackmagic.

I ended up compiling ffmpeg 4.2 with the 11.4 SDK, that works fine.

@stoyanovgeorge

This comment has been minimized.

Copy link

stoyanovgeorge commented May 6, 2020

@tech-nickel yes, I didn't try to compile 11.5, but glad that you managed to do it!

@brendandower90

This comment has been minimized.

Copy link

brendandower90 commented Jun 25, 2020

Compiled with ffmpeg 4.2.3 and Desktop Video 11.5.1 on Ubuntu 20.04, however, I had to use sudo apt install libnuma-dev for x265 support to be enabled.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.