Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Joplin Android debug app dependencies
$ ./gradlew :app:dependencies --configuration debugRuntimeClasspath
> Configure project :app
WARNING:: The option setting 'android.jetifier.ignorelist=bcprov' is experimental.
> Configure project :react-native-securerandom
WARNING:: API 'variant.getJavaCompile()' is obsolete and has been replaced with 'variant.getJavaCompileProvider()'.
It will be removed in version 7.0 of the Android Gradle plugin.
For more information, see https://d.android.com/r/tools/task-configuration-avoidance.
To determine what is calling variant.getJavaCompile(), use -Pandroid.debug.obsoleteApi=true on the command line to display more information.
> Task :app:dependencies
------------------------------------------------------------
Project ':app'
------------------------------------------------------------
debugRuntimeClasspath - Resolved configuration for runtime for variant: debug
+--- com.facebook.flipper:flipper:0.99.0
| +--- com.facebook.soloader:soloader:0.10.1
| | +--- com.facebook.soloader:annotation:0.10.1
| | \--- com.facebook.soloader:nativeloader:0.10.1
| +--- com.google.code.findbugs:jsr305:3.0.2
| +--- androidx.appcompat:appcompat:1.3.0
| | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | +--- androidx.core:core:1.5.0
| | | +--- androidx.annotation:annotation:1.2.0
| | | +--- androidx.lifecycle:lifecycle-runtime:2.0.0 -> 2.3.1
| | | | +--- androidx.arch.core:core-runtime:2.1.0
| | | | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | | | \--- androidx.arch.core:core-common:2.1.0
| | | | | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | | +--- androidx.lifecycle:lifecycle-common:2.3.1
| | | | | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | | +--- androidx.arch.core:core-common:2.1.0 (*)
| | | | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | +--- androidx.versionedparcelable:versionedparcelable:1.1.1
| | | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | | \--- androidx.collection:collection:1.0.0 -> 1.1.0
| | | | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | \--- androidx.collection:collection:1.0.0 -> 1.1.0 (*)
| | +--- androidx.cursoradapter:cursoradapter:1.0.0
| | | \--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | +--- androidx.activity:activity:1.2.3
| | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | +--- androidx.core:core:1.1.0 -> 1.5.0 (*)
| | | +--- androidx.lifecycle:lifecycle-runtime:2.3.1 (*)
| | | +--- androidx.lifecycle:lifecycle-viewmodel:2.3.1
| | | | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | +--- androidx.savedstate:savedstate:1.1.0
| | | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | | +--- androidx.arch.core:core-common:2.0.1 -> 2.1.0 (*)
| | | | \--- androidx.lifecycle:lifecycle-common:2.0.0 -> 2.3.1 (*)
| | | +--- androidx.lifecycle:lifecycle-viewmodel-savedstate:2.3.1
| | | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | | +--- androidx.savedstate:savedstate:1.1.0 (*)
| | | | +--- androidx.lifecycle:lifecycle-livedata-core:2.3.1
| | | | | +--- androidx.arch.core:core-common:2.1.0 (*)
| | | | | +--- androidx.arch.core:core-runtime:2.1.0 (*)
| | | | | \--- androidx.lifecycle:lifecycle-common:2.3.1 (*)
| | | | \--- androidx.lifecycle:lifecycle-viewmodel:2.3.1 (*)
| | | +--- androidx.collection:collection:1.0.0 -> 1.1.0 (*)
| | | \--- androidx.tracing:tracing:1.0.0
| | | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | +--- androidx.fragment:fragment:1.3.4
| | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | +--- androidx.core:core:1.2.0 -> 1.5.0 (*)
| | | +--- androidx.collection:collection:1.1.0 (*)
| | | +--- androidx.viewpager:viewpager:1.0.0
| | | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | | \--- androidx.customview:customview:1.0.0
| | | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | | \--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | +--- androidx.loader:loader:1.0.0
| | | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | | +--- androidx.lifecycle:lifecycle-livedata:2.0.0
| | | | | +--- androidx.arch.core:core-runtime:2.0.0 -> 2.1.0 (*)
| | | | | +--- androidx.lifecycle:lifecycle-livedata-core:2.0.0 -> 2.3.1 (*)
| | | | | \--- androidx.arch.core:core-common:2.0.0 -> 2.1.0 (*)
| | | | \--- androidx.lifecycle:lifecycle-viewmodel:2.0.0 -> 2.3.1 (*)
| | | +--- androidx.activity:activity:1.2.2 -> 1.2.3 (*)
| | | +--- androidx.lifecycle:lifecycle-livedata-core:2.3.1 (*)
| | | +--- androidx.lifecycle:lifecycle-viewmodel:2.3.1 (*)
| | | +--- androidx.lifecycle:lifecycle-viewmodel-savedstate:2.3.1 (*)
| | | +--- androidx.savedstate:savedstate:1.1.0 (*)
| | | \--- androidx.annotation:annotation-experimental:1.0.0
| | +--- androidx.appcompat:appcompat-resources:1.3.0
| | | +--- androidx.collection:collection:1.0.0 -> 1.1.0 (*)
| | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | +--- androidx.core:core:1.0.1 -> 1.5.0 (*)
| | | +--- androidx.vectordrawable:vectordrawable:1.1.0
| | | | +--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| | | | +--- androidx.core:core:1.1.0 -> 1.5.0 (*)
| | | | \--- androidx.collection:collection:1.1.0 (*)
| | | \--- androidx.vectordrawable:vectordrawable-animated:1.1.0
| | | +--- androidx.vectordrawable:vectordrawable:1.1.0 (*)
| | | +--- androidx.interpolator:interpolator:1.0.0
| | | | \--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | \--- androidx.collection:collection:1.1.0 (*)
| | +--- androidx.drawerlayout:drawerlayout:1.0.0
| | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | \--- androidx.customview:customview:1.0.0 (*)
| | +--- androidx.savedstate:savedstate:1.1.0 (*)
| | +--- androidx.collection:collection:1.0.0 -> 1.1.0 (*)
| | +--- androidx.lifecycle:lifecycle-runtime:2.3.1 (*)
| | \--- androidx.lifecycle:lifecycle-viewmodel:2.3.1 (*)
| \--- androidx.sqlite:sqlite-framework:2.1.0
| +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| \--- androidx.sqlite:sqlite:2.1.0
| \--- androidx.annotation:annotation:1.0.0 -> 1.2.0
+--- com.facebook.flipper:flipper-network-plugin:0.99.0
+--- com.facebook.flipper:flipper-fresco-plugin:0.99.0
| +--- com.facebook.fresco:fresco:2.5.0
| | +--- com.facebook.fresco:soloader:2.5.0
| | | +--- com.facebook.fresco:fbcore:2.5.0
| | | \--- com.facebook.soloader:soloader:0.10.1 (*)
| | +--- com.facebook.soloader:nativeloader:0.10.1
| | +--- com.facebook.fresco:ui-common:2.5.0
| | | \--- com.facebook.fresco:fbcore:2.5.0
| | +--- com.facebook.fresco:fbcore:2.5.0
| | +--- com.facebook.fresco:drawee:2.5.0
| | | +--- com.facebook.fresco:fbcore:2.5.0
| | | +--- com.facebook.fresco:imagepipeline:2.5.0
| | | | +--- com.facebook.soloader:nativeloader:0.10.1
| | | | +--- com.facebook.soloader:annotation:0.10.1
| | | | +--- com.parse.bolts:bolts-tasks:1.4.0
| | | | +--- com.facebook.fresco:fbcore:2.5.0
| | | | \--- com.facebook.fresco:imagepipeline-base:2.5.0
| | | | +--- com.facebook.infer.annotation:infer-annotation:0.18.0
| | | | | +--- com.google.code.findbugs:jsr305:3.0.1 -> 3.0.2
| | | | | \--- org.jetbrains.kotlin:kotlin-annotations-jvm:1.3.72
| | | | +--- com.facebook.soloader:annotation:0.10.1
| | | | +--- com.parse.bolts:bolts-tasks:1.4.0
| | | | \--- com.facebook.fresco:fbcore:2.5.0
| | | +--- com.facebook.fresco:imagepipeline-native:2.5.0
| | | | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | | | +--- com.facebook.fresco:fbcore:2.5.0
| | | | \--- com.facebook.soloader:soloader:0.10.1 (*)
| | | +--- com.facebook.fresco:memory-type-ashmem:2.5.0
| | | | +--- com.facebook.fresco:fbcore:2.5.0
| | | | \--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-native:2.5.0
| | | | +--- com.facebook.fresco:fbcore:2.5.0
| | | | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | | | +--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | | | \--- com.facebook.soloader:nativeloader:0.10.1
| | | +--- com.facebook.fresco:memory-type-java:2.5.0
| | | | +--- com.facebook.fresco:fbcore:2.5.0
| | | | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | | | \--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | | +--- com.facebook.fresco:ui-common:2.5.0 (*)
| | | \--- com.facebook.fresco:middleware:2.5.0
| | | +--- com.facebook.fresco:fbcore:2.5.0
| | | \--- com.facebook.fresco:ui-common:2.5.0 (*)
| | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | +--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-ashmem:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-native:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-java:2.5.0 (*)
| | +--- com.facebook.fresco:nativeimagefilters:2.5.0
| | | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | | +--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-ashmem:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-native:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-java:2.5.0 (*)
| | | +--- com.facebook.soloader:nativeloader:0.10.1
| | | +--- com.parse.bolts:bolts-tasks:1.4.0
| | | \--- com.facebook.fresco:fbcore:2.5.0
| | \--- com.facebook.fresco:nativeimagetranscoder:2.5.0
| | +--- com.facebook.fresco:imagepipeline-base:2.5.0 (*)
| | +--- com.facebook.soloader:nativeloader:0.10.1
| | +--- com.parse.bolts:bolts-tasks:1.4.0
| | \--- com.facebook.fresco:fbcore:2.5.0
| +--- com.facebook.fresco:flipper:2.5.0
| | +--- com.facebook.fresco:fresco:2.5.0 (*)
| | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | +--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-ashmem:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-native:2.5.0 (*)
| | \--- com.facebook.fresco:memory-type-java:2.5.0 (*)
| +--- com.facebook.fresco:stetho:2.5.0
| | +--- com.facebook.fresco:fresco:2.5.0 (*)
| | +--- com.facebook.fresco:fbcore:2.5.0
| | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | +--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-ashmem:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-native:2.5.0 (*)
| | +--- com.facebook.fresco:memory-type-java:2.5.0 (*)
| | \--- com.facebook.fresco:imagepipeline-base:2.5.0 (*)
| +--- com.parse.bolts:bolts-tasks:1.4.0
| \--- com.parse.bolts:bolts-applinks:1.4.0
| \--- com.parse.bolts:bolts-tasks:1.4.0
+--- project :react-native-camera
| +--- com.facebook.react:react-native:+ -> 0.66.1
| | +--- com.facebook.infer.annotation:infer-annotation:0.18.0 (*)
| | +--- com.facebook.yoga:proguard-annotations:1.19.0
| | +--- javax.inject:javax.inject:1
| | +--- androidx.appcompat:appcompat:1.0.2 -> 1.3.0 (*)
| | +--- androidx.autofill:autofill:1.1.0
| | | \--- androidx.core:core:1.1.0 -> 1.5.0 (*)
| | +--- androidx.swiperefreshlayout:swiperefreshlayout:1.0.0
| | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | \--- androidx.interpolator:interpolator:1.0.0 (*)
| | +--- com.facebook.fresco:fresco:2.5.0 (*)
| | +--- com.facebook.fresco:imagepipeline-okhttp3:2.5.0
| | | +--- com.facebook.fresco:fbcore:2.5.0
| | | +--- com.facebook.fresco:imagepipeline:2.5.0 (*)
| | | +--- com.facebook.fresco:imagepipeline-native:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-ashmem:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-native:2.5.0 (*)
| | | +--- com.facebook.fresco:memory-type-java:2.5.0 (*)
| | | \--- com.squareup.okhttp3:okhttp:3.12.1 -> 4.9.1
| | | +--- com.squareup.okio:okio:2.8.0 -> 2.9.0
| | | | +--- org.jetbrains.kotlin:kotlin-stdlib:1.4.10
| | | | | +--- org.jetbrains.kotlin:kotlin-stdlib-common:1.4.10
| | | | | \--- org.jetbrains:annotations:13.0
| | | | \--- org.jetbrains.kotlin:kotlin-stdlib-common:1.4.10
| | | \--- org.jetbrains.kotlin:kotlin-stdlib:1.4.10 (*)
| | +--- com.facebook.fresco:ui-common:2.5.0 (*)
| | +--- com.facebook.soloader:soloader:0.10.1 (*)
| | +--- com.google.code.findbugs:jsr305:3.0.2
| | +--- com.squareup.okhttp3:okhttp:4.9.1 (*)
| | +--- com.squareup.okhttp3:okhttp-urlconnection:4.9.1
| | | +--- com.squareup.okhttp3:okhttp:4.9.1 (*)
| | | \--- org.jetbrains.kotlin:kotlin-stdlib-jdk8:1.4.10
| | | +--- org.jetbrains.kotlin:kotlin-stdlib:1.4.10 (*)
| | | \--- org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.4.10
| | | \--- org.jetbrains.kotlin:kotlin-stdlib:1.4.10 (*)
| | +--- com.squareup.okio:okio:2.9.0 (*)
| | \--- com.facebook.fbjni:fbjni-java-only:0.2.2
| | \--- com.facebook.soloader:nativeloader:0.10.1
| +--- com.google.zxing:core:3.3.3
| +--- com.drewnoakes:metadata-extractor:2.11.0
| | \--- com.adobe.xmp:xmpcore:5.1.3
| +--- androidx.exifinterface:exifinterface:1.3.2
| | \--- androidx.annotation:annotation:1.1.0 -> 1.2.0
| +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| \--- androidx.legacy:legacy-support-v4:1.0.0
| +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| +--- androidx.media:media:1.0.0
| | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | \--- androidx.versionedparcelable:versionedparcelable:1.0.0 -> 1.1.1 (*)
| +--- androidx.legacy:legacy-support-core-utils:1.0.0
| | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | +--- androidx.documentfile:documentfile:1.0.0 -> 1.0.1
| | | \--- androidx.annotation:annotation:1.0.2 -> 1.2.0
| | +--- androidx.loader:loader:1.0.0 (*)
| | +--- androidx.localbroadcastmanager:localbroadcastmanager:1.0.0
| | | \--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | \--- androidx.print:print:1.0.0
| | \--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| +--- androidx.legacy:legacy-support-core-ui:1.0.0
| | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | +--- androidx.legacy:legacy-support-core-utils:1.0.0 (*)
| | +--- androidx.customview:customview:1.0.0 (*)
| | +--- androidx.viewpager:viewpager:1.0.0 (*)
| | +--- androidx.coordinatorlayout:coordinatorlayout:1.0.0
| | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | \--- androidx.customview:customview:1.0.0 (*)
| | +--- androidx.drawerlayout:drawerlayout:1.0.0 (*)
| | +--- androidx.slidingpanelayout:slidingpanelayout:1.0.0
| | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | +--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | | \--- androidx.customview:customview:1.0.0 (*)
| | +--- androidx.interpolator:interpolator:1.0.0 (*)
| | +--- androidx.swiperefreshlayout:swiperefreshlayout:1.0.0 (*)
| | +--- androidx.asynclayoutinflater:asynclayoutinflater:1.0.0
| | | +--- androidx.annotation:annotation:1.0.0 -> 1.2.0
| | | \--- androidx.core:core:1.0.0 -> 1.5.0 (*)
| | \--- androidx.cursoradapter:cursoradapter:1.0.0 (*)
| \--- androidx.fragment:fragment:1.0.0 -> 1.3.4 (*)
+--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- androidx.swiperefreshlayout:swiperefreshlayout:1.0.0 (*)
+--- org.webkit:android-jsc-intl:+ -> r241213
+--- com.android.support:multidex:2.0.1 -> androidx.multidex:multidex:2.0.0
+--- project :joplin_react-native-saf-x
| +--- com.facebook.react:react-native:+ -> 0.66.1 (*)
| \--- androidx.documentfile:documentfile:1.0.1 (*)
+--- project :react-native-community_clipboard
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-community_datetimepicker
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-community_geolocation
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-community_netinfo
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-community_slider
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :joplin-rn-alarm-notification
| +--- com.facebook.react:react-native:+ -> 0.66.1 (*)
| +--- com.google.code.gson:gson:2.8.8
| \--- androidx.appcompat:appcompat:1.1.0 -> 1.3.0 (*)
+--- project :react-native-document-picker
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-file-viewer
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-fs
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-get-random-values
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-image-picker
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-image-resizer
| \--- androidx.exifinterface:exifinterface:1.3.2 (*)
+--- project :react-native-quick-actions
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-rsa-native
| +--- com.facebook.react:react-native:+ -> 0.66.1 (*)
| +--- com.madgag.spongycastle:core:1.56.0.0
| +--- com.madgag.spongycastle:prov:1.56.0.0
| | \--- com.madgag.spongycastle:core:1.56.0.0
| \--- com.madgag.spongycastle:bcpkix-jdk15on:1.56.0.0
| +--- com.madgag.spongycastle:core:1.56.0.0
| \--- com.madgag.spongycastle:prov:1.56.0.0 (*)
+--- project :react-native-securerandom
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-share
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-sqlite-storage
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-vector-icons
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-version-info
| \--- com.facebook.react:react-native:+ -> 0.66.1 (*)
+--- project :react-native-webview
| +--- com.facebook.react:react-native:+ -> 0.66.1 (*)
| \--- org.jetbrains.kotlin:kotlin-stdlib:1.3.50 -> 1.4.10 (*)
\--- project :rn-fetch-blob
\--- com.facebook.react:react-native:+ -> 0.66.1 (*)
(*) - dependencies omitted (listed previously)
A web-based, searchable dependency report is available by adding the --scan option.
Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.9/userguide/command_line_interface.html#sec:command_line_warnings
BUILD SUCCESSFUL in 4s
1 actionable task: 1 executed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment