Skip to content

Instantly share code, notes, and snippets.

@aitor

aitor/run.sh

Created Aug 1, 2019
Embed
What would you like to do?
> pip2.7 install otpsecure  
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Collecting otpsecure
Requirement already satisfied: beautifulsoup4 in /usr/local/lib/python2.7/site-packages (from otpsecure) (4.8.0)
Requirement already satisfied: pycrypto>=2.6.1 in /usr/local/lib/python2.7/site-packages (from otpsecure) (2.6.1)
Requirement already satisfied: requests>=2.4.1 in /usr/local/lib/python2.7/site-packages (from otpsecure) (2.22.0)
Requirement already satisfied: soupsieve>=1.2 in /usr/local/lib/python2.7/site-packages (from beautifulsoup4->otpsecure) (1.9.2)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python2.7/site-packages (from requests>=2.4.1->otpsecure) (1.25.3)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/site-packages (from requests>=2.4.1->otpsecure) (2019.6.16)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/site-packages (from requests>=2.4.1->otpsecure) (3.0.4)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python2.7/site-packages (from requests>=2.4.1->otpsecure) (2.8)
Requirement already satisfied: backports.functools-lru-cache; python_version < "3" in /usr/local/lib/python2.7/site-packages (from soupsieve>=1.2->beautifulsoup4->otpsecure) (1.5)
Installing collected packages: otpsecure
Successfully installed otpsecure-1.0.6
> python2.7 otpsecure.py  
Traceback (most recent call last):
File "otpsecure.py", line 20, in <module>
client = otpsecure.Client(APIKEY, SECRET)
AttributeError: 'module' object has no attribute 'Client'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment