Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
DeVault gitian build
[396/517] Linking CXX executable devault-tx
ld: warning: PIE disabled. Absolute addressing (perhaps -mdynamic-no-pic) not allowed in code signed PIE, but used in ___gmpn_divexact_1 from ../depends/x86_64-apple-darwin14/lib/libgmp.a(dive_1.o). To fix this warning, don't compile with -mdynamic-no-pic or link with -Wl,-no_pie
[413/517] Linking CXX executable devaultd
ld: warning: PIE disabled. Absolute addressing (perhaps -mdynamic-no-pic) not allowed in code signed PIE, but used in ___gmpn_divexact_1 from ../depends/x86_64-apple-darwin14/lib/libgmp.a(dive_1.o). To fix this warning, don't compile with -mdynamic-no-pic or link with -Wl,-no_pie
[517/517] Linking CXX executable DeVault-Core
ld: warning: direct access in function 'QtPrivate::QStringList_removeDuplicates(QStringList*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qstringlist.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QtPrivate::QStringList_removeDuplicates(QStringList*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qstringlist.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QtPrivate::QStringList_removeDuplicates(QStringList*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qstringlist.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QtPrivate::QStringList_removeDuplicates(QStringList*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qstringlist.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QtPrivate::QStringList_removeDuplicates(QStringList*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qstringlist.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::duplicateNode(QHashData::Node*, void*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QDirIteratorPrivate::QDirIteratorPrivate(QFileSystemEntry const&, QStringList const&, QFlags<QDir::Filter>, QFlags<QDirIterator::IteratorFlag>, bool)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qdiriterator.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QDirIteratorPrivate::~QDirIteratorPrivate()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qdiriterator.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QResourcePrivate::ensureChildren() const' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qresource.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QResourcePrivate::ensureChildren() const' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qresource.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHash<QString, QHashDummyValue>::insert(QString const&, QHashDummyValue const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qresource.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHash<QString, QHashDummyValue>::insert(QString const&, QHashDummyValue const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qresource.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHash<QString, QHashDummyValue>::insert(QString const&, QHashDummyValue const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qresource.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::duplicateNode(QHashData::Node*, void*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QFileSystemEngine::slowCanonicalized(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qfilesystemengine.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QFileSystemEngine::slowCanonicalized(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qfilesystemengine.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QFileSystemEngine::slowCanonicalized(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qfilesystemengine.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QFileSystemEngine::slowCanonicalized(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qfilesystemengine.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QItemSelectionModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qitemselectionmodel.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QItemSelectionModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qitemselectionmodel.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z17qRegisterMetaTypeI14QItemSelectionEiPKcPT_N9QtPrivate21MetaTypeDefinedHelperIS3_Xaasr12QMetaTypeId2IS3_EE7Definedntsr12QMetaTypeId2IS3_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qitemselectionmodel.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z17qRegisterMetaTypeI14QItemSelectionEiPKcPT_N9QtPrivate21MetaTypeDefinedHelperIS3_Xaasr12QMetaTypeId2IS3_EE7Definedntsr12QMetaTypeId2IS3_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qitemselectionmodel.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z17qRegisterMetaTypeI14QItemSelectionEiPKcPT_N9QtPrivate21MetaTypeDefinedHelperIS3_Xaasr12QMetaTypeId2IS3_EE7Definedntsr12QMetaTypeId2IS3_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qitemselectionmodel.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QItemSelection, true>::Construct(void*, void const*)' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z17qRegisterMetaTypeI14QItemSelectionEiPKcPT_N9QtPrivate21MetaTypeDefinedHelperIS3_Xaasr12QMetaTypeId2IS3_EE7Definedntsr12QMetaTypeId2IS3_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qitemselectionmodel.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QItemSelection, true>::Destruct(void*)' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QSingleShotTimer::QSingleShotTimer(int, Qt::TimerType, QObject const*, QtPrivate::QSlotObjectBase*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qtimer.o)' to global weak symbol 'QtPrivate::QSlotObject<void (QObject::*)(), QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*)' from file 'src/qt/CMakeFiles/DeVault-Core.dir/bitcoin.cpp.o' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMimeBinaryProvider::~QMimeBinaryProvider()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qmimeprovider.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMimeBinaryProvider::loadMimeTypeList()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qmimeprovider.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMimeBinaryProvider::loadMimeTypeList()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Core.a(qmimeprovider.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QAction*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qactiongroup.o)' to global weak symbol 'QMetaTypeIdQObject<QAction*, 8>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QAction*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qactiongroup.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QAction*, true>::Construct(void*, void const*)' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QAction*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qactiongroup.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QAction*, true>::Destruct(void*)' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QAction*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qactiongroup.o)' to global weak symbol 'QMetaTypeIdQObject<QAction*, 8>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QWidget*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qwidgetsvariant.o)' to global weak symbol 'QMetaTypeIdQObject<QWidget*, 8>::qt_metatype_id()::metatype_id' from file 'src/qt/CMakeFiles/DeVault-Core.dir/bitcoin.cpp.o' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QWidget*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qwidgetsvariant.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QWidget*, true>::Construct(void*, void const*)' from file 'src/qt/CMakeFiles/DeVault-Core.dir/bitcoin.cpp.o' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QWidget*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qwidgetsvariant.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QWidget*, true>::Destruct(void*)' from file 'src/qt/CMakeFiles/DeVault-Core.dir/bitcoin.cpp.o' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QMetaTypeIdQObject<QWidget*, 8>::qt_metatype_id()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qwidgetsvariant.o)' to global weak symbol 'QMetaTypeIdQObject<QWidget*, 8>::qt_metatype_id()::metatype_id' from file 'src/qt/CMakeFiles/DeVault-Core.dir/bitcoin.cpp.o' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QErrorMessagePrivate::~QErrorMessagePrivate()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qerrormessage.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QErrorMessagePrivate::~QErrorMessagePrivate()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qerrormessage.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QAbstractItemView::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qabstractitemview.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QAbstractItemView::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qabstractitemview.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QTreeWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qtreewidget.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QTreeWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qtreewidget.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z27qRegisterNormalizedMetaTypeI14QItemSelectionEiRK10QByteArrayPT_N9QtPrivate21MetaTypeDefinedHelperIS4_Xaasr12QMetaTypeId2IS4_EE7Definedntsr12QMetaTypeId2IS4_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qtreewidget.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z27qRegisterNormalizedMetaTypeI14QItemSelectionEiRK10QByteArrayPT_N9QtPrivate21MetaTypeDefinedHelperIS4_Xaasr12QMetaTypeId2IS4_EE7Definedntsr12QMetaTypeId2IS4_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qtreewidget.o)' to global weak symbol 'QMetaTypeId<QItemSelection>::qt_metatype_id()::metatype_id' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z27qRegisterNormalizedMetaTypeI14QItemSelectionEiRK10QByteArrayPT_N9QtPrivate21MetaTypeDefinedHelperIS4_Xaasr12QMetaTypeId2IS4_EE7Definedntsr12QMetaTypeId2IS4_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qtreewidget.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QItemSelection, true>::Construct(void*, void const*)' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function '__Z27qRegisterNormalizedMetaTypeI14QItemSelectionEiRK10QByteArrayPT_N9QtPrivate21MetaTypeDefinedHelperIS4_Xaasr12QMetaTypeId2IS4_EE7Definedntsr12QMetaTypeId2IS4_EE9IsBuiltInEE11DefinedTypeE' from file '../depends/x86_64-apple-darwin14/lib/libQt5Widgets.a(qtreewidget.o)' to global weak symbol 'QtMetaTypePrivate::QMetaTypeFunctionHelper<QItemSelection, true>::Destruct(void*)' from file 'src/qt/libbitcoin-qt-base.a(mocs_compilation.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QNetworkConfigurationManagerPrivate::~QNetworkConfigurationManagerPrivate()' from file '../depends/x86_64-apple-darwin14/lib/libQt5Network.a(qnetworkconfigmanager_p.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHash<QString, QHashDummyValue>::remove(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Network.a(qnetworkconfigmanager_p.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHash<QString, QHashDummyValue>::remove(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Network.a(qnetworkconfigmanager_p.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::deleteNode2(QHashData::Node*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHash<QString, QHashDummyValue>::remove(QString const&)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Network.a(qnetworkconfigmanager_p.o)' to global weak symbol 'QHash<QString, QHashDummyValue>::duplicateNode(QHashData::Node*, void*)' from file 'src/qt/libbitcoin-qt-base.a(walletmodel.cpp.o)' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: direct access in function 'QHostInfoResult::QHostInfoResult(QObject const*, QtPrivate::QSlotObjectBase*)' from file '../depends/x86_64-apple-darwin14/lib/libQt5Network.a(qhostinfo.o)' to global weak symbol 'QtPrivate::QSlotObject<void (QObject::*)(), QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*)' from file 'src/qt/CMakeFiles/DeVault-Core.dir/bitcoin.cpp.o' means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
ld: warning: PIE disabled. Absolute addressing (perhaps -mdynamic-no-pic) not allowed in code signed PIE, but used in ___gmpn_divexact_1 from ../depends/x86_64-apple-darwin14/lib/libgmp.a(dive_1.o). To fix this warning, don't compile with -mdynamic-no-pic or link with -Wl,-no_pie
-- Install configuration: "Release"
-- Install component: "bitcoind"
-- Install configuration: "Release"
-- Install component: "bitcoin-qt"
-- Install configuration: "Release"
-- Install component: "bitcoin-seeder"
ninja: error: unknown target 'osx-deploydir'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment