Skip to content

Instantly share code, notes, and snippets.

🥑
coding lotsa code

Matt Gardner allthesignals

🥑
coding lotsa code
Block or report user

Report or block allthesignals

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View controllers.application.js
import Ember from 'ember';
export default Ember.Controller.extend({
appName: 'Ember Twiddle'
});
View carto-data-provider.js
export default class CartoDataProvider extends Component {
@service
router;
@service
store;
modelName = 'carto-geojson-feature';
modelId = null;
View controllers.application.js
import Ember from 'ember';
export default Ember.Controller.extend({
appName: 'Ember Twiddle'
});
View components.my-component.js
import Ember from 'ember';
export default Ember.Component.extend({
});
View projects-map.hbs
{{#mapbox-gl as |map|}}
{{map.on 'click' (action 'handleMapClick')}}
{{map.on 'mousemove' (action 'handleMouseMove')}}
{{!-- Two yields implicitly merge the mapbox-gl addon's block params API with our own
internal extensions --}}
{{yield map}}
{{yield (hash
dynamic-tiles=(component 'mapbox-gl-dynamic-tiles'
map=map
View my-mergy-component.hbs
{{yield (hash someApi=(action 'api'))}}
{{yield (hash anotherApi=(action 'anotherApi')}}
View yarn.lock
# THIS IS AN AUTOGENERATED FILE. DO NOT EDIT THIS FILE DIRECTLY.
# yarn lockfile v1
"@babel/code-frame@7.0.0-beta.44":
version "7.0.0-beta.44"
resolved "https://registry.yarnpkg.com/@babel/code-frame/-/code-frame-7.0.0-beta.44.tgz#2a02643368de80916162be70865c97774f3adbd9"
dependencies:
"@babel/highlight" "7.0.0-beta.44"
View package.json
{
"name": "labs-zola",
"version": "0.0.0",
"private": true,
"description": "Small description for labs-zola goes here",
"repository": "",
"license": "MIT",
"author": "",
"directories": {
"doc": "doc",
View error.bash
@ember-decorators/babel-transforms
Allowed: (any single version)
Found: 3.1.5, 2.1.2
labs-zola
├── @ember-decorators/babel-transforms@3.1.5
├─┬ ember-font-awesome
│ └── @ember-decorators/babel-transforms@2.1.2
├─┬ ember-mapbox-composer
│ ├── @ember-decorators/babel-transforms@3.1.5
│ └─┬ ember-font-awesome
View yarn.lock
# THIS IS AN AUTOGENERATED FILE. DO NOT EDIT THIS FILE DIRECTLY.
# yarn lockfile v1
"@babel/code-frame@7.0.0-beta.44":
version "7.0.0-beta.44"
resolved "http://registry.npmjs.org/@babel/code-frame/-/code-frame-7.0.0-beta.44.tgz#2a02643368de80916162be70865c97774f3adbd9"
dependencies:
"@babel/highlight" "7.0.0-beta.44"
You can’t perform that action at this time.