Skip to content

Embed URL

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Script to install basic apps on ubuntu
# Utils
sudo apt-get install htop
sudo apt-get install gnome-do
sudo apt-get install exuberant-ctags ncurses-term
sudo apt-get install vim-gnome
sudo apt-get install inkscape
sudo apt-get install sun-java6-jdk
sudo apt-get install compizconfig-settings-manager
sudo apt-get install ubuntu-restricted-extras
# Server
sudo apt-get install apache2
sudo apt-get install libapache2-mod-passenger
# Programming
sudo apt-get install libxml2
sudo apt-get install libxml2-dev
sudo apt-get install libxslt-dev
sudo apt-get install mysql-server
sudo apt-get install libmysql-ruby libmysqlclient-dev
sudo apt-get install sqlite3
sudo apt-get install libsqlite3-dev
sudo apt-get install git-core
sudo apt-get install gitg
sudo apt-get install git-gui
sudo apt-get install meld
git config --global alias.s status
git config --global alias.a add
git config --global alias.d diff
git config --global alias.g grep
git config --global alias.b branch
git config --global alias.c commit
git config --global alias.co checkout
git config --global alias.mt mergetool
git config --global color.diff auto
git config --global color.status auto
git config --global color.branch auto
git config --global merge.tool meld
git config --global push.default tracking
sudo apt-get install ruby-full
sudo apt-get install rake
sudo apt-get install rubygems
gem source -a http://gems.github.com/
sudo gem install rcov
sudo gem install hpricot
sudo gem install capistrano
sudo gem install highline
sudo gem install net-ssh
sudo gem install henrik-jekyll
sudo gem install haml
sudo gem install compass
sudo gem install juicer
juicer install yui_compressor
juicer install jslint
sudo gem install rails -v=2.3.4
sudo gem install rspec
sudo gem install hoptoad_notifier
sudo gem install dry_scaffold
sudo gem install rghost
sudo gem install rghost_barcode
sudo gem install parseline
sudo gem install compass-colors
sudo gem install compass -v=0.10.0.pre2
sudo gem install fancy-buttons -v=0.3.9
sudo gem install sqlite3-ruby
sudo gem install mysql
sudo gem install mongrel
sudo gem install webrat
# Passenger
sudo gem install passenger
sudo apt-get install build-essential
sudo apt-get install apache2-prefork-dev
sudo apt-get install libapr1-dev
sudo apt-get install libaprutil1-dev
passenger-install-apache2-module
git clone git://github.com/akitaonrails/vimfiles.git ~/.vim
cd ~/.vim
git submodule init
git submodule update
ln -s ~/.vim/vimrc ~/.vimrc
cd ~/.vim/bundle/Command-T/ruby/command-t
ruby extconf.rb
make
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.