Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
`npm list --json` when package-lock.json is absent and present
npm list --json
{
"name": "@secoya/rabbitmq-tools",
"version": "0.1.8",
"problems": [
"missing: amqplib@0.4.2, required by @secoya/rabbitmq-tools@0.1.8",
"missing: babel-runtime@6.9.2, required by @secoya/rabbitmq-tools@0.1.8",
"missing: bitsyntax@0.0.4, required by amqplib@0.4.2",
"missing: buffer-more-ints@0.0.2, required by amqplib@0.4.2",
"missing: readable-stream@1.1.14, required by amqplib@0.4.2",
"missing: when@3.6.4, required by amqplib@0.4.2",
"missing: buffer-more-ints@0.0.2, required by bitsyntax@0.0.4",
"missing: core-util-is@1.0.2, required by readable-stream@1.1.14",
"missing: inherits@2.0.3, required by readable-stream@1.1.14",
"missing: isarray@0.0.1, required by readable-stream@1.1.14",
"missing: string_decoder@0.10.31, required by readable-stream@1.1.14",
"missing: core-js@2.5.1, required by babel-runtime@6.9.2",
"missing: regenerator-runtime@0.9.6, required by babel-runtime@6.9.2"
],
"dependencies": {
"amqplib": {
"version": "0.4.2",
"from": "amqplib@0.4.2",
"resolved": "https://registry.npmjs.org/amqplib/-/amqplib-0.4.2.tgz",
"problems": [
"missing: bitsyntax@0.0.4, required by amqplib@0.4.2",
"missing: buffer-more-ints@0.0.2, required by amqplib@0.4.2",
"missing: readable-stream@1.1.14, required by amqplib@0.4.2",
"missing: when@3.6.4, required by amqplib@0.4.2",
"missing: buffer-more-ints@0.0.2, required by bitsyntax@0.0.4",
"missing: core-util-is@1.0.2, required by readable-stream@1.1.14",
"missing: inherits@2.0.3, required by readable-stream@1.1.14",
"missing: isarray@0.0.1, required by readable-stream@1.1.14",
"missing: string_decoder@0.10.31, required by readable-stream@1.1.14"
],
"dependencies": {
"bitsyntax": {
"version": "0.0.4",
"from": "bitsyntax@0.0.4",
"resolved": "https://registry.npmjs.org/bitsyntax/-/bitsyntax-0.0.4.tgz",
"problems": [
"missing: buffer-more-ints@0.0.2, required by bitsyntax@0.0.4"
],
...
"when": {
"version": "3.6.4",
"from": "when@3.6.4",
"resolved": "https://registry.npmjs.org/when/-/when-3.6.4.tgz"
}
}
},
"babel-runtime": {
"version": "6.9.2",
"from": "babel-runtime@6.9.2",
"resolved": "https://registry.npmjs.org/babel-runtime/-/babel-runtime-6.9.2.tgz",
"problems": [
"missing: core-js@2.5.1, required by babel-runtime@6.9.2",
"missing: regenerator-runtime@0.9.6, required by babel-runtime@6.9.2"
],
"dependencies": {
"core-js": {
"version": "2.5.1",
"from": "core-js@2.5.1",
"resolved": "https://registry.npmjs.org/core-js/-/core-js-2.5.1.tgz"
},
npm list --json
{
"name": "@secoya/rabbitmq-tools",
"version": "0.1.8",
"problems": [
"missing: amqplib@0.4.2, required by @secoya/rabbitmq-tools@0.1.8",
"missing: babel-runtime@6.9.2, required by @secoya/rabbitmq-tools@0.1.8"
],
"dependencies": {
"amqplib": {
"required": "0.4.2",
"missing": true
},
"babel-runtime": {
"required": "6.9.2",
"missing": true
}
}
}
npm ERR! missing: amqplib@0.4.2, required by @secoya/rabbitmq-tools@0.1.8
npm ERR! missing: babel-runtime@6.9.2, required by @secoya/rabbitmq-tools@0.1.8
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.