Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
-- The C compiler identification is GNU 6.3.0
-- The CXX compiler identification is GNU 6.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Configuring OGRE 2.1.0unstable
-- Check size of void*
-- Check size of void* - done
-- Performing Test OGRE_GCC_HAS_SSE
-- Performing Test OGRE_GCC_HAS_SSE - Success
-- Performing Test OGRE_GCC_VISIBILITY
-- Performing Test OGRE_GCC_VISIBILITY - Success
-- Detected g++ 6.3.0
-- Enabling GCC visibility flags
-- Check if the system is big endian
-- Searching 16 bit integer
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of unsigned short
-- Check size of unsigned short - done
-- Using unsigned short
-- Check if the system is big endian - little endian
-- Search path: /home/raven/rain/dev/libs/ogre/build/Release/Dependencies/build/ogredeps;/home/raven/rain/dev/libs/ogre/build/Release/Dependencies;/home/raven/rain/dev/libs/ogre/Dependencies;/home/raven/rain/dev/libs/ogre/build/Release/../Dependencies;/home/raven/rain/dev/libs/ogre/../Dependencies
-- Looking for ZLIB...
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29")
-- Checking for module 'zzip-zlib-config'
-- Found zzip-zlib-config, version
-- Found ZLIB: optimized;/usr/lib/x86_64-linux-gnu/libz.so;debug;/usr/lib/x86_64-linux-gnu/libz.so
-- Looking for ZZip...
-- Checking for module 'zziplib'
-- Found zziplib, version 0.13.62
-- Found ZZip: optimized;/usr/lib/x86_64-linux-gnu/libzzip.so;debug;/usr/lib/x86_64-linux-gnu/libzzip.so
-- Looking for FreeImage...
-- Checking for module 'freeimage'
-- No package 'freeimage' found
-- Found FreeImage: optimized;/usr/lib/x86_64-linux-gnu/libfreeimage.so;debug;/usr/lib/x86_64-linux-gnu/libfreeimage.so
-- Looking for FREETYPE...
-- Checking for module 'freetype2'
-- Found freetype2, version 21.0.15
-- CMAKE_PREFIX_PATH: /home/raven/rain/dev/libs/ogre/build/Release/Dependencies/build/ogredeps;/home/raven/rain/dev/libs/ogre/build/Release/Dependencies;/home/raven/rain/dev/libs/ogre/Dependencies;/home/raven/rain/dev/libs/ogre/build/Release/../Dependencies;/home/raven/rain/dev/libs/ogre/../Dependencies;/usr/local;/usr/lib/x86_64-linux-gnu
-- CMAKE_PREFIX_PATH: /home/raven/rain/dev/libs/ogre/build/Release/Dependencies/build/ogredeps;/home/raven/rain/dev/libs/ogre/build/Release/Dependencies;/home/raven/rain/dev/libs/ogre/Dependencies;/home/raven/rain/dev/libs/ogre/build/Release/../Dependencies;/home/raven/rain/dev/libs/ogre/../Dependencies;/usr/local;/usr/lib/x86_64-linux-gnu
-- Found FREETYPE: optimized;/usr/lib/x86_64-linux-gnu/libfreetype.so;debug;/usr/lib/x86_64-linux-gnu/libfreetype.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Looking for Rapidjson...
-- Rapidjson_PREFIX_PATH changed.
-- Checking for module 'Rapidjson'
-- No package 'Rapidjson' found
-- Could NOT find Rapidjson (missing: Rapidjson_INCLUDE_DIR)
-- Could not locate Rapidjson
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
-- Looking for Remotery...
-- Remotery_PREFIX_PATH changed.
-- Checking for module 'Remotery'
-- No package 'Remotery' found
-- Could NOT find Remotery (missing: Remotery_INCLUDE_DIR Remotery_LIBRARIES)
-- Could not locate Remotery
-- Looking for Cg...
-- Cg_PREFIX_PATH changed.
-- Checking for module 'Cg'
-- No package 'Cg' found
-- Could not locate Cg
CMake Warning at /usr/share/cmake-3.7/Modules/FindBoost.cmake:761 (message):
Imported targets not available for Boost version
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindBoost.cmake:865 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.7/Modules/FindBoost.cmake:1470 (_Boost_MISSING_DEPENDENCIES)
CMake/Dependencies.cmake:199 (find_package)
CMakeLists.txt:258 (include)
CMake Warning at /usr/share/cmake-3.7/Modules/FindBoost.cmake:761 (message):
Imported targets not available for Boost version
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindBoost.cmake:865 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.7/Modules/FindBoost.cmake:1470 (_Boost_MISSING_DEPENDENCIES)
CMake/Dependencies.cmake:199 (find_package)
CMakeLists.txt:258 (include)
CMake Warning at /usr/share/cmake-3.7/Modules/FindBoost.cmake:761 (message):
Imported targets not available for Boost version
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindBoost.cmake:865 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.7/Modules/FindBoost.cmake:1470 (_Boost_MISSING_DEPENDENCIES)
CMake/Dependencies.cmake:207 (find_package)
CMakeLists.txt:258 (include)
CMake Warning at /usr/share/cmake-3.7/Modules/FindBoost.cmake:761 (message):
Imported targets not available for Boost version
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindBoost.cmake:865 (_Boost_COMPONENT_DEPENDENCIES)
/usr/share/cmake-3.7/Modules/FindBoost.cmake:1470 (_Boost_MISSING_DEPENDENCIES)
CMake/Dependencies.cmake:207 (find_package)
CMakeLists.txt:258 (include)
-- Looking for POCO...
-- Checking for module 'POCO'
-- No package 'POCO' found
-- Could not locate POCO
-- Looking for TBB...
-- Could not locate TBB
-- Looking for GLSL_Optimizer...
-- GLSL_Optimizer_PREFIX_PATH changed.
-- Checking for module 'GLSL_Optimizer'
-- No package 'GLSL_Optimizer' found
-- Could not locate GLSL_Optimizer
-- Looking for HLSL2GLSL...
-- HLSL2GLSL_PREFIX_PATH changed.
-- Checking for module 'HLSL2GLSL'
-- No package 'HLSL2GLSL' found
-- Could not locate HLSL2GLSL
-- Looking for OIS...
-- OIS_PREFIX_PATH changed.
-- Checking for module 'OIS'
-- No package 'OIS' found
-- Could not locate OIS
-- Found Threads: TRUE
-- Could NOT find SDL2 (missing: SDL2_LIBRARY SDL2_INCLUDE_DIR)
-- Found Doxygen: /usr/bin/doxygen
-- Looking for Softimage...
-- Softimage_PREFIX_PATH changed.
-- Could not locate Softimage
-- Could NOT find TinyXML (missing: TINYXML_INCLUDE_DIR TINYXML_LIBRARIES)
-- Looking for CppUnit...
-- Checking for module 'cppunit'
-- No package 'cppunit' found
-- Could not locate CppUnit
-- Check size of void*
-- Check size of void* - done
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ zlib
+ zziplib
+ freeimage
+ freetype
+ X11
+ Xt
+ Xaw
+ OpenGL
+ OpenGL 3+
+ OpenGL ES 2.x
+ OpenGL ES 3.x
+ Doxygen
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ rapidjson: C++ JSON parser <http://rapidjson.org/>
+ OpenGL ES 1.x: Support for the OpenGL ES 1.x render system (DEPRECATED) <http://www.khronos.org/opengles/>
+ Remotery: Realtime CPU/D3D/OpenGL/CUDA/Metal Profiler in a single C file with web browser viewer <https://github.com/Celtoys/Remotery>
+ cg: C for graphics shader language <http://developer.nvidia.com/object/cg_toolkit.html>
+ boost: Boost (general) <http://boost.org>
+ boost-thread: Used for threading support <http://boost.org>
+ boost-date_time: Used for threading support <http://boost.org>
+ POCO: POCO framework <http://pocoproject.org/>
+ tbb: Threading Building Blocks <http://www.threadingbuildingblocks.org/>
+ GLSL Optimizer: GLSL Optimizer <http://github.com/aras-p/glsl-optimizer/>
+ HLSL2GLSL: HLSL2GLSL <http://hlsl2glslfork.googlecode.com/>
+ OIS: Input library needed for the samples <http://sourceforge.net/projects/wgois>
+ SDL2: Simple DirectMedia Library <https://www.libsdl.org/>
+ Softimage: Softimage SDK needed for building XSIExporter <FALSE>
+ TinyXML: TinyXML needed for building OgreXMLConverter <FALSE>
+ CppUnit: Library for performing unit tests <http://cppunit.sourceforge.net>
-----------------------------------------------------------------------------
-- Could not find dependency for samples: SDL2
-- Skipping samples & tests build
--
----------------------------------------------------------------------------
FEATURE SUMMARY
----------------------------------------------------------------------------
Building components:
+ MeshLodGenerator
+ Overlay
Building plugins:
+ Particle FX
Building rendersystems:
+ OpenGL 3.3+
Building executables:
+ Samples
+ Tools
Building core features:
+ Mesh Lod
+ DDS image codec
+ FreeImage codec
+ ZIP archives
Build type: dynamic
Threading support: none
Use double precision: disabled
Assert mode: standard
Allocator type: standard
STL containers use allocator: enabled
Strings use allocator: disabled
Memory tracker (debug): disabled
Memory tracker (release): disabled
Use 1.x legacy animations: enabled
Use Boost: disabled
Use SIMD (SSE2): enabled
Use SIMD (NEON): enabled
----------------------------------------------------------------------------
-- Configuring done
-- Generating done
-- Build files have been written to: /home/raven/rain/dev/libs/ogre/build/Release
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.