Create a gist now

Instantly share code, notes, and snippets.

What would you like to do?
Installation log of Tensorflow 1.0 on Windows using pip
Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. All rights reserved.
C:\Users\Alex>pip3 -V
pip 9.0.1 from c:\programming\anaconda3\lib\site-packages (python 3.5)
C:\Users\Alex>pip3 install --upgrade tensorflow
Collecting tensorflow
Downloading tensorflow-1.0.0-cp35-cp35m-win_amd64.whl (14.7MB)
100% |################################| 14.7MB 94kB/s
Requirement already up-to-date: wheel>=0.26 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Collecting protobuf>=3.1.0 (from tensorflow)
Downloading protobuf-3.2.0-py2.py3-none-any.whl (360kB)
100% |################################| 368kB 376kB/s
Requirement already up-to-date: six>=1.10.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Collecting numpy>=1.11.0 (from tensorflow)
Downloading numpy-1.12.0-cp35-none-win_amd64.whl (7.7MB)
100% |################################| 7.7MB 177kB/s
Collecting setuptools (from protobuf>=3.1.0->tensorflow)
Downloading setuptools-34.3.0-py2.py3-none-any.whl (389kB)
100% |################################| 399kB 395kB/s
Collecting packaging>=16.8 (from setuptools->protobuf>=3.1.0->tensorflow)
Downloading packaging-16.8-py2.py3-none-any.whl
Collecting appdirs>=1.4.0 (from setuptools->protobuf>=3.1.0->tensorflow)
Downloading appdirs-1.4.2-py2.py3-none-any.whl
Collecting pyparsing (from packaging>=16.8->setuptools->protobuf>=3.1.0->tensorflow)
Using cached pyparsing-2.1.10-py2.py3-none-any.whl
Installing collected packages: pyparsing, packaging, appdirs, setuptools, protobuf, numpy, tensorflow
Found existing installation: pyparsing 2.1.4
Uninstalling pyparsing-2.1.4:
Successfully uninstalled pyparsing-2.1.4
Found existing installation: setuptools 27.2.0
Uninstalling setuptools-27.2.0:
Successfully uninstalled setuptools-27.2.0
Found existing installation: numpy 1.11.3
Uninstalling numpy-1.11.3:
Successfully uninstalled numpy-1.11.3
Successfully installed appdirs-1.4.2 numpy-1.12.0 packaging-16.8 protobuf-3.2.0 pyparsing-2.1.10 setuptools-34.3.0 tensorflow-1.0.0
Traceback (most recent call last):
File "c:\programming\anaconda3\lib\runpy.py", line 184, in _run_module_as_main
"__main__", mod_spec)
File "c:\programming\anaconda3\lib\runpy.py", line 85, in _run_code
exec(code, run_globals)
File "C:\Programming\Anaconda3\Scripts\pip3.exe\__main__.py", line 9, in <module>
File "c:\programming\anaconda3\lib\site-packages\pip\__init__.py", line 233, in main
return command.main(cmd_args)
File "c:\programming\anaconda3\lib\site-packages\pip\basecommand.py", line 252, in main
pip_version_check(session)
File "c:\programming\anaconda3\lib\site-packages\pip\utils\outdated.py", line 102, in pip_version_check
installed_version = get_installed_version("pip")
File "c:\programming\anaconda3\lib\site-packages\pip\utils\__init__.py", line 838, in get_installed_version
working_set = pkg_resources.WorkingSet()
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 644, in __init__
self.add_entry(entry)
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 700, in add_entry
for dist in find_distributions(entry, True):
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 1949, in find_eggs_in_zip
if metadata.has_metadata('PKG-INFO'):
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 1463, in has_metadata
return self.egg_info and self._has(self._fn(self.egg_info, name))
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 1823, in _has
return zip_path in self.zipinfo or zip_path in self._index()
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 1703, in zipinfo
return self._zip_manifests.load(self.loader.archive)
File "c:\programming\anaconda3\lib\site-packages\pip\_vendor\pkg_resources\__init__.py", line 1643, in load
mtime = os.stat(path).st_mtime
FileNotFoundError: [WinError 2] The system cannot find the file specified: 'c:\\programming\\anaconda3\\lib\\site-packages\\setuptools-27.2.0-py3.5.egg'
C:\Users\Alex>pip3 install --upgrade tensorflow
Requirement already up-to-date: tensorflow in c:\programming\anaconda3\lib\site-packages
Requirement already up-to-date: wheel>=0.26 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: six>=1.10.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: protobuf>=3.1.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: numpy>=1.11.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: setuptools in c:\programming\anaconda3\lib\site-packages (from protobuf>=3.1.0->tensorflow)
Requirement already up-to-date: appdirs>=1.4.0 in c:\programming\anaconda3\lib\site-packages (from setuptools->protobuf>=3.1.0->tensorflow)
Requirement already up-to-date: packaging>=16.8 in c:\programming\anaconda3\lib\site-packages (from setuptools->protobuf>=3.1.0->tensorflow)
Requirement already up-to-date: pyparsing in c:\programming\anaconda3\lib\site-packages (from packaging>=16.8->setuptools->protobuf>=3.1.0->tensorflow)
C:\Users\Alex>pip3 install --upgrade tensorflow
Requirement already up-to-date: tensorflow in c:\programming\anaconda3\lib\site-packages
Requirement already up-to-date: protobuf>=3.1.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: wheel>=0.26 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: numpy>=1.11.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: six>=1.10.0 in c:\programming\anaconda3\lib\site-packages (from tensorflow)
Requirement already up-to-date: setuptools in c:\programming\anaconda3\lib\site-packages (from protobuf>=3.1.0->tensorflow)
Requirement already up-to-date: packaging>=16.8 in c:\programming\anaconda3\lib\site-packages (from setuptools->protobuf>=3.1.0->tensorflow)
Requirement already up-to-date: appdirs>=1.4.0 in c:\programming\anaconda3\lib\site-packages (from setuptools->protobuf>=3.1.0->tensorflow)
Requirement already up-to-date: pyparsing in c:\programming\anaconda3\lib\site-packages (from packaging>=16.8->setuptools->protobuf>=3.1.0->tensorflow)
C:\Users\Alex>python
Python 3.5.2 |Anaconda custom (64-bit)| (default, Jul 5 2016, 11:41:13) [MSC v.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import tensorflow as tf
>>> hello = tf.constant('Hello, TensorFlow!')
>>> sess = tf.Session()
>>> print(sess.run(hello))
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "BestSplits" device_type: "CPU"') for unknown op: BestSplits
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "CountExtremelyRandomStats" device_type: "CPU"') for unknown op: CountExtremelyRandomStats
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "FinishedNodes" device_type: "CPU"') for unknown op: FinishedNodes
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "GrowTree" device_type: "CPU"') for unknown op: GrowTree
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "ReinterpretStringToFloat" device_type: "CPU"') for unknown op: ReinterpretStringToFloat
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "SampleInputs" device_type: "CPU"') for unknown op: SampleInputs
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "ScatterAddNdim" device_type: "CPU"') for unknown op: ScatterAddNdim
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "TopNInsert" device_type: "CPU"') for unknown op: TopNInsert
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "TopNRemove" device_type: "CPU"') for unknown op: TopNRemove
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "TreePredictions" device_type: "CPU"') for unknown op: TreePredictions
E c:\tf_jenkins\home\workspace\release-win\device\cpu\os\windows\tensorflow\core\framework\op_kernel.cc:943] OpKernel ('op: "UpdateFertileSlots" device_type: "CPU"') for unknown op: UpdateFertileSlots
b'Hello, TensorFlow!'
>>> exit()
C:\Users\Alex>pip3 install --upgrade setuptools
Requirement already up-to-date: setuptools in c:\programming\anaconda3\lib\site-packages
Requirement already up-to-date: appdirs>=1.4.0 in c:\programming\anaconda3\lib\site-packages (from setuptools)
Requirement already up-to-date: packaging>=16.8 in c:\programming\anaconda3\lib\site-packages (from setuptools)
Requirement already up-to-date: six>=1.6.0 in c:\programming\anaconda3\lib\site-packages (from setuptools)
Requirement already up-to-date: pyparsing in c:\programming\anaconda3\lib\site-packages (from packaging>=16.8->setuptools)
C:\Users\Alex>conda -V
conda 4.3.7
C:\Users\Alex>pip -V
pip 9.0.1 from c:\programming\anaconda3\lib\site-packages (python 3.5)
C:\Users\Alex>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl
tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl is not a supported wheel on this platform.
C:\Users\Alex>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.0.0-cp35-cp35m-win_x86_64.whl
tensorflow_gpu-1.0.0-cp35-cp35m-win_x86_64.whl is not a supported wheel on this platform.
C:\Users\Alex>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.0.0-cp35-cp35m-win_64.whl
tensorflow_gpu-1.0.0-cp35-cp35m-win_64.whl is not a supported wheel on this platform.
C:\Users\Alex>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.0.0-cp35-cp35m-win_amd64.whl
Collecting tensorflow-gpu==1.0.0 from https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.0.0-cp35-cp35m-win_amd64.whl
Downloading https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.0.0-cp35-cp35m-win_amd64.whl (43.1MB)
100% |################################| 43.1MB 27kB/s
Collecting protobuf>=3.1.0 (from tensorflow-gpu==1.0.0)
Using cached protobuf-3.2.0-py2.py3-none-any.whl
Collecting six>=1.10.0 (from tensorflow-gpu==1.0.0)
Using cached six-1.10.0-py2.py3-none-any.whl
Collecting numpy>=1.11.0 (from tensorflow-gpu==1.0.0)
Using cached numpy-1.12.0-cp35-none-win_amd64.whl
Collecting wheel>=0.26 (from tensorflow-gpu==1.0.0)
Downloading wheel-0.29.0-py2.py3-none-any.whl (66kB)
100% |################################| 71kB 169kB/s
Collecting setuptools (from protobuf>=3.1.0->tensorflow-gpu==1.0.0)
Using cached setuptools-34.3.0-py2.py3-none-any.whl
Collecting appdirs>=1.4.0 (from setuptools->protobuf>=3.1.0->tensorflow-gpu==1.0.0)
Using cached appdirs-1.4.2-py2.py3-none-any.whl
Collecting packaging>=16.8 (from setuptools->protobuf>=3.1.0->tensorflow-gpu==1.0.0)
Using cached packaging-16.8-py2.py3-none-any.whl
Collecting pyparsing (from packaging>=16.8->setuptools->protobuf>=3.1.0->tensorflow-gpu==1.0.0)
Using cached pyparsing-2.1.10-py2.py3-none-any.whl
Installing collected packages: six, appdirs, pyparsing, packaging, setuptools, protobuf, numpy, wheel, tensorflow-gpu
Successfully installed appdirs-1.4.2 numpy-1.12.0 packaging-16.8 protobuf-3.2.0 pyparsing-2.1.10 setuptools-34.3.0 six-1.10.0 tensorflow-gpu-1.0.0 wheel-0.29.0
C:\Users\Alex>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_amd64.whl
Collecting tensorflow==1.0.0 from https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_amd64.whl
Downloading https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_amd64.whl (14.7MB)
100% |################################| 14.7MB 94kB/s
Collecting six>=1.10.0 (from tensorflow==1.0.0)
Using cached six-1.10.0-py2.py3-none-any.whl
Collecting numpy>=1.11.0 (from tensorflow==1.0.0)
Using cached numpy-1.12.0-cp35-none-win_amd64.whl
Collecting protobuf>=3.1.0 (from tensorflow==1.0.0)
Using cached protobuf-3.2.0-py2.py3-none-any.whl
Collecting wheel>=0.26 (from tensorflow==1.0.0)
Using cached wheel-0.29.0-py2.py3-none-any.whl
Collecting setuptools (from protobuf>=3.1.0->tensorflow==1.0.0)
Using cached setuptools-34.3.0-py2.py3-none-any.whl
Collecting appdirs>=1.4.0 (from setuptools->protobuf>=3.1.0->tensorflow==1.0.0)
Using cached appdirs-1.4.2-py2.py3-none-any.whl
Collecting packaging>=16.8 (from setuptools->protobuf>=3.1.0->tensorflow==1.0.0)
Using cached packaging-16.8-py2.py3-none-any.whl
Collecting pyparsing (from packaging>=16.8->setuptools->protobuf>=3.1.0->tensorflow==1.0.0)
Using cached pyparsing-2.1.10-py2.py3-none-any.whl
Installing collected packages: six, numpy, appdirs, pyparsing, packaging, setuptools, protobuf, wheel, tensorflow
Successfully installed appdirs-1.4.2 numpy-1.12.0 packaging-16.8 protobuf-3.2.0 pyparsing-2.1.10 setuptools-34.3.0 six-1.10.0 tensorflow-1.0.0 wheel-0.29.0
C:\Users\Alex>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment