Skip to content

Instantly share code, notes, and snippets.

@ardakazanci
Last active November 4, 2019 11:36
Show Gist options
  • Save ardakazanci/4e4ec2866c9568d666c5ea026e01ce5e to your computer and use it in GitHub Desktop.
Save ardakazanci/4e4ec2866c9568d666c5ea026e01ce5e to your computer and use it in GitHub Desktop.
/*
Java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.
To get you started, a portion of the solution is provided for you in the editor; you must format and print the input to complete the solution.
Input Format
Every line of input will contain a String followed by an integer.
Each String will have a maximum of alphabetic characters, and each integer will be in the inclusive range from to .
Output Format
In each line of output there should be two columns:
The first column contains the String and is left justified using exactly characters.
The second column contains the integer, expressed in exactly digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.
Sample Input
java 100
cpp 65
python 50
Sample Output
================================
java 100
cpp 065
python 050
================================
Explanation
Each String is left-justified with trailing whitespace through the first characters. The leading digit of the integer is the character, and each integer that was less than digits now has leading zeroes.
*/
// Arda Kazancı - 2019
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
String xString = "";
System.out.println("================================");
for(int i=0;i<3;i++){
String s1=sc.next();
int x=sc.nextInt();
if(x >= 0 && x <= 999){
if(x < 100 && x>=10){
xString = "0"+x;
}else if(x < 10 && x >=0 ){
xString = "00"+x;
}else if(x >= 100 && x <= 999){
xString = ""+x;
}
System.out.print(s1);
int count = s1.length() + xString.length(); // String count
int countEmpty = 18 - count;
for(int k =1; k <= countEmpty; k++){
System.out.print(" ");
}
System.out.println(xString);
}
}
System.out.println("================================");
}
}
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment