Create a gist now

Instantly share code, notes, and snippets.

@aruld /Info.plist
Last active Mar 29, 2016

To run Intellij 14.1 with latest JDK 9 on OS X Yosemite, edit /Applications/IntelliJ\ IDEA\ 14.app/Contents/Info.plist and set JVMVersion to 1.8 under JVM Options.
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleDocumentTypes</key>
<array>
<dict>
<key>CFBundleTypeExtensions</key>
<array>
<string>ipr</string>
</array>
<key>CFBundleTypeIconFile</key>
<string>idea.icns</string>
<key>CFBundleTypeName</key>
<string>IntelliJ IDEA Project File</string>
<key>CFBundleTypeRole</key>
<string>Editor</string>
</dict>
<dict>
<key>CFBundleTypeExtensions</key>
<array>
<string>*</string>
</array>
<key>CFBundleTypeName</key>
<string>All documents</string>
<key>CFBundleTypeOSTypes</key>
<array>
<string>****</string>
</array>
<key>CFBundleTypeRole</key>
<string>Editor</string>
<key>LSTypeIsPackage</key>
<false/>
</dict>
</array>
<key>CFBundleExecutable</key>
<string>idea</string>
<key>CFBundleIconFile</key>
<string>idea.icns</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>IntelliJ IDEA-EAP</string>
<key>CFBundlePackageType</key>
<string>APPL</string>
<key>CFBundleIdentifier</key>
<string>com.jetbrains.intellij-EAP</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleGetInfoString</key>
<string>IntelliJ IDEA EAP IU-141.498.1, build IU-141.498.1. Copyright JetBrains s.r.o., (c) 2000-2015</string>
<key>CFBundleShortVersionString</key>
<string>EAP IU-141.498.1</string>
<key>CFBundleVersion</key>
<string>IU-141.498.1</string>
<key>LSApplicationCategoryType</key>
<string>public.app-category.developer-tools</string>
<key>CFBundleHelpBookName</key>
<string>JetBrains.IJ.help</string>
<key>CFBundleHelpBookFolder</key>
<string>IJ.help</string>
<key>NSHighResolutionCapable</key>
<true/>
<key>LSArchitecturePriority</key>
<array><string>x86_64</string><string>i386</string></array>
<key>LSRequiresNativeExecution</key>
<string>YES</string>
<key>LSMinimumSystemVersion</key>
<string>10.6</string>
<key>CFBundleURLTypes</key>
<array>
<dict>
<key>CFBundleTypeRole</key>
<string>Editor</string>
<key>CFBundleURLName</key>
<string>Stacktrace</string>
<key>CFBundleURLSchemes</key>
<array>
<string>idea</string>
</array>
</dict>
</array>
<key>JVMOptions</key>
<dict>
<key>ClassPath</key>
<string>$APP_PACKAGE/Contents/lib/bootstrap.jar:$APP_PACKAGE/Contents/lib/extensions.jar:$APP_PACKAGE/Contents/lib/util.jar:$APP_PACKAGE/Contents/lib/jdom.jar:$APP_PACKAGE/Contents/lib/log4j.jar:$APP_PACKAGE/Contents/lib/trove4j.jar:$APP_PACKAGE/Contents/lib/jna.jar</string>
<key>JVMVersion</key>
<string>1.8</string>
<key>MainClass</key>
<string>com.intellij.idea.Main</string>
<key>Properties</key>
<dict>
<key>idea.paths.selector</key>
<string>IntelliJIdea14</string>
<key>idea.executable</key>
<string>idea</string>
<key>idea.java.redist</key>
<string>NoJavaDistribution</string>
<key>idea.home.path</key>
<string>$APP_PACKAGE/Contents</string>
</dict>
<key>VMOptions</key>
<string>-Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -Xverify:none -Xbootclasspath/a:../lib/boot.jar</string>
<key>WorkingDirectory</key>
<string>$APP_PACKAGE/Contents/bin</string>
</dict>
</dict>
</plist>
@indapublic

Trying change JVMVersion to 1.8 for IDEA 2016.1 (Community Edition)
In splash screen I see: JRE: 1.8.0_73

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment