Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
From: =?utf-8?B?w4Z2YXIgQXJuZmrDtnLDsA==?= Bjarmason <avarab@gmail.com>
To: Jeff King <peff@peff.net>
Cc: git@vger.kernel.org, Tor Arntsen <tor@spacetec.no>, Randal L. Schwartz <merlyn@stonehenge.com>, Jakub Narebski <jnareb@gmail.com>, Tom G. Christensen <tgc@statsbiblioteket.dk>
Subject: Dropping support for older perl (was: curl)
References: <20170809120024.7phdjzjv54uv5dpz@sigill.intra.peff.net>
User-agent: Debian GNU/Linux 8.9 (jessie); Emacs 25.1.1; mu4e 0.9.19
In-reply-to: <20170809120024.7phdjzjv54uv5dpz@sigill.intra.peff.net>
Date: Wed, 09 Aug 2017 21:26:53 +0200
Message-ID: <87bmno5ypu.fsf@gmail.com>
MIME-Version: 1.0
Content-Type: text/plain
On Wed, Aug 09 2017, Jeff King jotted:
[Originally sent as 87zib8g8ub.fsf@gmail.com, but it appears a mailer
gnome ate it, sorry if anyone gets this twice]
> This is a resurrection of the thread from April:
>
> https://public-inbox.org/git/20170404025438.bgxz5sfmrawqswcj@sigill.intra.peff.net/
>
> The general idea is that we should drop support for very old curl
> versions, which already fail to compile.
> [...]
> The first cutoff is based on having more compilation breakages than the
> other (and also just being incredibly old). The second is just a sweet
> spot of bang-for-the-buck and age. In the absence of other data, it's
> probably what I would suggest. The third one uses the existing compile
> breakage from v2.12.0 as a guide.
On a related note. I wonder what else in our codebase should get a
bumped version. I'd be keen to bump our supported perl version.
It's not a big deal, but we use various outdated constructs because 5.8
doesn't have newer ones but say 5.10.1 does.
In 2010 I bumped our dependency from 5.6 to 5.8: d48b284183 ("perl: bump
the required Perl version to 5.8 from 5.6.[21]", 2010-09-24).
RHEL/CentOS 5.x has perl 5.8.8, but it also has curl 7.15.5[1] which is
obseleted by these curl patches. Maybe we'd want to be more conservative
with perl for whatever reason, but I'd like to at least bump our
requirenment of 5.8.0 to 5.8.8. Those releases are 4 years apart, and a
lot of bugs were fixed[2], and some constructs / modules have newer APIs
we could use.
But if we do the thing corresponding to these curl patches we should
bump the dependency to 5.10.1, that was released in August 2009 (and the
curl version JK is bumping us to in March 2009), and 5.10.1 is shipped
with RHEL/CentOS 6.
The bump to 5.10.1 may be a bad idea, I know AIX/HPUX/Solaris and some
others have historically been more conservative about upgrading perl
than stuff like libcurl since it's in the base system.
But I don't know if those versions are in use yet. CC-ing some people
who might know, and I'm going to ask around in the perl community as
well.
1. https://stackoverflow.com/questions/35276487/how-do-i-upgrade-curl-in-centos-5-11
2. http://perldoc.perl.org/perlhist.html
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment