public
Created

Why not Python 2.7 yet ?

  • Download Gist
why-not-python2.7-yet.rst
reStructuredText

What are the possible reasons for not using Python 2.7 yet ?

  1. Google App Engine does not support Python 2.7
  2. The GNU/Linux stable distributions doesn't support Python 2.7 eg:- Ubuntu 10.04 LTS, Debian 6.0, RHEL 6, CentOS 6, Slackware 13.37
  3. Using Python 3.x and no plan to support older Python versions
  4. IPython is not yet supported
  5. Some hosting sites like iPage doesn't support Python 2.7
  6. To keep Jython compatibility (Jython doesn't have Python 2.7 support)
  7. OSX 10.6 doesn't support Python 2.7
  8. "psyco" module is not available for Python 2.7

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.