Skip to content

Instantly share code, notes, and snippets.

@baketzforme

baketzforme/rpi.sh

Last active Nov 3, 2018
Embed
What would you like to do?
Tezos Node on Raspberry Pi 3 B+
# Installing a Tezos node on a Raspberry Pi 3 B+ (running Raspbian (Debian Stretch) Minimal install from NOOBS Lite 2.8):
sudo apt-get install -y patch unzip make gcc m4 git g++ aspcud bubblewrap curl bzip2 rsync libgmp3-dev libev-dev libhidapi-dev fail2ban ntp
sh <(curl -sL https://raw.githubusercontent.com/ocaml/opam/561fb4759fa2184525d0c74bf7c3accbb1edd2dc/shell/install.sh)
opam init --compiler=4.06.1
eval $(opam env)
git clone -b betanet https://gitlab.com/tezos/tezos.git
cd tezos
make build-deps
eval $(opam env)
make
./tezos-node identity generate 26
@71m024

This comment has been minimized.

Copy link

@71m024 71m024 commented Sep 22, 2018

This does not work for me.
I get this error: "Makefile:11: *** Unexpected opam version (found: 2.0.0~rc3, expected: 2.0.0). Stop."
I used Raspian on a Pi 3B+

@byforcesunseen

This comment has been minimized.

Copy link

@byforcesunseen byforcesunseen commented Nov 3, 2018

This does not work for me.
I get this error: "Makefile:11: *** Unexpected opam version (found: 2.0.0~rc3, expected: 2.0.0). Stop."
I used Raspian on a Pi 3B+

You need to edit tezos/scripts/version.sh and change opam_version from 2.0.0 to 2.0.0~rc3:

-opam_version=2.0.0
+opam_version=2.0.0~rc3
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.