Skip to content

Instantly share code, notes, and snippets.

@bendlas
Created Jul 5, 2018
Embed
What would you like to do?
these derivations will be built:
/nix/store/99zfwl007nwiqyh5l9g5j8l78jx30fdd-antimony-0.9.3.drv
building '/nix/store/99zfwl007nwiqyh5l9g5j8l78jx30fdd-antimony-0.9.3.drv'...
unpacking sources
unpacking source archive /nix/store/6n4zp4605w4byy38w980xjmm1yg8rr7n-source
source root is source
patching sources
applying patch /nix/store/07ar6yc0ccpyx9sb18ap7wz7k2zszc8l-paths-fix.patch
patching file app/CMakeLists.txt
configuring
fixing cmake files...
cmake flags: -DCMAKE_BUILD_TYPE=Release -DCMAKE_SKIP_BUILD_RPATH=ON -DCMAKE_INSTALL_INCLUDEDIR=/nix/store/il895as8z1pip1vr98xz80701rf324vc-antimony-0.9.3/include -DCMAKE_INSTALL_LIBDIR=/nix/store/il895as8z1pip1vr98xz80701rf324vc-antimony-0.9.3/lib -DCMAKE_INSTALL_NAME_DIR=/nix/store/il895as8z1pip1vr98xz80701rf324vc-antimony-0.9.3/lib -DCMAKE_POLICY_DEFAULT_CMP0025=NEW -DCMAKE_OSX_DEPLOYMENT_TARGET= -DCMAKE_OSX_SYSROOT= -DCMAKE_FIND_FRAMEWORK=last -DCMAKE_STRIP=/nix/store/4qvrxzxa535y8304mk195x50b6p9607d-binutils-2.30/bin/strip -DCMAKE_RANLIB=/nix/store/4qvrxzxa535y8304mk195x50b6p9607d-binutils-2.30/bin/ranlib -DCMAKE_AR=/nix/store/4qvrxzxa535y8304mk195x50b6p9607d-binutils-2.30/bin/ar -DCMAKE_C_COMPILER=gcc -DCMAKE_CXX_COMPILER=g++ -DCMAKE_INSTALL_PREFIX=/nix/store/il895as8z1pip1vr98xz80701rf324vc-antimony-0.9.3 -DGITREV=020910c25614a3752383511ede5a1f5551a8bd39 -DGITTAG=0.9.3 -DGITBRANCH=master
-- The C compiler identification is GNU 7.3.0
-- The CXX compiler identification is GNU 7.3.0
-- Check for working C compiler: /nix/store/yz6kinf4ia19r1c14yirl6x4ciwgzk67-gcc-wrapper-7.3.0/bin/gcc
-- Check for working C compiler: /nix/store/yz6kinf4ia19r1c14yirl6x4ciwgzk67-gcc-wrapper-7.3.0/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nix/store/yz6kinf4ia19r1c14yirl6x4ciwgzk67-gcc-wrapper-7.3.0/bin/g++
-- Check for working CXX compiler: /nix/store/yz6kinf4ia19r1c14yirl6x4ciwgzk67-gcc-wrapper-7.3.0/bin/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PythonLibs: /nix/store/pz8nl4cnppd3p1cykshcb40mqxjd5yvy-python3-3.6.5/lib/libpython3.6m.so (found suitable version "3.6.5", minimum required is "3.3")
CMake Warning at /nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:801 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:907 (_Boost_COMPONENT_DEPENDENCIES)
/nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:1542 (_Boost_MISSING_DEPENDENCIES)
CMakeLists.txt:17 (find_package)
CMake Warning at /nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:1610 (message):
No header defined for python3; skipping header check
Call Stack (most recent call first):
CMakeLists.txt:17 (find_package)
CMake Warning at /nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:801 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:907 (_Boost_COMPONENT_DEPENDENCIES)
/nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:1542 (_Boost_MISSING_DEPENDENCIES)
CMakeLists.txt:17 (find_package)
CMake Warning at /nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:1610 (message):
No header defined for python-py35; skipping header check
Call Stack (most recent call first):
CMakeLists.txt:17 (find_package)
CMake Warning at /nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:801 (message):
New Boost version may have incorrect or missing dependencies and imported
targets
Call Stack (most recent call first):
/nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:907 (_Boost_COMPONENT_DEPENDENCIES)
/nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:1542 (_Boost_MISSING_DEPENDENCIES)
CMakeLists.txt:17 (find_package)
CMake Warning at /nix/store/hpbxdigild7y9rpvj4a6g8319g8d2z9c-cmake-3.10.2/share/cmake-3.10/Modules/FindBoost.cmake:1610 (message):
No header defined for python-py34; skipping header check
Call Stack (most recent call first):
CMakeLists.txt:17 (find_package)
CMake Error at CMakeLists.txt:23 (message):
Could not find boost::python3
-- Configuring incomplete, errors occurred!
See also "/build/source/build/CMakeFiles/CMakeOutput.log".
builder for '/nix/store/99zfwl007nwiqyh5l9g5j8l78jx30fdd-antimony-0.9.3.drv' failed with exit code 1
error: build of '/nix/store/99zfwl007nwiqyh5l9g5j8l78jx30fdd-antimony-0.9.3.drv' failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment