Skip to content

Instantly share code, notes, and snippets.

Avatar
:shipit:
Hello World

Blaine Schanfeldt blaines

:shipit:
Hello World
View GitHub Profile
@Kimtaro
Kimtaro / gist:1779371
Created Feb 9, 2012
Installing the wordnet gem on OSX, as of February 9 2012
View gist:1779371

Getting the wordnet gem, version 0.0.5, working is a little tricky at the moment. It's being rewritten but isn't released yet and the dbd gem is in a similar state.

These steps got it working for me on OS X Lion and MRI 1.8.7. On 1.9.2 convertdb.rb segfaults.

WordNet

Download WordNet from http://wordnet.princeton.edu/wordnet/download/current-version/

$ ./configure
View 00-INSTALL
IMPORTANT: this is outdated, go to https://github.com/netroy/Lockets
"npm install socket-io" & you are ready to go