Create a gist now

Instantly share code, notes, and snippets.

What would you like to do?
Maya 2017 Installation on Ubuntu 16.04
#!/bin/bash
#Make sure we’re running with root permissions.
if [ `whoami` != root ]; then
echo Please run this script using sudo
echo Just type “sudo !!
exit
fi
#Check for 64-bit arch
if [uname -m != x86_64]; then
echo Maya will only run on 64-bit linux.
echo Please install the 64-bit ubuntu and try again.
exit
fi
## Create Download Directory
mkdir -p maya2017Install
cd maya2017Install
## Download Maya Install Files
wget http://edutrial.autodesk.com/NET17SWDLD/2017/MAYA/ESD/Autodesk_Maya_2017_EN_JP_ZH_Linux_64bit.tgz
tar xvf Autodesk_Maya_2017_EN_JP_ZH_Linux_64bit.tgz
## Install Dependencies
apt-get install -y libssl1.0.0
apt-get install -y gcc
apt-get install -y libssl-dev
apt-get install -y libjpeg62
apt-get install -y alien
apt-get install -y csh
apt-get install -y tcsh
apt-get install -y libaudiofile-dev
apt-get install -y libglw1-mesa
apt-get install -y elfutils
apt-get install -y libglw1-mesa-dev
apt-get install -y mesa-utils
apt-get install -y xfstt
apt-get install -y ttf-liberation
apt-get install -y xfonts-100dpi
apt-get install -y xfonts-75dpi
apt-get install -y ttf-mscorefonts-installer
apt-get install -y libfam0
apt-get install -y libfam-dev
apt-get install -y libgstreamer-plugins-base0.10-0
wget http://launchpadlibrarian.net/183708483/libxp6_1.0.2-2_amd64.deb
## Install Maya
alien -cv *.rpm
dpkg -i *.deb
echo "int main (void) {return 0;}" > mayainstall.c
gcc mayainstall.c
mv /usr/bin/rpm /usr/bin/rpm_backup
cp a.out /usr/bin/rpm
chmod +x ./setup
./setup
rm /usr/bin/rpm
mv /usr/bin/rpm_backup /usr/bin/rpm
## Fix Startup Errors
ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.5.2.4 /usr/lib/libtiff.so.3
ln -s /usr/lib/x86_64-linux-gnu/libssl.so /usr/autodesk/maya2017/lib/libssl.so.10
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so /usr/autodesk/maya2017/lib/libcrypto.so.10
mkdir -p /usr/tmp
chmod 777 /usr/tmp
mkdir -p ~/maya/2017/
chmod 777 ~/maya/2017/
## Fix Segmentation Fault Error
echo "MAYA_DISABLE_CIP=1" >> ~/maya/2017/Maya.env
## Fix Color Managment Errors
echo "LC_ALL=C" >> ~/maya/2017/Maya.env
chmod 777 ~/maya/2017/Maya.env
## Maya Camera Modifier Key
gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"
## Ensure that Fonts are Loaded
xset +fp /usr/share/fonts/X11/100dpi/
xset +fp /usr/share/fonts/X11/75dpi/
xset fp rehash
echo Maya was installed successfully.
Owner

borgfriend commented Sep 5, 2016

Quick installation:

wget https://gist.githubusercontent.com/borgfriend/b83467639cb8039dc79974bf780a4994/raw/fdb608b9ab0c02c4a9237b54ab98d680ef608b11/maya2017install.sh
sudo chmod +x maya2017install.sh
sudo ./maya2017install.sh

Warning: Do not run the script as su, this will change the home directory and messes up the script.

Post Install:

Display Drivers

Nvidia: Ensure that the proprietary drivers are enabled (Software & Updates > Additional Drivers)

Start Maya

Run Maya by simply typing maya or via the Application Launcher.

Important: DO NOT: run maya as root or with sudo, if you initially launch maya with sudo something with the initial setup goes wrong and maya usually crashes when starting from the Application Launcher.

Remove Installation Files

The install files are not removed by the script. This avoids the issue of re-downloading the files if the script crashes. (Remove line 21-22 from the script)

If the script should crash, please post a comment in which line it caused the issue and (if possible) which steps helped that you did not run into the issue again.

Uninstall Maya

sudo apt remove adlm*
sudo apt remove maya2017-64

Known Issues:

Intel GPU: Color Management Error

Problem: Maya starts and still throws an Color Management Error
Solution: ?

Minkiu commented Sep 25, 2016

Hello borgfriend,

thank you very much again for this script, I managed to get Maya 2017 without a problem, I did face the "Segmentation fault" problem though, so I just removed the actual install part from your script an ran it from line 38, where the fixes are, and it worked smoothly.

Thanks again.

schlegel11 commented Oct 1, 2016

Thanks for this awesome script.
Anyway I got or better get some errors.
I had to create the usr/tmp dir manually (or you can do it via "mkdir /usr/tmp" in the script).
After I started maya I got the "Color management" error (no difference with "LC_ALL=C" in Maya.env so I think it's the intel gpu)
I also got some " Failed trying to load font : --helvetica-bold-r-normal--11-----*-iso8859-1 " errors.
I'm on Linux Mint 18 cinnamon.
Anyway maya is still running ;)

rudolfwalter commented Oct 17, 2016

The architecture checking part is incorrect (a space is needed inside the brackets). Also, at least on my system, /usr/tmp does not exist, so a chmod on it cannot possibly succeed (I just symlinked /tmp).

Also, take a look at my fork for a simple way to avoid having to use gcc or change things in /usr/bin.

StefanReinhardt commented Nov 4, 2016

Thank you for this awesome script.
Nonetheless i had some small issues with the maya startup. (IMHO depending on VP2.0)
Maya couldn't find the correct libGL.so from my nvidia drivers. (I have a GTX960) In my case it could be fixed with
sudo ln -s /usr/lib/nvidia-361/libGL.so /usr/autodesk/maya2017/lib/
Just for the record, if someone is running into the similar problems.

I have also some other startuperrors which only pop up but do not yet have any influence.

root : ERROR : code for hash md5 was not found.
Traceback (most recent call last):
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type md5
root : ERROR : code for hash sha1 was not found.
Traceback (most recent call last):
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha1
root : ERROR : code for hash sha224 was not found.
Traceback (most recent call last):
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha224
root : ERROR : code for hash sha256 was not found.
Traceback (most recent call last):
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha256
root : ERROR : code for hash sha384 was not found.
Traceback (most recent call last):
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha384
root : ERROR : code for hash sha512 was not found.
Traceback (most recent call last):
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha512

Maybe someone knows what the issue is here? (I have already checked my libssl and openssl packages. They are correctly installed and on the newest version)

Thanks to StefanReinhardt, I have the same graphic card and the same issues with VP2.0 for a long time and never had found a solution. In my case in Debian (testing) the fix is (as root):
ln -s /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1 /usr/autodesk/maya2017/lib/libGL.so

The other errors can be fixed changing _hashlib.so in /usr/autodesk/maya2017/lib/python2.7/lib-dynload. There is an alternative for ubuntu in /usr/autodesk/maya2017/support/python/2.7.11 and a README file with instructions, but that not worked for me. Instead I used the file from the system python 2.7. As root:
cd /usr/autodesk/maya2017/lib/python2.7/lib-dynload
mv _hashlib.so rhel_hashlib.so
cp -v /usr/lib/python2.7/lib-dynload/_hashlib.x86_64-linux-gnu.so _hashlib.so
chmod o+r _hashlib.so

I also had another minor error in the ScriptEditor about libaudiofile.so fixed with (as root):
ln -s /usr/lib/libaudiofile.so.0 /usr/autodesk/maya2017/lib/libaudiofile.so

Thank you so much for this script! For some reason the fonts did not get activated even though they are included in your dependencies, which results in Maya spamming the log about missing fonts. May I recommend that you add these lines after installation of dependencies to make sure that they are loaded when Maya runs for the first time?

xset +fp /usr/share/fonts/X11/100dpi/
xset +fp /usr/share/fonts/X11/75dpi/
xset fp rehash

Also please add a warning to users not to run as "sudo su". Superuser gets a different home folder for ~ which results in some folders being referenced wrong. This breaks some of the steps in your script.

Thanks again for this! It helped immensely.

Owner

borgfriend commented Jan 6, 2017

@rudolfwalter: Thanks for the suggestion. I will not change my script, since using gcc ensures that it will also work on other variants of Ubuntu (like Elementary)

@borgfriend Thanks a lot sharing this script!
I run into problems very soon though. Right when it converts the rpm's into deb's it just gets stuck at one point. I ran it several times and waited up to an hour for it to continue. It is converting the Maya2017_64-2017.0-1720.x86_64.rpm. Here is where it gets stuck:

chown 0:0 Maya2017_64-2017.0//var/opt/Autodesk/Adlm/Maya2017
chmod 755 Maya2017_64-2017.0//var/opt/Autodesk/Adlm/Maya2017
chown 0:0 Maya2017_64-2017.0//var/opt/Autodesk/Adlm/Maya2017/MayaConfig.pit
chmod 755 Maya2017_64-2017.0//var/opt/Autodesk/Adlm/Maya2017/MayaConfig.pit
mkdir Maya2017_64-2017.0/debian
hostname
date -R
hostname
date -R
chmod 755 Maya2017_64-2017.0/debian/rules
debian/rules binary 2>&1

Does anyone maybe have a clue what could be going on?

Owner

borgfriend commented Jan 28, 2017

The alien command usually takes a very long time to execute. It will directly open the Maya install after that, you need to finish inputting the information in the dialog so that the script can continue

Thanks, the commands worked perfectly on Ubuntu MATE 16.04!

Got my Maya up and running, but I'm having a problem with Krakatoa MY not refreshing PRTLoader particles according to timeline. I need to perform some kind of action with the object (select/unselect/change value) to render particles on according frame in viewport. Any ideas, please? :(

scorpes commented Mar 2, 2017

My Maya 2017 crashes when I hit the
playblast option box in an empty scene, this happens only in Ubuntu 16.
Anyone else having this issue?

scorpes commented Mar 8, 2017

When starting maya 2017, do you have this as well?

Warning: The port 'readLiquidCache::liquid' does not have a type.
Warning: The port 'readLiquidCache::solids' does not have a type.
Warning: The node definition 'Bifrost::Nodes::Object::readObjectFromCacheUsingName' could not be resolved for node 'readLiquidCache::readObjectFromCacheUsingName1'.
Warning: The node definition 'Bifrost::Nodes::Object::readObjectFromCacheUsingName' could not be resolved for node 'readLiquidCache::readObjectFromCacheUsingName2'.
Warning: The node definition 'Bifrost::Nodes::Misc::createFilepath' could not be resolved for node 'readLiquidCache::createPath1'.
Warning: The node definition 'Bifrost::Nodes::Misc::createFilepath' could not be resolved for node 'readLiquidCache::createPath2'.
Warning: The node definition 'Bifrost::Nodes::Misc::concatString' could not be resolved for node 'readLiquidCache::concatString1'.
Warning: The node definition 'Bifrost::Nodes::Misc::concatString' could not be resolved for node 'readLiquidCache::concatString2'.
Warning: One or more parameters are invalid in the connection involving 'readObjectFromCacheUsingName1.object' and '.liquid' (source port not found on node).
Warning: One or more parameters are invalid in the connection involving 'readObjectFromCacheUsingName2.object' and '.solids' (source port not found on node).
Warning: One or more parameters are invalid in the connection involving '.path' and 'concatString1.str' (target port not found on node).
Warning: One or more parameters are invalid in the connection involving '.path' and 'concatString2.str' (target port not found on node).
Warning: One or more parameters are invalid in the connection involving 'concatString1.value' and 'createPath1.str' (source port not found on node).
Warning: One or more parameters are invalid in the connection involving 'concatString2.value' and 'createPath2.str' (source port not found on node).
Warning: One or more parameters are invalid in the connection involving 'createPath1.value' and 'readObjectFromCacheUsingName1.cachePath' (source port not found on node).
Warning: One or more parameters are invalid in the connection involving 'createPath2.value' and 'readObjectFromCacheUsingName2.cachePath' (source port not found on node).
Warning: The port 'str2' could not be found in compound 'readLiquidCache'.
Warning: The port 'str2' could not be found in compound 'readLiquidCache'.
Warning: The port 'reuseTarget' could not be found in compound 'readLiquidCache'.
Warning: The port 'reuseTarget' could not be found in compound 'readLiquidCache'.
Warning: The node definition 'Bifrost::Nodes::_private::fetchObject' could not be resolved for node 'createBaseObject::fetchObject'.
Warning: One or more parameters are invalid in the connection involving 'fetchObject.object' and 'clearPropertyValues.object' (source port not found on node).
Warning: One or more parameters are invalid in the connection involving '.name' and 'fetchObject.name' (target port not found on node).

I'm having trouble running this on a fresh Ubuntu-16.04 - it worked great on 14.04. I"m getting this error after install, when I'm trying to start maya.

Error: found cl_khr_gl_sharing but failed to get function pointersaddSelectTypeItem: (kFailure): Unexpected Internal Failure
registerSubSceneOverrideCreator: (kInvalidParameter): Cannot find item of required type
Failed to register Initialize Maya Modify menu. Cannot add Convert Primitives to Polygons menu item.

Any ideas??

sgvfx commented Apr 13, 2017

Hello! I've installed Maya 2017 on Ubuntu 16.04 and have a problem. Maya crash when I try startup. Somebody know how to fix this problem?

Fixed it problem: sudo ln -s /usr/lib/nvidia-375/libGL.so /usr/autodesk/maya2017/lib/

root : ERROR : code for hash md5 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type md5
root : ERROR : code for hash sha1 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha1
root : ERROR : code for hash sha224 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha224
root : ERROR : code for hash sha256 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha256
root : ERROR : code for hash sha384 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha384
root : ERROR : code for hash sha512 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha512
Graphic device does not support OpenGL Core Profile, fallback to OpenGL renderer.
Stack trace:
/usr/autodesk/maya2017/lib/libOGSDeviceOGL-16.so(+0x43309) [0x7f65facd7309]
/usr/autodesk/maya2017/lib/libOGSDeviceOGL-16.so(+0x38e1a) [0x7f65faccce1a]
/usr/autodesk/maya2017/lib/libOGSDeviceOGL-16.so(+0x2453d) [0x7f65facb853d]
OGS::Devices::Sys::CreateVirtualDevice(OGS::Devices::ACreationParameters*)
CreateOGSDevice(OGS::Devices::ACreationParameters*)
OGSRenderer::initializeOGSDevice(OGS::Objects::UString*, int)
OGSMayaRenderer::initialize(OGSRenderer::DeviceAPI, int, void*, void*, void*, bool)
OGSMayaBridge::CreateOGSRenderer()
OGSMayaBaseRenderer::initialize()
OGSViewportRenderer::initialize()
OGSMayaBridge::Create3DViewportRenderer()
/usr/autodesk/maya2017/bin/maya.bin() [0x417d9b]
Tapplication::start()
/usr/autodesk/maya2017/bin/maya.bin() [0x40ee50]
main
__libc_start_main
/usr/autodesk/maya2017/bin/maya.bin() [0x40e6ed]

faj2007 commented Apr 14, 2017

you can try 'sudo maya' in the terminal, although they don't recommend to do this, i did it and maya do work.

I am Windows User and i want to shift From Windows to Linux and i'm a 3D artist can anyone help me please.
is it a good idea to shift?
what will be the system requirements for Autodesk -Maya 2017 For Linux-OS System ?

Hi,
i have installed maya 2017 ,i cannot activate student license ( serial number and product key ) got from autodesk only. Please guide me to activate maya2017.
Error : Activation request does not match license type
Your activation request does not match the license type (stand-alone or network).

Thank you very much!
It worked for me.

Now I am fighting with the installation of Motion Builder.
Anybody know on the similar script for it?

Alfriadox commented Jun 16, 2017

I tried to use this to install Maya 2016, and have been getting this error whenever I try to start maya:

Stack trace:
  /lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7f043213a4b0]
  OGS::Devices::GL3FunctionTable::populate()
  OGS::Devices::GL3Context::PopulateFunctionTable(OGS::Devices::ACreationParameters const*)
  OGS::Devices::VirtualDeviceGL3::CreateDevice(OGS::Devices::ACreationParameters const*)
  OGS::Devices::Sys::CreateVirtualDevice(OGS::Devices::ACreationParameters*)
  OGSRenderer::initializeOGSDevice(OGS::Objects::UString*, int)
  OGSMayaRenderer::initialize(OGSRenderer::DeviceAPI, int, void*, void*, void*, bool)
  OGSMayaBridge::CreateOGSRenderer()
  OGSMayaBaseRenderer::initialize()
  OGSViewportRenderer::initialize()
  OGSMayaBridge::Create3DViewportRenderer()
  /usr/autodesk/maya2016/bin/maya.bin() [0x41704b]
  Tapplication::start()
  /usr/autodesk/maya2016/bin/maya.bin() [0x40e6ff]
  main
  __libc_start_main
  /usr/autodesk/maya2016/bin/maya.bin() [0x40debd]

Fatal Error. Attempting to save in /usr/tmp/antonia.20170616.0921.ma
Writing crash report in /usr/tmp/antonia.20170616.0921.crash

could this have been because i used sudo su instead of sudo? and or because i changed the commands to match the 2016 version i was installing?

kuliraj commented Jun 17, 2017

Worked for me, thanks!
Had some issue at first with runing Maya w/o sudo. Fixed with chmod 777 /usr/tmp

I tried to install Maya 2017 student on linux mint 18.2. When I run 'maya' in terminal, I get this error:
/usr/autodesk/maya2017/bin/maya.bin: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory
any solution?
Thanks

urbanintell commented Jul 10, 2017

I get this error, but it still goes on to say it was installed successfully. I am doing this in am Ubuntu Docker image btw

Errors were encountered while processing:
libxp6:amd64
mv: cannot stat '/usr/bin/rpm': No such file or directory
./setup: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
mv: cannot stat '/usr/bin/rpm_backup': No such file or directory
ln: failed to create symbolic link '/usr/autodesk/maya2017/lib/libssl.so.10': No such file or directory
ln: failed to create symbolic link '/usr/autodesk/maya2017/lib/libcrypto.so.10': No such file or directory

caroline-lin commented Jul 26, 2017

Bless you for this script! I got Maya 2017 running smoothly with it on x86_64 Ubuntu 16.04 LTS using the student licence.

EDIT: Of all things, Maya is having trouble loading Helvetica fonts...
// Error: file: /usr/autodesk/maya2017/scripts/startup/initHUD.mel line 433: Failed trying to load font : --helvetica-bold-r-normal--11-----*-iso8859-1

I tried to install Maya 2017 student on linux mint 18.2. When I run this command " sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so /usr/autodesk/maya2017/lib/libssl.so.10 " in terminal, I get this error:
ln: failed to create symbolic link '/usr/autodesk/maya2017/lib/libssl.so.10': No such file or directory
any solution?
Thanks

rubenwardy commented Sep 30, 2017

@sabarishwar

ln -s /usr/lib/x86_64-linux-gnu/libssl.so /usr/lib/x86_64-linux-gnu/libssl.so.10

you may also need

ln -s /usr/lib/x86_64-linux-gnu/libtiff.so /usr/lib/x86_64-linux-gnu/libtiff.so.3
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so /usr/lib/x86_64-linux-gnu/libcrypto.so.10

I modified the script to work with Ubuntu 17.04, and also explained it and added debugging info: https://blog.rubenwardy.com/2017/09/30/install-autodesk-maya-ubuntu-17-04/
You're welcome to take my changes back

i get the following error upon opening maya
// Error: line 86: Cannot find procedure "buildDefaultHotBoxMenu". //

// Error: file: /usr/autodesk/maya/scripts/muscle/cMuscle.mel line 505: menu: Object 'mainRigDeformationsMenu' not found. //

// AbcExport v1.0 using Alembic 1.5.8 (built Dec 24 2015 17:39:02)

// AbcImport v1.0 using Alembic 1.5.8 (built Dec 24 2015 17:39:02)

// Error: file: /usr/autodesk/maya/scripts/others/addSelectTypeItem.mel line 101: Cannot find procedure "updateSelectTypeItemState". //

// Error: file: /usr/autodesk/maya/scripts/startup/autoLoadPlugin.mel line 32: initializePlugin function failed (gpuCache) //

// Error: line 1: initializePlugin function failed (gpuCache) //

// Error: file: /usr/autodesk/maya/scripts/startup/ModObjectsMenu.mel line 55: setParent: Object 'mainModifyMenu' not found. //

// Error: Failed to register Initialize Maya Modify menu. Cannot add Convert Primitives to Polygons menu item. //

// Error: line 1: Cannot find procedure "nodeEdRefreshVnnNodeTreeListers". //

pymel.core : Updating pymel with pre-loaded plugins: mayaHIK, CloudImportExport, tiffFloatReader, bifrostvisplugin, ikSpringSolver, ik2Bsolver, xgenToolkit, AbcExport, retargeterNodes, OpenEXRLoader, lookdevKit, Unfold3D, Type, mayaCharacterization, modelingToolkit, rotateHelper, MayaMuscle, matrixNodes, AbcImport, autoLoader, sceneAssembly, Substance, OneClick, shaderFXPlugin, bifrostshellnode, renderSetup, ArubaTessellator, quatNodes, fbxmaya

// Error: file: /usr/autodesk/maya/plug-ins/xgen/scripts/muAddShelfButton.mel line 118: Object '' not found. //

// Error: file: /usr/autodesk/maya/plug-ins/bifrost/scripts/mw_loadui.mel line 28: setParent: Object '' not found. //

// Error: file: /usr/autodesk/maya/plug-ins/MASH/scripts/MASHCreateUI.mel line 88: setParent: Object '' not found. //
any solutions

magdesign commented Oct 28, 2017

Thanks for this script.
It works perfect on Ubuntu 16.04 LTS
But somehow not on 17.10
When trying to start Maya, I am getting this odd

Segmentation fault (core dumped)

message and nothing else happens. Also tried with updating the symlinks to: ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.5.2.6 /usr/lib/libtiff.so.3
as well as making a symlink to the graphics driver as I did on 16.04 LTS: sudo ln -s /usr/lib/nvidia-384/libGL.so /usr/autodesk/maya2017/libGL.so

Thanks for any help installing on a fresh and clean Ubuntu 17.10

ramirezrubio commented Nov 9, 2017

I have the same problem that @magdesign has on ubuntu 17.10
-> Segmentation fault (core dumped)
Waiting for an update.
Thank you for you work

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment