Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
# Apple Macbook Pro M1-Pro (16-inch, 2021)
# MacOS Monterey 12.1
# nvm 0.39.1 (installed via brew)
# node v14.7.1
# yarn 1.22.17
scaffold-eth % yarn install --force
yarn install v1.22.17
[1/4] 🔍 Resolving packages...
[2/4] 🚚 Fetching packages...
warning Pattern ["@apollo/client@latest"] is trying to unpack in the same destination "/Users/chad/Library/Caches/Yarn/v6/npm-@apollo-client-3.3.21-2862baa4e1ced8c5e89ebe6fc52877fc64a726aa-integrity/node_modules/@apollo/client" as pattern ["@apollo/client@^3.3.21"]. This could result in non-deterministic behavior, skipping.
[3/4] 🔗 Linking dependencies...
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > @nomiclabs/hardhat-waffle@2.0.1" has incorrect peer dependency "@nomiclabs/hardhat-ethers@^2.0.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > hardhat-deploy@0.9.0" has unmet peer dependency "@ethersproject/hardware-wallets@^5.0.14".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > eslint-config-airbnb@18.2.1" has unmet peer dependency "eslint-plugin-import@^2.22.1".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > eslint-config-airbnb@18.2.1" has unmet peer dependency "eslint-plugin-jsx-a11y@^6.4.1".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > eslint-config-airbnb@18.2.1" has unmet peer dependency "eslint-plugin-react@^7.21.5".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > eslint-config-airbnb@18.2.1" has unmet peer dependency "eslint-plugin-react-hooks@^4 || ^3 || ^2.3.0 || ^1.7.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > eslint-plugin-prettier@3.4.0" has unmet peer dependency "prettier@>=1.13.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > @testing-library/user-event@12.8.3" has incorrect peer dependency "@testing-library/dom@>=7.21.4".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > @uniswap/sdk@3.0.3" has unmet peer dependency "@ethersproject/address@^5.0.0-beta".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > @uniswap/sdk@3.0.3" has unmet peer dependency "@ethersproject/contracts@^5.0.0-beta".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > @uniswap/sdk@3.0.3" has unmet peer dependency "@ethersproject/networks@^5.0.0-beta".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > @uniswap/sdk@3.0.3" has unmet peer dependency "@ethersproject/providers@^5.0.0-beta".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > @uniswap/sdk@3.0.3" has unmet peer dependency "@ethersproject/solidity@^5.0.0-beta".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > arb-ts@0.0.18" has incorrect peer dependency "ethers@~5.0.24".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > graphiql@1.4.7" has incorrect peer dependency "graphql@>= v14.5.0 <= 15.5.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > react-qr-reader@2.2.1" has incorrect peer dependency "react@~16".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > react-qr-reader@2.2.1" has incorrect peer dependency "react-dom@~16".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > eslint-config-prettier@8.3.0" has unmet peer dependency "eslint@>=7.0.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > eslint-plugin-prettier@4.0.0" has unmet peer dependency "eslint@>=7.28.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > hardhat-gas-reporter > eth-gas-reporter@0.2.22" has unmet peer dependency "@codechecks/client@^0.1.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > eslint-config-airbnb > eslint-config-airbnb-base@14.2.1" has unmet peer dependency "eslint-plugin-import@^2.22.1".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > eth-hooks > observable-hooks@4.0.5" has unmet peer dependency "rxjs@>=6.0.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > web3modal > styled-components@5.3.0" has unmet peer dependency "react-is@>= 16.8.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.21.0" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > walletlink > eth-block-tracker > @babel/plugin-transform-runtime@7.14.5" has unmet peer dependency "@babel/core@^7.0.0-0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/hardhat > ethereum-waffle > @ethereum-waffle/compiler > typechain > ts-essentials@6.0.7" has unmet peer dependency "typescript@>=3.7.0".
warning "workspace-aggregator-8e59eae3-a1ae-4a22-8133-ae7917519578 > @scaffold-eth/react-app > graphiql > codemirror-graphql > graphql-language-service-parser > graphql-language-service-types@1.8.2" has incorrect peer dependency "graphql@>= v14.5.0 <= 15.5.0".
[4/4] 🔨 Rebuilding all packages...
[12/23] ⠐ web3
[10/23] ⠐ keccak
[8/23] ⠐ keccak
[11/23] ⠐ fsevents
[9/23] ⠐ secp256k1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment