Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
package.json for Building a JS Development Environment on Pluralsight
{
"name": "javascript-development-environment",
"version": "1.0.0",
"description": "JavaScript development environment Pluralsight course by Cory House",
"scripts": {
},
"author": "Cory House",
"license": "MIT",
"dependencies": {
"whatwg-fetch": "1.0.0"
},
"devDependencies": {
"babel-cli": "6.16.0",
"babel-core": "6.17.0",
"babel-loader": "6.2.5",
"babel-preset-latest": "6.16.0",
"babel-register": "6.16.3",
"chai": "3.5.0",
"chalk": "1.1.3",
"cheerio": "0.22.0",
"compression": "1.6.2",
"cross-env": "3.1.3",
"css-loader": "0.25.0",
"eslint": "3.8.1",
"eslint-plugin-import": "2.0.1",
"eslint-watch": "2.1.14",
"express": "4.14.0",
"extract-text-webpack-plugin": "1.0.1",
"html-webpack-plugin": "2.22.0",
"jsdom": "9.8.0",
"json-schema-faker": "0.3.6",
"json-server": "0.8.22",
"localtunnel": "1.8.1",
"mocha": "3.1.2",
"nock": "8.1.0",
"npm-run-all": "3.1.1",
"nsp": "2.6.2",
"numeral": "1.5.3",
"open": "0.0.5",
"rimraf": "2.5.4",
"style-loader": "0.13.1",
"surge": "0.20.4",
"webpack": "1.13.2",
"webpack-dev-middleware": "1.8.4",
"webpack-hot-middleware": "2.13.0",
"webpack-md5-hash": "0.0.5"
}
}
@mcneilt
Copy link

mcneilt commented Nov 7, 2018

I receive an error when trying to use open.
open('http://localhost:' + port);
TypeError: Cannot read property 'replace' of undefined
at escape (C:\Temp\MyJavascript\pluralsight-js-dev-env\node_modules\open\lib\open.js:62:12)

@gagneet
Copy link

gagneet commented Dec 20, 2018

Great tutorial on Pluralsight and an equally good package.json.
Have updated with the latest package versions at the end of the year 2018:

{
  "repository": {
    "type": "git",
    "url": "git://github.com/user/javascript-development-environment.git"
  },
  "name": "javascript-development-environment",
  "version": "1.0.1",
  "description": "JavaScript development environment packages for use to build a Node.js project, obtained from: https://www.npmjs.com/search?q=",
  "scripts": {},
  "author": "Cory House",
  "license": "MIT",
  "dependencies": {
    "whatwg-fetch": "^3.0.0"
  },
  "devDependencies": {
    "babel-cli": "^6.26.0",
    "babel-core": "^6.26.3",
    "@babel/core": "^7.2.2",
    "babel-loader": "^8.0.4",
    "babel-preset-env": "^1.7.0",
    "babel-register": "^6.26.0",
    "chai": "^4.2.0",
    "chalk": "^2.4.1",
    "cheerio": "^1.0.0-rc.2",
    "compression": "^1.7.3",
    "cross-env": "^5.2.0",
    "css-loader": "^2.0.1",
    "eslint": "^5.10.0",
    "eslint-plugin-import": "^2.14.0",
    "eslint-watch": "^4.0.2",
    "express": "^4.16.4",
    "jsdom": "^13.1.0",
    "json-schema-faker": "^0.5.0-rc16",
    "json-server": "^0.14.0",
    "localtunnel": "^1.9.1",
    "lodash": "^4.17.11",
    "mocha": "^5.2.0",
    "nock": "^10.0.4",
    "npm-run-all": "^4.1.5",
    "nsp": "^3.2.1",
    "numeral": "^2.0.6",
    "open": "0.0.5",
    "rimraf": "^2.6.2",
    "style-loader": "^0.23.1",
    "webpack": "^4.28.0",
    "extract-text-webpack-plugin": "^3.0.2",
    "webpack-dev-middleware": "^3.4.0",
    "webpack-hot-middleware": "^2.24.3",
    "webpack-md5-hash": "0.0.6"
  },
  "comments": {
    "babel-preset-latest": "deprecated and babel-preset-env replaced",
    "nsp": "deprecated, no alternate package, nsp built-in npm@6"
  }
}

Have moved some of the packages to accommodate the package dependencies.
Have still kept NSP, even though it is deprecated. You can remove it.

@gagneet
Copy link

gagneet commented Dec 20, 2018

The above packages output will be the following warnings:

PS C:\nodejs-demo> npm install

> jsonpath@1.0.0 postinstall C:\nodejs-demo\node_modules\jsonpath
> node lib/aesprim.js > generated/aesprim-browser.js

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

added 1099 packages from 1002 contributors and audited 11870 packages in 94.459s
found 2 vulnerabilities (1 low, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details

There is no workaround if you wish to use Open. Hence, you can ignore it, or just use it and ensure you do not make the code error:

PS C:\nodejs-demo> npm audit

                       === npm audit security report ===


                                 Manual Review
             Some vulnerabilities require your attention to resolve

          Visit https://go.npm.me/audit-guide for additional guidance


  Critical        Command Injection

  Package         open

  Patched in      No patch available

  Dependency of   open [dev]

  Path            open

  More info       https://nodesecurity.io/advisories/663


  Low             Prototype Pollution

  Package         lodash

  Patched in      >=4.17.5

  Dependency of   nsp [dev]

  Path            nsp > cli-table2 > lodash

  More info       https://nodesecurity.io/advisories/577

found 2 vulnerabilities (1 low, 1 critical) in 11870 scanned packages
  2 vulnerabilities require manual review. See the full report for details.

@Dauli
Copy link

Dauli commented Mar 31, 2019

Best course sir. Thank you!

@wptechprodigy
Copy link

wptechprodigy commented Jun 24, 2019

Thanks Cory for the content. And gagneet thanks for the update.

@echelonnought
Copy link

echelonnought commented Jun 25, 2019

So smooth, thanks, sir. I literally followed through quite well with this while going through your course.

@DanSam5K
Copy link

DanSam5K commented Jun 25, 2019

@kelvinotundoKE
Copy link

kelvinotundoKE commented Jun 26, 2019

I.m going through this course. Running the npm install command returns several deprecated warnings. Any help?

@coryhouse
Copy link
Author

coryhouse commented Jun 26, 2019

You can ignore the deprecation warnings to assure you can follow along with me using the versions I used. Once you're done with the course, you can upgrade the packages. I show how to here.

@echelonnought
Copy link

echelonnought commented Jun 27, 2019

@coryhouse
Copy link
Author

coryhouse commented Jun 27, 2019

For support please post on the Pluralsight course discussion board.

@opeeny
Copy link

opeeny commented Jun 28, 2019

where can i get the most updated package.json file

@coryhouse
Copy link
Author

coryhouse commented Jun 28, 2019

You need to use this file with these versions to follow along with the course.

@phavor
Copy link

phavor commented Jun 29, 2019

They are currently breaking @coryhouse. For example when I run node buildScripts/srcServer.js it throws an error saying sendFile is not a function

@coryhouse
Copy link
Author

coryhouse commented Jun 29, 2019

For support please post on the Pluralsight course discussion board.

@samuelmwangimbuthia
Copy link

samuelmwangimbuthia commented Jul 5, 2019

Please assist, i am getting this error when i try to install npm packages
PS C:\Users\de\pluralsight-js-dev-env> npm install
npm : The term 'npm' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the
name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • npm install
  •   + CategoryInfo          : ObjectNotFound: (npm:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException
    

@coryhouse
Copy link
Author

coryhouse commented Jul 5, 2019

Please post on the course discussion for support. That said, you need to install Node, and npm will be installed as well when you do.

@thehcker
Copy link

thehcker commented Jul 9, 2019

Thanks for that @cory.

@mirzai67
Copy link

mirzai67 commented Jul 12, 2019

Thank you Cory. Really appreciate it

@Toheeb
Copy link

Toheeb commented Jul 19, 2019

For anyone who encountered Parsing errors, run
npm cache verify
before
npm install.

This worked for me.

@Dollypee
Copy link

Dollypee commented Jul 25, 2019

Thanks for this @coryhouse

@konaken73
Copy link

konaken73 commented Aug 21, 2019

thanks @coryhouse

@UWEMAKAN
Copy link

UWEMAKAN commented Aug 27, 2019

Thank you @coryhouse, but I'm doing the course in 2019 using Node version 8 and version 10 many of the packages in the original package.json are deprecated, and also the ones I found in the 2018 version of the package.json. Could you help, please?

@coryhouse
Copy link
Author

coryhouse commented Aug 27, 2019

@UWEMAKAN - Please post on the course discussion on Pluralsight for support. That said, more info here: coryhouse/javascript-development-environment#33

@ayeahgodlove
Copy link

ayeahgodlove commented Aug 27, 2019

So far the course has been great until i got errors when doing npm install.
I'm taking this course in 2019 using nodejs v10.16.0 and many of these package.json are depreciated.
Whats the solution ? i'm a beginnner

@coryhouse
Copy link
Author

coryhouse commented Aug 27, 2019

Please post on the course discussion on Pluralsight for support. That said, more info here: coryhouse/javascript-development-environment#33

@Alhaji-trujillo
Copy link

Alhaji-trujillo commented Sep 5, 2019

@coryhouse the VS Code terminal keep saying "deprecated" for all whenever I run the npm install. I am using the 12.10.0 node.js. I will be glad if you can provide a solution to this here.

Thanks
Cheers

@coryhouse
Copy link
Author

coryhouse commented Sep 5, 2019

@AlhajiTrujillo - Please post on the course discussion on Pluralsight for support. That said, more info here: coryhouse/javascript-development-environment#33

@Alhaji-trujillo
Copy link

Alhaji-trujillo commented Sep 17, 2019

@jaypshah5591 have you tried installing the npm

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment