Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Volition build failing on Heroku
! Warning: Multiple default buildpacks reported the ability to handle this app. The first buildpack in the list below will be used.
Detected buildpacks: Ruby,Node.js
See https://devcenter.heroku.com/articles/buildpacks#buildpack-detect-order
-----> Ruby app detected
-----> Compiling Ruby/Rails
-----> Using Ruby version: ruby-2.4.0
-----> Installing dependencies using bundler 1.15.2
Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
Your Gemfile lists the gem premailer-rails (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.15.4). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
Fetching gem metadata from https://rubygems.org/.......
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Fetching https://github.com/google/google-id-token.git
Fetching https://github.com/payolapayments/payola.git
Fetching rake 12.3.0
Fetching concurrent-ruby 1.0.5
Fetching minitest 5.11.3
Installing rake 12.3.0
Installing minitest 5.11.3
Installing concurrent-ruby 1.0.5
Fetching thread_safe 0.3.6
Fetching builder 3.2.3
Installing thread_safe 0.3.6
Installing builder 3.2.3
Fetching erubi 1.7.0
Fetching mini_portile2 2.3.0
Installing erubi 1.7.0
Installing mini_portile2 2.3.0
Fetching crass 1.0.3
Fetching rack 2.0.4
Installing crass 1.0.3
Fetching nio4r 2.2.0
Installing rack 2.0.4
Installing nio4r 2.2.0 with native extensions
Fetching websocket-extensions 0.1.3
Installing websocket-extensions 0.1.3
Fetching mini_mime 1.0.0
Installing mini_mime 1.0.0
Fetching arel 8.0.0
Installing arel 8.0.0
Fetching public_suffix 3.0.1
Fetching ast 2.4.0
Installing public_suffix 3.0.1
Installing ast 2.4.0
Fetching execjs 2.7.0
Fetching ice_nine 0.11.2
Installing execjs 2.7.0
Installing ice_nine 0.11.2
Fetching babel-source 5.8.35
Fetching bcrypt 3.1.11
Installing bcrypt 3.1.11 with native extensions
Installing babel-source 5.8.35
Using bundler 1.15.2
Fetching choice 0.2.0
Installing choice 0.2.0
Fetching equalizer 0.0.11
Installing equalizer 0.0.11
Fetching connection_pool 2.2.1
Installing connection_pool 2.2.1
Fetching erubis 2.7.0
Installing erubis 2.7.0
Fetching multipart-post 2.0.0
Installing multipart-post 2.0.0
Fetching ffi 1.9.18
Installing ffi 1.9.18 with native extensions
Fetching path_expander 1.0.2
Installing path_expander 1.0.2
Fetching sexp_processor 4.10.0
Installing sexp_processor 4.10.0
Fetching flutie 2.0.0
Installing flutie 2.0.0
Fetching method_source 0.9.0
Installing method_source 0.9.0
Fetching thor 0.20.0
Installing thor 0.20.0
Fetching multi_json 1.13.1
Installing multi_json 1.13.1
Fetching jwt 2.1.0
Installing jwt 2.1.0
Fetching high_voltage 3.0.0
Installing high_voltage 3.0.0
Fetching htmlentities 4.3.4
Installing htmlentities 4.3.4
Fetching rb-fsevent 0.10.2
Installing rb-fsevent 0.10.2
Fetching ruby_dep 1.5.0
Installing ruby_dep 1.5.0
Fetching normalize-rails 3.0.3
Installing normalize-rails 3.0.3
Fetching pg 0.21.0
Installing pg 0.21.0 with native extensions
Fetching puma 3.11.2
Installing puma 3.11.2 with native extensions
Fetching rack-cors 1.0.2
Installing rack-cors 1.0.2
Fetching rack-timeout 0.4.2
Installing rack-timeout 0.4.2
Fetching ruby-graphviz 1.2.3
Installing ruby-graphviz 1.2.3
Fetching rails_serve_static_assets 0.0.5
Installing rails_serve_static_assets 0.0.5
Fetching rails_stdout_logging 0.0.5
Installing rails_stdout_logging 0.0.5
Fetching tilt 2.0.8
Installing tilt 2.0.8
Fetching redis 4.0.1
Installing redis 4.0.1
Fetching tty-which 0.3.0
Installing tty-which 0.3.0
Fetching turbolinks-source 5.1.0
Installing turbolinks-source 5.1.0
Fetching will_paginate 3.1.6
Installing will_paginate 3.1.6
Fetching rainbow 2.2.2
Installing rainbow 2.2.2 with native extensions
Fetching aasm 4.12.3
Installing aasm 4.12.3
Fetching i18n 0.9.3
Installing i18n 0.9.3
Fetching tzinfo 1.2.4
Installing tzinfo 1.2.4
Fetching descendants_tracker 0.0.4
Installing descendants_tracker 0.0.4
Fetching nokogiri 1.8.2
Installing nokogiri 1.8.2 with native extensions
Fetching websocket-driver 0.6.5
Installing websocket-driver 0.6.5 with native extensions
Fetching mail 2.7.0
Installing mail 2.7.0
Fetching rack-test 0.8.2
Installing rack-test 0.8.2
Fetching appsignal 2.4.3
Installing appsignal 2.4.3 with native extensions
Fetching request_store 1.4.0
Installing request_store 1.4.0
Fetching sprockets 3.7.1
Installing sprockets 3.7.1
Fetching rack-mini-profiler 0.10.7
Installing rack-mini-profiler 0.10.7
Fetching rack-protection 2.0.0
Installing rack-protection 2.0.0
Fetching addressable 2.5.2
Installing addressable 2.5.2
Fetching parser 2.4.0.2
Fetching autoprefixer-rails 7.2.5
Installing autoprefixer-rails 7.2.5
Installing parser 2.4.0.2
Fetching uglifier 4.1.5
Installing uglifier 4.1.5
Fetching babel-transpiler 0.7.0
Installing babel-transpiler 0.7.0
Fetching faraday 0.14.0
Fetching ruby_parser 3.10.1
Installing faraday 0.14.0
Installing ruby_parser 3.10.1
Using google-id-token 1.4.2 from https://github.com/google/google-id-token.git (at master@858acae)
Fetching rb-inotify 0.9.10
Installing rb-inotify 0.9.10
Fetching rails_12factor 0.0.3
Installing rails_12factor 0.0.3
Fetching redis-store 1.4.1
Installing redis-store 1.4.1
Fetching turbolinks 5.1.0
Installing turbolinks 5.1.0
Fetching activesupport 5.1.4
Installing activesupport 5.1.4
Fetching axiom-types 0.1.1
Installing axiom-types 0.1.1
Fetching coercible 1.0.0
Installing coercible 1.0.0
Fetching recipient_interceptor 0.1.2
Installing recipient_interceptor 0.1.2
Fetching loofah 2.1.1
Installing loofah 2.1.1
Fetching sidekiq 5.0.5
Installing sidekiq 5.0.5
Fetching css_parser 1.6.0
Installing css_parser 1.6.0
Fetching launchy 2.4.3
Installing launchy 2.4.3
Fetching sprockets-es6 0.9.2
Installing sprockets-es6 0.9.2
Fetching gibbon 3.2.0
Installing gibbon 3.2.0
Fetching stripe 3.9.1
Installing stripe 3.9.1
Fetching twilio-ruby 5.6.2
Installing twilio-ruby 5.6.2
Fetching flay 2.10.0
Fetching flog 4.6.1
Installing flay 2.10.0
Installing flog 4.6.1
Fetching listen 3.1.5
Fetching sass-listen 4.0.0
Installing listen 3.1.5
Installing sass-listen 4.0.0
Fetching redis-rack 2.0.4
Fetching rails-dom-testing 2.0.3
Installing redis-rack 2.0.4
Installing rails-dom-testing 2.0.3
Fetching globalid 0.4.1
Fetching activemodel 5.1.4
Installing globalid 0.4.1
Installing activemodel 5.1.4
Fetching enumerize 2.1.2
Installing enumerize 2.1.2
Fetching jbuilder 2.7.0
Fetching redis-activesupport 5.0.4
Installing redis-activesupport 5.0.4
Installing jbuilder 2.7.0
Fetching spring 2.0.2
Installing spring 2.0.2
Fetching virtus 1.0.5
Installing virtus 1.0.5
Fetching rails-html-sanitizer 1.0.3
Installing rails-html-sanitizer 1.0.3
Fetching premailer 1.11.1
Installing premailer 1.11.1
Fetching letter_opener 1.6.0
Fetching stripe_event 2.1.1
Fetching google_sign_in 0.1.4
Installing letter_opener 1.6.0
Installing google_sign_in 0.1.4
Installing stripe_event 2.1.1
Fetching sass 3.5.5
Fetching activejob 5.1.4
Installing activejob 5.1.4
Fetching activerecord 5.1.4
Fetching actionview 5.1.4
Installing sass 3.5.5
Installing actionview 5.1.4
Installing activerecord 5.1.4
Fetching codeclimate-engine-rb 0.4.1
Installing codeclimate-engine-rb 0.4.1
Fetching actionpack 5.1.4
Installing actionpack 5.1.4
Fetching reek 4.7.3
Fetching rails-erd 1.5.2
Installing rails-erd 1.5.2
Installing reek 4.7.3
Fetching actioncable 5.1.4
Fetching actionmailer 5.1.4
Installing actioncable 5.1.4
Installing actionmailer 5.1.4
Fetching railties 5.1.4
Fetching gon 6.2.0
Installing railties 5.1.4
Installing gon 6.2.0
Fetching sprockets-rails 3.2.1
Installing sprockets-rails 3.2.1
Fetching redis-actionpack 5.0.2
Installing redis-actionpack 5.0.2
Fetching premailer-rails 1.10.1
Installing premailer-rails 1.10.1
Fetching redis-rails 5.0.2
Fetching rubycritic 3.3.0
Installing redis-rails 5.0.2
Fetching font-awesome-rails 4.7.0.3
Fetching jquery-rails 4.3.1
Installing font-awesome-rails 4.7.0.3
Installing jquery-rails 4.3.1
Fetching rails 5.1.4
Fetching react-rails 2.2.0
Installing rails 5.1.4
Fetching sass-rails 5.0.7
Installing sass-rails 5.0.7
Using payola-payments 1.5.1 from https://github.com/payolapayments/payola.git (at master@08bd7bc)
Fetching title 0.0.7
Installing rubycritic 3.3.0
Installing title 0.0.7
Installing react-rails 2.2.0
Bundle complete! 61 Gemfile dependencies, 130 gems now installed.
Gems in the groups development and test were not installed.
Bundled gems are installed into ./vendor/bundle.
Post-install message from ruby-graphviz:
You need to install GraphViz (http://graphviz.org/) to use this Gem.
For more information about Ruby-Graphviz :
* Doc : http://rdoc.info/projects/glejeune/Ruby-Graphviz
* Sources : https://github.com/glejeune/Ruby-Graphviz
* Mailing List : https://groups.google.com/forum/#!forum/ruby-graphviz
Last (important) changes :
Ruby-Graphviz no longer supports Ruby < 1.9.3
Bundle completed (41.66s)
Cleaning up the bundler cache.
Your Gemfile lists the gem premailer-rails (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of one of them later.
Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.15.4). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
The latest bundler is 1.16.1, but you are currently running 1.15.2.
To update, run `gem install bundler`
-----> Installing node-v6.11.1-linux-x64
-----> Detecting rake tasks
-----> Preparing app for Rails asset pipeline
Running: rake assets:precompile
[2018-02-13T20:07:04 (process) #1697][INFO] appsignal: Loading Rails (5.1.4) integration
[2018-02-13T20:07:05 (process) #1697][ERROR] appsignal: Push api key not set after loading config
[2018-02-13T20:07:05 (process) #1697][ERROR] appsignal: Not starting, no valid config for this environment
I, [2018-02-13T20:07:06.140743 #1697] INFO -- : Writing /tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/public/assets/apple-icon-4d5e4b579ddfcfb5d876e140f2c0ecb67eabbe72c519fc000f6bf17b0d26395f.png
I, [2018-02-13T20:07:06.143899 #1697] INFO -- : Writing /tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/public/assets/dark-mosaic-0f6f0ed6c96f379c1cee89709cbf240aa4f02eaea0d993b2cf46cfd51b701f34.png
I, [2018-02-13T20:07:06.146398 #1697] INFO -- : Writing /tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/public/assets/favicon-4c33c2512d898b286ec37de31f54d74daf244a09c2918df315164834e6d1d1b8.png
I, [2018-02-13T20:07:06.148943 #1697] INFO -- : Writing /tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/public/assets/garrett-d74392f9cd8af80e6881b06c19200433b0b031fff0f88d09c154890ffcf889db.jpg
I, [2018-02-13T20:07:06.151501 #1697] INFO -- : Writing /tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/public/assets/logo-18b2643749090664df908478f10a002ba071f8736355ae7d55ef1f48c0c7da08.png
I, [2018-02-13T20:07:06.154286 #1697] INFO -- : Writing /tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/public/assets/paid-7034ec29ee1160965696a939031660b723b5860d8c8322bf52ddc3487f92fed0.png
rake aborted!
Uglifier::Error: Unexpected character '`'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/uglifier-4.1.5/lib/uglifier.rb:234:in `parse_result'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/uglifier-4.1.5/lib/uglifier.rb:216:in `run_uglifyjs'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/uglifier-4.1.5/lib/uglifier.rb:168:in `compile'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/uglifier_compressor.rb:53:in `call'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/uglifier_compressor.rb:28:in `call'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/processor_utils.rb:75:in `call_processor'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/processor_utils.rb:57:in `block in call_processors'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/processor_utils.rb:56:in `reverse_each'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/processor_utils.rb:56:in `call_processors'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/loader.rb:134:in `load_from_unloaded'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/loader.rb:60:in `block in load'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/loader.rb:317:in `fetch_asset_from_dependency_cache'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/loader.rb:44:in `load'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/cached_environment.rb:20:in `block in initialize'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/cached_environment.rb:47:in `load'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/base.rb:66:in `find_asset'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/base.rb:73:in `find_all_linked_assets'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/manifest.rb:142:in `block in find'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/legacy.rb:114:in `block (2 levels) in logical_paths'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/path_utils.rb:228:in `block in stat_tree'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/path_utils.rb:212:in `block in stat_directory'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/path_utils.rb:209:in `each'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/path_utils.rb:209:in `stat_directory'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/path_utils.rb:227:in `stat_tree'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/legacy.rb:105:in `each'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/legacy.rb:105:in `block in logical_paths'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/legacy.rb:104:in `each'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/legacy.rb:104:in `logical_paths'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/manifest.rb:140:in `find'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/sprockets/manifest.rb:185:in `compile'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:68:in `block (3 levels) in define'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/rake/sprocketstask.rb:147:in `with_logger'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:67:in `block (2 levels) in define'
/tmp/build_017564d1e163b2e487022e5d0d435063/usevolition-volition-d4204d4/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
Tasks: TOP => assets:precompile
(See full trace by running task with --trace)
!
! Precompiling assets failed.
!
! Push rejected, failed to compile Ruby app.
! Push failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment