Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
[root@8289b91813f1 /]# cat /etc/yum.repos.d/ruby22-fedora21.repo
[ruby22]
name=Ruby 2.2
baseurl=http://scientific.zcu.cz/repos/ruby22/fedora21-$basearch
enabled=1
gpgcheck=1
gpgkey=http://scientific.zcu.cz/repos/RPM-GPG-KEY-valtri2
[root@8289b91813f1 /]# yum install ruby
fedora/21/x86_64/metalink | 14 kB 00:00:00
fedora | 3.8 kB 00:00:00
ruby22 | 951 B 00:00:00
updates/21/x86_64/metalink | 17 kB 00:00:00
updates | 3.4 kB 00:00:00
updates-testing/21/x86_64/metalink | 11 kB 00:00:00
updates-testing | 4.9 kB 00:00:00
(1/5): fedora/21/x86_64/primary_db | 17 MB 00:00:01
(2/5): updates-testing/21/x86_64/group_gz | 406 kB 00:00:06
(3/5): updates/21/x86_64/primary_db | 1.2 kB 00:00:10
(4/5): fedora/21/x86_64/group_gz | 232 kB 00:00:11
updates-testing/21/x86_64/prim FAILED
http://mirrors.solfo.com/fedora/updates/testing/21/x86_64/repodata/2deced549f4faa7066e1f612c8da70205b530e4e5d4d6f75bbbcbf60f5d773de-primary.sqlite.bz2: [Errno 14] curl#6 - "Could not resolve host: mirrors.solfo.com"
Trying other mirror.
(5/5): updates-testing/21/x86_64/primary_db | 4.8 MB 00:00:01
(1/3): ruby22/x86_64/primary | 5.1 kB 00:00:00
(2/3): updates-testing/21/x86_64/updateinfo | 494 kB 00:00:00
(3/3): updates-testing/21/x86_64/pkgtags | 1.3 MB 00:00:00
ruby22 18/18
Resolving Dependencies
--> Running transaction check
---> Package ruby.x86_64 0:2.2.0-0.25.preview1.fc21 will be installed
--> Processing Dependency: ruby-libs(x86-64) = 2.2.0-0.25.preview1.fc21 for package: ruby-2.2.0-0.25.preview1.fc21.x86_64
--> Processing Dependency: rubygem(bigdecimal) >= 1.2.5 for package: ruby-2.2.0-0.25.preview1.fc21.x86_64
--> Processing Dependency: ruby(rubygems) >= 2.4.1 for package: ruby-2.2.0-0.25.preview1.fc21.x86_64
--> Processing Dependency: libruby.so.2.2()(64bit) for package: ruby-2.2.0-0.25.preview1.fc21.x86_64
--> Running transaction check
---> Package ruby-libs.x86_64 0:2.2.0-0.25.preview1.fc21 will be installed
---> Package rubygem-bigdecimal.x86_64 0:1.2.5-0.25.preview1.fc21 will be installed
---> Package rubygems.noarch 0:2.4.1-0.25.preview1.fc21 will be installed
--> Processing Dependency: rubygem(io-console) >= 0.4.2 for package: rubygems-2.4.1-0.25.preview1.fc21.noarch
--> Processing Dependency: rubygem(rdoc) >= 4.2.0.alpha for package: rubygems-2.4.1-0.25.preview1.fc21.noarch
--> Processing Dependency: rubygem(psych) >= 2.0.6 for package: rubygems-2.4.1-0.25.preview1.fc21.noarch
--> Processing Dependency: /usr/bin/ruby for package: rubygems-2.4.1-0.25.preview1.fc21.noarch
--> Running transaction check
---> Package rubygem-io-console.x86_64 0:0.4.2-23.fc21 will be installed
--> Processing Dependency: libruby.so.2.1()(64bit) for package: rubygem-io-console-0.4.2-23.fc21.x86_64
---> Package rubygem-psych.x86_64 0:2.0.6-0.25.preview1.fc21 will be installed
--> Processing Dependency: libyaml-0.so.2()(64bit) for package: rubygem-psych-2.0.6-0.25.preview1.fc21.x86_64
---> Package rubygem-rdoc.noarch 0:4.2.0.alpha-0.25.preview1.fc21 will be installed
--> Processing Dependency: ruby(irb) = 2.2.0 for package: rubygem-rdoc-4.2.0.alpha-0.25.preview1.fc21.noarch
--> Processing Dependency: rubygem(json) >= 1.8.1 for package: rubygem-rdoc-4.2.0.alpha-0.25.preview1.fc21.noarch
---> Package rubypick.noarch 0:1.1.1-2.fc21 will be installed
--> Running transaction check
---> Package libyaml.x86_64 0:0.1.6-5.fc21 will be installed
---> Package ruby-irb.noarch 0:2.2.0-0.25.preview1.fc21 will be installed
---> Package rubygem-io-console.x86_64 0:0.4.2-23.fc21 will be installed
--> Processing Dependency: libruby.so.2.1()(64bit) for package: rubygem-io-console-0.4.2-23.fc21.x86_64
---> Package rubygem-json.x86_64 0:1.8.1-23.fc21 will be installed
--> Processing Dependency: libruby.so.2.1()(64bit) for package: rubygem-json-1.8.1-23.fc21.x86_64
--> Finished Dependency Resolution
Error: Package: rubygem-io-console-0.4.2-23.fc21.x86_64 (fedora)
Requires: libruby.so.2.1()(64bit)
Available: ruby-libs-2.1.2-23.fc21.x86_64 (fedora)
libruby.so.2.1()(64bit)
Installing: ruby-libs-2.2.0-0.25.preview1.fc21.x86_64 (ruby22)
~libruby.so.2.2()(64bit)
Error: Package: rubygem-json-1.8.1-23.fc21.x86_64 (fedora)
Requires: libruby.so.2.1()(64bit)
Available: ruby-libs-2.1.2-23.fc21.x86_64 (fedora)
libruby.so.2.1()(64bit)
Installing: ruby-libs-2.2.0-0.25.preview1.fc21.x86_64 (ruby22)
~libruby.so.2.2()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.