Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
sudo apt-get install -y \
git \
g++ \
libgtk-3-dev \
gtk-doc-tools \
gnutls-bin \
valac \
intltool \
libtool \
libpcre2-dev \
libglib3.0-cil-dev \
libgnutls28-dev \
libgirepository1.0-dev \
libxml2-utils \
gperf
git clone --recursive https://github.com/thestinger/termite.git
git clone https://github.com/thestinger/vte-ng.git
echo export LIBRARY_PATH="/usr/include/gtk-3.0:$LIBRARY_PATH"
cd vte-ng && ./autogen.sh && make && sudo make install
cd ../termite && make && sudo make install
sudo ldconfig
sudo mkdir -p /lib/terminfo/x; sudo ln -s \
/usr/local/share/terminfo/x/xterm-termite \
/lib/terminfo/x/xterm-termite
sudo update-alternatives --install /usr/bin/x-terminal-emulator x-terminal-emulator /usr/local/bin/termite 60
@lightx

This comment has been minimized.

Copy link

@lightx lightx commented May 12, 2018

thanks for doing this, works like a charm!

@Mesayah

This comment has been minimized.

Copy link

@Mesayah Mesayah commented Jan 25, 2019

I needed to install libtool first due to an error during a build, so consider adding it to the apt command.

@martiliones

This comment has been minimized.

Copy link

@martiliones martiliones commented May 25, 2019

Thanks!

@abinashdash17

This comment has been minimized.

Copy link

@abinashdash17 abinashdash17 commented May 27, 2019

superb. I installed libtool as said by @Mesayah and didn't encountered any problem. Not sure whether it's required or not.

@crivotz

This comment has been minimized.

Copy link
Owner Author

@crivotz crivotz commented Jul 19, 2019

Thanks for hint! libtool added

@jhessin

This comment has been minimized.

Copy link

@jhessin jhessin commented Jul 28, 2019

When running this script on Debian 10 "Buster" I keep getting this error:

configure: error: Package requirements (glib-2.0 >= 2.40.0 gobject-2.0 pango >= 1.22.0 gtk+-3.0 >= 3.8.0 gobject-2.0 gio-2.0 gio-unix-2.0 zlib libpcre2-8 >= 10.21 gnutls >= 3.2.7) were not met:

No package 'gtk+-3.0' found
No package 'gnutls' found

And then the following:

Package gtk+-3.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-3.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-3.0' found
Package vte-2.91 was not found in the pkg-config search path.
Perhaps you should add the directory containing `vte-2.91.pc'
to the PKG_CONFIG_PATH environment variable
No package 'vte-2.91' found
Package gtk+-3.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-3.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-3.0' found
Package vte-2.91 was not found in the pkg-config search path.
Perhaps you should add the directory containing `vte-2.91.pc'
to the PKG_CONFIG_PATH environment variable
No package 'vte-2.91' found
g++ -std=c++11 -O3 -Wall -Wextra -pedantic -Winit-self -Wshadow -Wformat=2 -Wmissing-declarations -Wstrict-overflow=5 -Wcast-align -Wconversion -Wunused-macros -Wwrite-strings -DNDEBUG -D_POSIX_C_SOURCE=200809L -DTERMITE_VERSION=\"v15-5-g9565563\"   -Wno-missing-field-initializers -s -Wl,--as-needed  termite.cc  -o termite
termite.cc:32:21: fatal error: gtk/gtk.h: No such file or directory
compilation terminated.
make: *** [Makefile:39: termite] Error 1
@eirenicon

This comment has been minimized.

Copy link

@eirenicon eirenicon commented Jul 28, 2019

Does not work for me either... same reasons as above.

@crivotz

This comment has been minimized.

Copy link
Owner Author

@crivotz crivotz commented Jul 29, 2019

I was using the script for Stretch. With the upgrade to Buster everything worked and I didn't have to do it again.

I try to make a VM and see how to solve ;)

@jhamfler

This comment has been minimized.

Copy link

@jhamfler jhamfler commented Aug 7, 2019

I'm on Debian 9 and it works fine. Thank you btw.

@nullbyte61

This comment has been minimized.

Copy link

@nullbyte61 nullbyte61 commented Jan 12, 2020

Debian 10 working fine

@crivotz

This comment has been minimized.

Copy link
Owner Author

@crivotz crivotz commented Jan 13, 2020

Good! I've moved on to kitty but I'm glad it's still working properly.

@Beetix

This comment has been minimized.

Copy link

@Beetix Beetix commented Mar 3, 2020

I've been using these instructions on Debian 10. I had an issue with the VTE library causing a segfault on Termite when typing certain characters like "^". Was using the default branch, 0.50.2-ng, to compile vte-ng. Switching to branch 0.56.2-ng fixed the issue.

@tropis

This comment has been minimized.

Copy link

@tropis tropis commented Jul 18, 2020

  1. Compile error of app.vala (during make inside the termite directory): "struct Test.App.Options cannot be empty"
    There is a fix documented in GNOME/vte project to add a dummy param inside "public struct Options"
    GNOME/vte@53690d5

  2. There is also a runtime error: the default config file isn't installed. App configs are stored in a tree under ~/config
    Fix: Create directory, and copy the default config from the installation directory
    mkdir ~/.config/termite
    cp ~/termite/config ~/.config/termite/

Sparkylinux 2020.6 based on Debian testing Bullseye

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment