Instantly share code, notes, and snippets.

What would you like to do?
Installing Node.js for Linux & macOS with nvm

Installing Node.js with nvm to Linux & macOS

A quick guide on how to setup Node.js development environment.

Previous versions of these install instructions had been tested with:

Install nvm for managing Node.js versions

The reason for using nvm instead of other install types is mainly in how easy it is to have multiple versions of Node.js (if needed) without too much of extra complexity. Sometimes applications might require a certain version of Node.js to work, so having the flexibility of using specific versions can save a lot of time from you.

  1. Open new Terminal window.
  2. Run nvm installer
    • ...with either curl or wget.
      • curl -o- | bash
      • wget -qO- | bash
    • The script clones the nvm repository to ~/.nvm and adds the source line to your profile (~/.bash_profile, ~/.zshrc, ~/.profile, or ~/.bashrc). (You might want/need to add the source loading line by yourself, if the automated install tool does not add it for you.)
      export NVM_DIR="$HOME/.nvm"
      [ -s "$NVM_DIR/" ] && \. "$NVM_DIR/"  # This loads nvm
      [ -s "$NVM_DIR/bash_completion" ] && \. "$NVM_DIR/bash_completion"  # This loads nvm bash_completion
  3. If everything went well, you should now be able to reload the shell by running
    • source ~/.bashrc
    • (Another option is to open a new Terminal window/tab.)
  4. Verify installation
    • To verify that nvm has been installed, do: command -v nvm
  5. List what versions of Node are currently installed (probably none).
    • nvm ls
  6. Install latest Node.js LTS release (recommended for production usage).
    • nvm install v10.15.0
  7. Install Current Node.js release with latest features (for testing the future features of Node).
    • nvm install v11.6.0
  8. Set a default Node version for nvm (enabling you to actually use it in a new Terminal session windows).
    • nvm alias default v10.15.0 (when you work with production quality projects)
    • nvm alias default v11.6.0 (ONLY if you want to test the latest features of Node.js.)

It is also possible to select what Node.js version is used per project basis, by running nvm use v10.15.0 (or another version number) on the directory where the individual project is located. One way to do that is to create small Bash shell script for enabling the right environment when needed, so you would not have to remember what exact version was needed.

You can find a lot of packages from the npm website. Have a good time with the tools.

Upgrading from previous version of Node.js

If you already have previous version of Node.js installed with nvm, you can upgrade to a different version with these steps.

  • Open new Terminal window (to make sure you have latest Node.js version active in your command line environment).
  • Linking global packages from previous version (at this example, v8._._).
    • nvm reinstall-packages v10.14.1

Updating outdated packages

List what (top level) packages are installed globally

npm ls -g --depth=0.

List what packages are outdated

npm outdated -g --depth=0.

Update outdated globally installed npm packages

npm update -g

Fixing old package versions

After installation of Node v10.x (or similar), it can be a good idea to recompile old packages (that have compiled native extensions) to make sure that they work with the new version of Node. That can be done easily by going to a project’s root directory, and running npm rebuild:

npm rebuild

Deleting old Node.js versions

  • Look what versions are installed:
    • nvm ls
  • Delete an older version (if it is no longer used in some of your projects):
    • nvm uninstall v10.14.1

This comment has been minimized.

bliotti commented Oct 12, 2017

Thank You


This comment has been minimized.

llccing commented Oct 21, 2017

when installed nvm, must source ~/.bashrc, otherwise run "nvm ls", will alert ,common not defined


This comment has been minimized.


d2s commented Oct 24, 2017

@llccing Oh, I had forgotten to mention that part of the original installation,
since I have mostly used this as a reminder about upgrade steps. Thanks for mentioning. 👍


This comment has been minimized.

aksayps commented Nov 7, 2017

Thank You..!!


This comment has been minimized.


d2s commented Nov 15, 2017

Happy to see that people are finding these notes useful. 👍


This comment has been minimized.

jbenz commented Dec 28, 2017

Worked like a charm for Debian 9. Cheers.


This comment has been minimized.

Favna commented Jan 2, 2018

  1. If everything went well, open new Terminal window/tab.

Concerning this, for people who SSH'd into a device/raspberrypi/vps it is much easier to just to source ~/.bashrc to reload it than actually opening a new Terminal window/tab. This is probably worth mentioning in the guide.


This comment has been minimized.


d2s commented Jan 4, 2018

Updated the guide based on your feedback. Thanks for the tip. 👍


This comment has been minimized.

MarcusBliss commented Feb 26, 2018

  • [ ]

Yeah. it worked


This comment has been minimized.

larka06 commented Apr 28, 2018

thank you this is the only complete set of instructions on the whole internet. A BIG THANK YOU


This comment has been minimized.


d2s commented May 2, 2018

Good to see that these are useful to people. 👍


This comment has been minimized.

Sandhya-Bairi commented Jul 5, 2018



This comment has been minimized.

yar00001 commented Aug 10, 2018

Adding the nvm loading scrip to my .zshrc gives me this error:

~ λ source ~/.zshrc
nvm is not compatible with the npm config "prefix" option: currently set to "/local/home/username/.nvm/versions/node/v4.4.5"
Run `nvm use --delete-prefix v4.4.5 --silent` to unset it.

This comment has been minimized.

jonkeller commented Nov 1, 2018

Yarn doesn't seem to like the current LTS version:

yarn install v1.12.1
$ node build-system/check-package-manager.js
Detected node version v10.13.0 (latest LTS).
Detected gulp version 3.9.1.
Detected yarn version 1.12.1 (stable). Installing packages...
[1/5]   Validating package.json...
error amp-html@0.1.0: The engine "node" is incompatible with this module. Expected version "^8.0.0". Got "10.13.0"
error Found incompatible module

This comment has been minimized.


d2s commented Nov 16, 2018


Yarn doesn't seem to like the current LTS version

Not sure about Yarn, since I haven't been using it in a while.
You might want to install the latest Yarn release from GitHub.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment