Skip to content

Instantly share code, notes, and snippets.

Dan Horst danhorst

Block or report user

Report or block danhorst

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View _linked_editors.html.erb
<div class="control-group required link-users" id="editors">
<span class="control-label">
<label class="required" for="<%=f.object.class.to_s.downcase%>_editors_attributes_0_name">
<%# NOTE: Whenever you just copy the HTML generated by Simple Form it breaks internationalization %>
<%= I18n.t('simple_form.required.html', default: '<abbr title="" data-original-title="required">*</abbr>').html_safe %>
<%= I18n.t('sufia.work.editor.individual.name' %>
<span class="help-inline"><%= I18n.t('sufia.work.editor.individual.help' %></span>
</label>
</span>
<%# Rest of the file ... %>
@danhorst
danhorst / activate-required-field.html
Created Jun 23, 2014
Conditionally require a field
View activate-required-field.html
<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<title>Toggle field requirement</title>
<meta name="description" content="A clean-room implmentation of conditional field requirement.">
<meta name="viewport" content="width=device-width, initial-scale=1">
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
<script>
View danhorst.pp
class people::danhorst {
#####################################################
# non-App Store apps
#####################################################
include chrome
include github_for_mac
include macvim
include virtualbox
View jQuery_example.html
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html lang="en-gb">
<head>
<title>Library Guides Home Page</title>
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1">
<meta name="description" content="Library Guides Home Page">
<!-- The jQuery library is included via the Google AJAX Libraries API
http://code.google.com/apis/ajaxlibs/
But could be installed locally by downloading it from the jQuery website
http://jquery.com/
View CatalogPlus_Search.rb
#!/usr/bin/ruby
require 'cgi'
require 'rubygems'
require 'highline/import'
def uri_escape(string)
CGI.escape(string)
end
@danhorst
danhorst / blackligth installtion
Created Feb 22, 2010
blacklight installation
View blackligth installtion
When I first tried to install blacklight not everything went smoothly.
These instructions are based on the documentation provided here:
http://github.com/projectblacklight/blacklight/blob/master/doc/README_INSTALLATION.rdoc
Install the dependencies:
-------------------------
$ sudo gem install rails
$ sudo gem install test-unit --version=1.2.3
$ sudo gem install authlogic --version=2.1.2
$ sudo gem install marc --version=0.3.0
View README.textile
View Simple link checker
@danhorst
danhorst / form-baseline.css
Created Apr 15, 2011
Custom CSS for Google docs form
View form-baseline.css
/**
* Userstyle can be applied using the Stylish Firefox extension
* https://addons.mozilla.org/en-US/firefox/addon/stylish/
**/
@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("spreadsheets.google.com") {
/** Page structure styles **/
.ss-form-container, .ss-container {border:3px solid #666 !important; margin:50px 0 0 400px !important; -moz-border-radius: 5px; padding:1.5em 1.5em 0 !important; width:580px !important;}
.ss-resp-card{border:none !important;}
@danhorst
danhorst / gist:1207464
Created Sep 9, 2011
Looksee Gemspec for version 1.0.3
View gist:1207464
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{looksee}
s.version = "1.0.3"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["George Ogata"]
s.date = %q{2011-09-05 00:00:00.000000000Z}
s.email = ["george.ogata@gmail.com"]
You can’t perform that action at this time.