Skip to content

Instantly share code, notes, and snippets.

Dat Duong datduong

Block or report user

Report or block datduong

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
@datduong
datduong / note.md
Last active Jul 3, 2018
ErrorCudaTorchDockerMountCuda
View note.md

I use

$nvidia-docker run -e TERM=dumb -v /usr/local/cuda:/usr/local/cuda -i -t kaixhin/torch /bin/bash

and I was able to run luarocks install cutorch. But when testing the library, I get the error on cuda.

require 'cutorch'
THCudaCheck FAIL file=/tmp/luarocks_cutorch-scm-1-7401/cutorch/lib/THC/THCGeneral.c line=70 error=35 : CUDA driver version is insufficient for CUDA runtime version
@datduong
datduong / note.md
Last active Jul 2, 2018
ErrorCudaTorchDocker
View note.md

To start a docker with torch, I use

nvidia-docker run -e TERM=dumb -i -t kaixhin/torch 

Running a main script like main.lua gives error that cutorch is not found. Below is partial error message shown

Training a SPEN on the Data using tag_cmd.sh
tag_cmd.sh: 5: [: 0: unexpected operator
-gradient_clip 1.0 -optim_method adam -evaluation_frequency 25 -save_frequency 25 -adam_epsilon 1e-8 -batches_per_epoch 100 -learning_rate_decay 0.0 -learning_rate 0.001 -num_epochs 30 -training_mode pretrain_unaries
You can’t perform that action at this time.