Skip to content

Instantly share code, notes, and snippets.

@dbwest
Created Mar 18, 2013
Embed
What would you like to do?
#in rails proj dir
$ bundle update
Resolving dependencies...
Using rake (0.9.6)
Using RedCloth (4.2.9)
Using i18n (0.6.4)
Using multi_json (1.3.7)
Using activesupport (3.2.8)
Using builder (3.0.4)
Using activemodel (3.2.8)
Using erubis (2.7.0)
Using journey (1.0.4)
...
Installing rmagick (2.12.2)
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
/Users/dev/.rvm/rubies/ruby-1.9.3-p392/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
extconf.rb:107: Use RbConfig instead of obsolete and deprecated Config.
checking for gcc-4.2... yes
checking for Magick-config... yes
checking for ImageMagick version >= 6.3.5... yes
checking for HDRI disabled version of ImageMagick... yes
checking for stdint.h... yes
checking for sys/types.h... yes
checking for wand/MagickWand.h... yes
checking for InitializeMagick() in -lMagickCore... no
checking for InitializeMagick() in -lMagick... no
Can't install RMagick 2.12.2. Can't find the ImageMagick library or one of the dependent libraries. Check the mkmf.log file for more detailed information.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.
Provided configuration options:
--with-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/Users/dev/.rvm/rubies/ruby-1.9.3-p392/bin/ruby
--with-MagickCorelib
--without-MagickCorelib
--with-Magicklib
--without-Magicklib
Gem files will remain installed in /Users/dev/.rvm/gems/ruby-1.9.3-p392@locomotive/gems/rmagick-2.12.2 for inspection.
Results logged to /Users/dev/.rvm/gems/ruby-1.9.3-p392@locomotive/gems/rmagick-2.12.2/ext/RMagick/gem_make.out
An error occurred while installing rmagick (2.12.2), and Bundler cannot
continue.
Make sure that `gem install rmagick -v '2.12.2'` succeeds before bundling.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment