Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
RPM SPEC for RabbitMQ plugins
Name : rabbitmq-server-plugins
Version : 2.6.1
Release : 2
Summary : Plugins for RabbitMQ server
Group : Development/Libraries
Source0 : http://www.rabbitmq.com/releases/plugins/v%{version}/amqp_client-%{version}.ez
Source1 : http://www.rabbitmq.com/releases/plugins/v%{version}/rabbitmq_stomp-%{version}.ez
Source2 : http://www.rabbitmq.com/releases/plugins/v%{version}/rabbitmq_management_agent-%{version}.ez
Source3 : http://www.rabbitmq.com/releases/plugins/v%{version}/rabbitmq_management-%{version}.jquery-fix.ez
Source4 : http://www.rabbitmq.com/releases/plugins/v%{version}/rabbitmq_mochiweb-%{version}.ez
Source5 : http://www.rabbitmq.com/releases/plugins/v%{version}/mochiweb-1.3-rmq%{version}-git9a53dbd.ez
Source6 : http://www.rabbitmq.com/releases/plugins/v%{version}/webmachine-1.7.0-rmq%{version}-hg0c4b60a.ez
Source7 : http://www.rabbitmq.com/releases/plugins/v%{version}/rabbitmq_federation-%{version}.ez
Source8 : http://www.rabbitmq.com/releases/plugins/v%{version}/rabbitmq_management_visualiser-%{version}.ez
URL : http://www.rabbitmq.com/plugins.html
Vendor : RabbitMQ
License : MPLv1.1
Packager : Dan Carley <dan.carley@gmail.com>
BuildArch : noarch
BuildRoot : %{_tmppath}/%{name}-%{version}-root
Requires : rabbitmq-server = %{version}
Requires : erlang >= R13B
%description
Plugins for RabbitMQ server.
%package amqp_client
Summary : Native Erlang AMQP client for RabbitMQ
Group : Development/Libraries
Requires : rabbitmq-server = %{version}
Requires : erlang >= R13B
%description amqp_client
RabbitMQ plugin for native Erlang message passing to a broker. Dependency of
some other plugins.
%package rabbitmq_stomp
Summary : STOMP plugin for RabbitMQ
Group : Development/Libraries
Requires : rabbitmq-server = %{version}
Requires : rabbitmq-server-plugins-amqp_client = %{version}
Requires : erlang >= R13B
Obsoletes : rabbitmq-server-plugins-rabbit_stomp
%description rabbitmq_stomp
RabbitMQ plugin for exposing AMQP functionality via the STOMP protocol.
%package rabbitmq_management_agent
Summary : Management agent for RabbitMQ cluster nodes
Group : Development/Libraries
Requires : rabbitmq-server = %{version}
Requires : erlang >= R13B
%description rabbitmq_management_agent
RabbitMQ plugin for managing cluster nodes. This must be installed on all
nodes in a cluster.
%package rabbitmq_management
Summary : Management/Monitoring API & UI for RabbitMQ
Group : Development/Libraries
Requires : rabbitmq-server = %{version}
Requires : rabbitmq-server-plugins-amqp_client = %{version}
Requires : rabbitmq-server-plugins-rabbitmq_management_agent = %{version}
Requires : erlang >= R13B
%description rabbitmq_management
RabbitMQ plugin for managing/monitoring the installation via HTTP.
%package rabbitmq_federation
Summary : Scalable messaging plugin for RabbitMQ
Group : Development/Libraries
Requires : rabbitmq-server = %{version}
Requires : rabbitmq-server-plugins-amqp_client = %{version}
Requires : erlang >= R13B
%description rabbitmq_federation
RabbitMQ plugin for scalable messaging across WANs and administrative domains.
%package rabbitmq_management_visualiser
Summary : Broker topology visualiser plugin for RabbitMQ
Group : Development/Libraries
Requires : rabbitmq-server = %{version}
Requires : rabbitmq-server-plugins-rabbitmq_management = %{version}
Requires : erlang >= R13B
%description rabbitmq_management_visualiser
RabbitMQ plugin for visualising broker topology showing links between channels,
queues and exchanges.
%define plugindir /usr/lib/rabbitmq/lib/rabbitmq_server-%{version}/plugins
%prep
%setup -c -T
%install
rm -rf %{buildroot}
install -d -m 755 %{buildroot}%{plugindir}
cp %{SOURCE0} %{buildroot}%{plugindir}
cp %{SOURCE1} %{buildroot}%{plugindir}
cp %{SOURCE2} %{buildroot}%{plugindir}
cp %{SOURCE3} %{buildroot}%{plugindir}/rabbitmq_management-%{version}.ez
cp %{SOURCE4} %{buildroot}%{plugindir}
cp %{SOURCE5} %{buildroot}%{plugindir}/mochiweb-%{version}.ez
cp %{SOURCE6} %{buildroot}%{plugindir}/webmachine-%{version}.ez
cp %{SOURCE7} %{buildroot}%{plugindir}
cp %{SOURCE8} %{buildroot}%{plugindir}
%clean
rm -rf %{buildroot}
%files amqp_client
%defattr(-,root,root)
%{plugindir}/amqp_client-%{version}.ez
%files rabbitmq_stomp
%defattr(-,root,root)
%{plugindir}/rabbitmq_stomp-%{version}.ez
%files rabbitmq_management_agent
%defattr(-,root,root)
%{plugindir}/rabbitmq_management_agent-%{version}.ez
%files rabbitmq_management
%defattr(-,root,root)
%{plugindir}/mochiweb-%{version}.ez
%{plugindir}/rabbitmq_management-%{version}.ez
%{plugindir}/rabbitmq_mochiweb-%{version}.ez
%{plugindir}/webmachine-%{version}.ez
%files rabbitmq_federation
%defattr(-,root,root)
%{plugindir}/rabbitmq_federation-%{version}.ez
%files rabbitmq_management_visualiser
%defattr(-,root,root)
%{plugindir}/rabbitmq_management_visualiser-%{version}.ez
%changelog
* Tue Jul 10 2012 Dan Carley <dan.carley@gmail.com> 2.6.1-2
- Plugins require mochiweb from Erlang R13B and later.
* Sun Oct 02 2011 Matt Dainty <matt@bodgit-n-scarper.com> 2.6.1-1
- Update to 2.6.1.
- Add the federation & visualiser plugins.
* Sun Aug 14 2011 Matt Dainty <matt@bodgit-n-scarper.com> 2.5.1-1
- Update to 2.5.1.
- Rename rabbit_stomp to rabbitmq_stomp to match upstream.
- Add the management plugins, tidying up the filenames as we go.
* Tue May 3 2011 Dan Carley <dan.carley@gmail.com> 2.2.0-1
- Bundle amqp_client and rabbit_stomp binary plugins.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.