Skip to content

Instantly share code, notes, and snippets.

@ddoomm
ddoomm / Node-gyp compiling with xcode 10+ and osx 10.7+.md
Last active May 17, 2019
Node-gyp compiling with xcode 10+ and osx 10.7+
View Node-gyp compiling with xcode 10+ and osx 10.7+.md

Node-gyp compiling with xcode 10+ and osx 10.7+

The problem

On OSX 10.7+ and xcode 10+ I'm not able to install some project dependencies using npm.

NODE and NODE-GYP versions:

dom:~workspace/my_project$ nvm use 0.10.36
Now using node v0.10.36 (npm v2.15.1)
dom:~workspace/my_project$ node-gyp -v
You can’t perform that action at this time.