Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
# install brew
ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew tap homebrew/versions
brew update
brew upgrade
# this will install 2 versions of Python
brew install python # 2.7: python, pip
brew install python3 # 3.5: python3, pip3
# python 2.7
# =============
python
# if you see this in your shell, let's move on
# Python 2.7.11 (default, Jan 22 2016, 08:29:18)
# [GCC 4.2.1 Compatible Apple LLVM 7.0.2 (clang-700.1.81)] on darwin
# Type "help", "copyright", "credits" or "license" for more information.
# view the list of installed packages
pip list
# install what you need
pip install ipython
pip install jupyter
pip install scikit-learn
pip install scikit-image
pip install numpy matplotlib
pip install sklearn
pip install scipy
# update packages that were already installed
pip install pandas --upgrade
# python 3.5
# =============
python3
# if you see this in your shell, let's move on
# Python 3.5.1 (default, Jan 22 2016, 08:54:32)
# [GCC 4.2.1 Compatible Apple LLVM 7.0.2 (clang-700.1.81)] on darwin
# Type "help", "copyright", "credits" or "license" for more information.
# view the list of installed packages
pip3 list
# install what you need
pip3 install ipython
pip3 install jupyter
pip3 install scikit-learn
pip3 install scikit-image
pip3 install numpy matplotlib
pip3 install sklearn
pip3 install scipy
# update packages that were already installed
pip3 install pandas --upgrade
# finally
brew cleanup
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.